Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Can not add additional Nest Wifi Router to my MEsh network

Community Member

I have tried to add my second NEst Wifi Router to my Mesh network for 3 days now, I have tried all the solutions stated here in the forum. Those are


1. Reinstallilng the Home App

2. Resessting the network including restarting it

3. Tried 3 different devices to add it through

4. Tried to add it with a Lan CAble from the original Nest Router


It is even so bad that if I remove my current WiFi Nest router (Which is working perfectly) and just try to set up a new network with the new NEST Wifi router I bought it does not work. If I go back and then try to set up a new network with my old NEST wifi Router it works.


Somehow this new NEst Wifi  Router has decided that it does not want to play with me. Any suggestion on what I should do?



Platinum Product Expert
Platinum Product Expert

Do you run double NAT? That's not recommended and can cause strange problems.

Here is some general advice if you're having problems with adding additional units to the network.

The general set up guidance walk you through how to add additional units:

If you're using an iOS or iPadOS for the setup, see the following:

For whatever device you use for setup (iOS, iPadOS or Android), make sure any VPN are disabled, and that Wi-Fi and Bluetooth are enabled. Also make sure to use the latest version of the Google Home app.

Some other tips that can help:
• Place the unit you're trying to add close to the primary unit during the setup process. When setup is done and unit has updated itself and rebooted, unplug its' power and move it where you want it.
• If the additional unit also has ethernet ports, try to connect its' WAN port to the primary/main/master unit's LAN port with an ethernet cable during setup.
• IPv6 has caused trouble in the past when adding additional units. Try to disable IPv6 in the Google Home app -> WiFi (icon) -> Network settings -> Advanced networking. Keep it disabled until unit is added. Enable IPv6 again if you need it.
• If the unit you're trying to add isn't brand new, make sure it's factory reset ( ) and ready for setup.
• Try the setup process from a different iOS, iPadOS or Amdroid unit. Make sure to use the same Google account inside the Google Home app.

Be aware that Nest Wifi units are made for different countries/regions in order to comply with Wi-Fi regulations (frequencies, channels and signal strength). Mixing units made for different regions are not supported. The Google Home app should warn you if that's the case, but it doesn't always do that.

I don't work for Google.

Community Specialist
Community Specialist

Hello everyone, 

Thanks @olavrb for your assistance.

@Rejje, I'm checking in to see if you've tried the recommendations above. I'd be glad to hear from you, so please tell me if you are still having issues.


Community Specialist
Community Specialist

Hi there Rejje,

I know it has been a while, but I wanted to ensure that everything is covered on your end. Please inform me if you still need a helping hand.


Community Specialist
Community Specialist

Hey there Rejje,

It's me again. I'll be locking this thread in the next 24 hours. If you have new issues, updates or discussion topics, feel free to start a new thread here in the Community.