Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Issues with Nest WiFi Router & Mesh Points

Community Member


I'll do my best to keep this as short and to the point as possible.

I have the Nest WiFi Router & 2 speaker mesh points for my home network that i purchased in early 2020. I have Comcast Xfinity for my Internet provider (up to 400 Mbps).

I started having "Connected. Limited Internet/No Internet" messages. I'd power cycle both my cable modem and router, and my devices would connect properly again only for a while. I've had to do this multiple times in a day. So frustrating!

Anyway, after some research, i came to determine the following and what i've done:

- I had a 10 year old Motorola 6200 (???) cable modem and was DOCSIS 3.0 (D3.0). I understand i should not have had this for so long. My ignorance.

- I replaced the cable modem 2 days ago from Best Buy with a Netgear CM700, D3.0, since i only have up to 400mbps, this is sufficient i thought. Everything worked great for 2 days and then it started doing the same thing again.

- Went back to another Best Buy, explained the situation again, and the rep knew that Comcast updated to DOCSIS 3.1, and would not support D3.0 anymore. My new cable modem was still D3.0. So he recommended an Arris SB8200, D3.1 cable modem. So i purchased this Arris D3.1 and returned the Netgear D3.0.

- After installing the D3.1 cable modem, everything was working fine for most of the day. This evening, some of my devices will not connect to the WiFi. My smart TV won't connect, my kids gaming consoles won't connect, but our phones are connected to the WiFi, my laptop is, and our smart speakers are.

- So now the router still has Internet and only some devices connected to it but the mesh points went offline.

I contacted Google support on 3/4 before i even changed out my 10 year old cable modem. They escalated to senior support and were supposed to get back to me within 48 hours. I had to reach out again March 9, 3 days after they were supposed to get back to me. They tried getting me to do the same things all over again (factory reset, power cycle, blah blah) but i explained we tried all that already. Again, would escalate to senior support and this time get back to me in 24 hours. Here we are 72+ hours later and still mi response.

So i believe the cable modem issue is resolved. I have a new modern that supports Xfinity's D3.1 requirement. But i continue to experience WiFi issues.

Is it fair to say that my Nest WiFi Router and 2 mesh points are broken? Should I purchase a new router? I find it hard to believe that a product that came out in 2019 is not functional anymore! I've done some research about upgrading to the Nest WiFi pero m Pro 6e but from what I've gathered, it works be pointless for my families use. We don't have any 6G devices so the performance would be pretty much identical. Plus, the speakers on the mesh points are used quite often by my family so it'd be a shame not to have that functionally anymore. I'll change them if we have to for reliable WiFi connectivity most importantly.

I work from home, my kids are gamers, as am I, we only stream shows/movies, computers, phones, all for a family of 5. We need this resolved, especially for my sanity!

I hope someone here can help. Thank you so much.


Community Member

I'm now having similiar issues to you. I have Fiber but only do a 50/50 plan. It was just installed a couple of months ago so I'm pretty confident that is all up to date on hardware.


I use my Google Nest Wifi as the router and that's ok with the ISP. It's been working great up until the last week or two.


I've been having some issues with all of my Google Home devices having a hard time understanding which speaker should respond. I figured that was more Google Hardware issues and tried a few things, but just became much more deliberant with how I was speaking to a particular device.

I also seemed to be having some issues with slow responses on my work computer but figured that was likely something going on with that computer itself.

But in the last week or so I've had to start rebooting my home network multiple times a day to get my full speeds from my ISP. It was stick at just 1-3Mb and fail most various speed tests, including the one on the Google Nest WiFi itself.

From more reading some of the google home device issues seem to be a result of poor response rates. I tested that with a few pings to various websites this morning and noticed really long delays. I rebooted the equipment again and everything works as normal.

From some research I think Google either has some hardware starting to fail, or a bad firmware update that was pushed out at some point. Definitely isn't going well and I'm now starting to think I'm going to need to get a new router but am not excited about that.

As an update I was able to get support from somebody at Google directly and they had me fill out the DNS addresses of the IP6 DNS locations even though I had IP6 shut off in the router as I wasn't using it. That seems to have cleared up the issues for now. I still occasionally have a dip in speeds, but they seem to be pretty infrequent and very short lived so they could be any number of issues other than the Google Wifi causing those.


I can't explain why putting in the IP6 addresses for DNS did anything unless it's perhaps related to some bug in a firmware update as I haven't had those entered since I got the system a year or two ago and it was working fine up until a few weeks ago. But seems to be resolved for now.

Community Specialist
Community Specialist

Hey kent7854, 

Awesome — glad to hear that your issue is fixed. It looks like we can consider this one complete, so I will lock the thread shortly unless I can help out with anything else. 


Community Member

Switch to a non Google system.  This is ongoing and they do not care in the least.  I had trouble for a long time and as you said they wanted me to do same steps over and over and never got back to me.  It is a known issue and tons of people are having the same issue.

Community Specialist
Community Specialist

Hey folks,


@mrBearToe, I’m sorry to hear you’re having this issue. You mentioned that you are already in contact with our Google support. Could you provide the case ID number of your interaction? I’d like to check on your case.

@RachelGomez123, thanks for the help.

@kent7854, a few questions: are you using a modem/router combo from your Internet Service Provider (ISP)? How many devices are dropping from the network? Also, do you have any paused devices? 


Give these steps a try:


  • If you're using a modem/router combo, set that to bridge mode to avoid double NAT issues.
  • Make sure that there is minimal to no interference (concrete, bulletproof glass, metal, mirror, etc.) and the points are no more than two rooms apart.
  • Remove any special characters in your network name and password.
  • Turn off IPv6.
  • Change your DNS server into on the primary and on the secondary server. Hit the save/ floppy disk icon on the upper right. You may skip this step if you’ve done it already.
  • Unplug the power from your Google Wifi devices for 2 minutes. You can skip this step if you’ve done it already
  • If the issue persists, try factory resetting your network. Take note that this will delete all network data.

Let us know how it goes.

@cltimbes, we're sad to see you go. If ever you change your mind, we're here to help.


Community Specialist
Community Specialist

Hi everyone,

Checking back in should you still have some questions here. Let us know by replying to this thread. 


Community Specialist
Community Specialist

Hello again folks,

I'm just checking in to make sure that you've seen our response. Please let us know if you have any other questions or concerns as I will be locking this in 24 hours.