Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Wifi has internet with full speeds, but wifi test fails

Community Member

I've been running speed tests through downloadable phone app and getting less than 1 mbps when my network is running slow. I also run speed tests on the router for hardline connection, but get the full speeds of my subscription plan with my provider. I also have a strong mesh connection and great range with an additional nest mesh access point extender. My firmware is up to date and i regularly check daily. I use maybe less than ten devices on the network at a time, which a few include basic security cameras (which one is a google camera). I have ran ( wifi speed tests on several devices and still get kbps speeds when the network is having issues. I am fairly new to the Google nest wifi system, but had no issue setting up my network. I am previously familiar with the Google home system and user ability is very easy for me to navigate all features in the google home app. I'm not understanding why multiple times a day at frequent daily occurances this happens. My nest mesh router is not set to any complicated advanced settings. Everything is set to standard plug and play wpa2 settings. Which security an DHCP should not have an affect on speeds eitherway.


I tried all of this, my apartment isn't even 800sqft. When i press restart from the home app. Routers don't come back online. Only thing that works is to unplug power cycle the devices.

Community Specialist
Community Specialist

Hey folks,

@EvokeWzdm, thanks for posting — let's see what's going on.


A few questions: are you using a modem/router combo from your Internet Service Provider (ISP)? How many devices are dropping from the network? Also, do you have any paused devices?


Give these steps a try:

  • If you're using a modem/router combo, set that to bridge mode to avoid double NAT issues.
  • Make sure that there is minimal to no interference (concrete, bulletproof glass, metal, mirror, etc.) and the points are no more than two rooms apart.
  • Remove any special characters in your network name and password.
  • Turn off IPv6.
  • Change your DNS server into on the primary and on the secondary server. Hit the save/ floppy disk icon on the upper right.
  • Unplug the power from your Google Wifi devices for 2 minutes.
  • If the issue persists, try factory resetting your network. Take note that this will delete all network data.
  • You may skip any step if you’ve done them already.

Let us know how it goes.

Thanks for the help here, @MikeClark.


Community Specialist
Community Specialist

Hello EvokeWzdm,

Checking back in should you still have some questions here. Let us know by replying to this thread. 


Community Specialist
Community Specialist

Hey everyone,

We haven't heard from you in a while so we'll be locking this thread if there is no update within 24 hours. If you have any new issues, updates or just a discussion topic, feel free to start a new thread in the Community.