Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

One wired point is not seen by end devices

Community Member

In my network I have a main router to which are connected two wireless points and a wired connection to a switch with two wired routers connected to the switch. In the Home app all the points seem connected with Great Connection. But end devices, such as my Pixel 7, do not see both point routers, only one of them.
I tried disconnecting the point that is seen, and still the other is not seen. I also tried to remove the one that is seen and connect the one that is not seen to the same ethernet connection, but it is still not seen.



Community Member


It sounds like you have a mesh network set up using Nest Wifi devices, and you're experiencing some issues with device connectivity. Here are some steps that you can try to troubleshoot this issue:

  1. Check your Nest Wifi network status in the Google Home app: Open the Google Home app, tap on your Nest Wifi network, and check the status of your devices. Ensure that all devices are showing as "Connected".

  2. Restart your Nest Wifi devices: Sometimes, restarting your Nest Wifi devices can help resolve connectivity issues. You can try unplugging your Nest Wifi devices, waiting for a few seconds, and then plugging them back in.

  3. Check the location of your Nest Wifi devices: Ensure that your Nest Wifi devices are placed in central locations in your home, and that they are not obstructed by walls or other objects. If your devices are too far apart, you may experience connectivity issues.

  4. Check the Wi-Fi channels: If your Nest Wifi devices are using the same Wi-Fi channel as other nearby devices, this could cause interference and connectivity issues. You can try changing the Wi-Fi channel in the Google Home app to improve connectivity.

  5. Reset your Nest Wifi devices: If none of the above steps work, you can try resetting your Nest Wifi devices to their factory settings. You can do this by holding down the reset button on the back of the device for about 10 seconds.

If you're still experiencing issues with device connectivity, you can try contacting Google support for further assistance. They should be able to help you troubleshoot the issue and find a solution.


Thanks, I did all that to no avail. If I could get help from the support I wouldn't post the problem here. 

Community Specialist
Community Specialist

Hey everyone,


@Gooyster, thanks for posting — let's see what's going on.


A few questions: are you using a modem/router combo from your Internet Service Provider (ISP)? Also, do you have any paused devices?


Give these steps a try:


  • If you're using a modem/router combo, set that to bridge mode to avoid double NAT issues.
  • Make sure that there is minimal to no interference (concrete, bulletproof glass, metal, mirror, etc.) and the points are no more than two rooms apart.
  • Remove any special characters in your network name and password.
  • Turn off IPv6.
  • Change your DNS server into on the primary and on the secondary server. Hit the save/ floppy disk icon on the upper right.

Let us know how it goes.

Appreciate your help here, @mdshoaibkhan


Community Specialist
Community Specialist

Hi folks,

Chiming in to see if you still need assistance with this. Hope the previous post helped. Let us know if you have additional questions ― we'd love to help.


Community Specialist
Community Specialist

Hello there,

We haven't heard from you in a while so we'll be locking this thread if there is no update within 24 hours. If you have any new issues, updates or just a discussion topic, feel free to start a new thread in the Community.