cancel
Showing results for 
Search instead for 
Did you mean: 

Printer on network shows no IP address in devices (works fine though)

Robert-R
Community Member

First of all, my printer works fine.  This is more of a curiosity.  I have the printer set to always request the same IP of 192.168.86.119.  I also have my Nest Wifi set to DHCP reservation for that mac address of the printer to assign 192.168.86.119.

However, when I view the info for the printer device in the home wifi app, it shows a blank IP address.  I'm just curious as to why this might be.  All other devices properly show their IP address.

2 ACCEPTED SOLUTIONS

kiltguy2112
Silver Product Expert
Silver Product Expert

Turn off the static IP at the printer, and let it get reserved address from the router and it will show up.

View solution in original post

That makes sense... the reason I turned on the static IP at printer was because if I restarted the network it was creating it's own IP not even in my network... like, if it couldn't talk to DHCP server it'd just do it's own thing and it wouldn't go and request a new IP from the nest wifi unless I rebooted the printer, so that's why I set the static IP at the printer also.  Not a big deal and I think that explains what I see.  Thanks.

View solution in original post

6 REPLIES 6

kiltguy2112
Silver Product Expert
Silver Product Expert

Turn off the static IP at the printer, and let it get reserved address from the router and it will show up.

That makes sense... the reason I turned on the static IP at printer was because if I restarted the network it was creating it's own IP not even in my network... like, if it couldn't talk to DHCP server it'd just do it's own thing and it wouldn't go and request a new IP from the nest wifi unless I rebooted the printer, so that's why I set the static IP at the printer also.  Not a big deal and I think that explains what I see.  Thanks.

Jeff
Community Specialist
Community Specialist

Thanks for the help on this, kiltguy2112.

Hey, Robert-R. Did that end up clearing up the issue for you? Have you had a chance to try it out? If things still aren't working, let us know.

Thanks.

Jeff
Community Specialist
Community Specialist

Hi, Robert-R.
I just wanted to check in real fast to see if you saw my reply and to find out if you still needed any help on this. If you're still needing assistance, please just let me know and I'll be happy to continue helping.
Thanks.

Robert-R
Community Member

All good now

Jeff
Community Specialist
Community Specialist

Good news, Robert-R.

I'll mark this as resolved, but if anyone needs anything else going forward, feel free to open up a new thread.

Thanks!