cancel
Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Slow wifi compared ISP incoming speed

Robbprice
Community Member

My incoming speed is nearly 500MB but Nest wifi is only around 80MB on. What can be done to fix this?

9 REPLIES 9

olavrb
Platinum Product Expert
Platinum Product Expert

Where and how did you measure 80mbps? Wirelessly? By ethernet cable? Inside the Google Home app?

Some things to check.

1. Make sure modem is put in bridge mode to avoid double NAT, which can cause performance issues.

2. Make sure the ethernet cable used to connect Nest Wifi with your modem is capable of gigabit speeds, and not damaged in any way. Could be worth trying a different ethernet cable, just in case. Same goes with every other ethernet cable and other equipment (like switches) involved.

3. The placement of the Nest Wifi units has huge impact on wireless performance.


I don't work for Google.

Robbprice
Community Member

Hi, tried a different cable, no difference in speed, I’m measuring Wi-Fi speed on my phone right next to the router. Router is in NAT and can’t be changed due to other points in bridge mode. 
Is there anything else I can try? I have had 300Mbs briefly a few months ago but never over 90Mbs these days. 
Rob

LovelyM
Community Specialist
Community Specialist

Hello everyone, 

@olavrb, your assistance here is greatly appreciated.

@Robbprice, I'm checking in to see if you were able to do the steps above. I want to make sure everything is covered on your end, so let me know if you still need help.

Best,
Lovely

GLJ100
Community Member

I have exactly the same issues, 860 down, 35 up but 80-120 when measured on Iphone or laptop

Robbprice
Community Member

Have you been able to sort it? 
The Google Wi-Fi app says it’s 800 & 70 but fast.com says 90 & 60 😢

GLJ100
Community Member

No, just tested and same. It’s totally an issue with the Access points

LovelyM
Community Specialist
Community Specialist

Hi folks,

Sorry for the late revert. I just want to check if you are still having any issues. If you do, please let me know what steps you have taken so far so we can give you the right level of help. For those of you who have already contacted support but the issue remains, share your case number with me so I can check on it further. 

Thanks,
Lovely

LovelyM
Community Specialist
Community Specialist

Hey there,

I know it has been a while, but I want to ensure that everything is covered on your end. Feel free to inform me here if you still need a helping hand.

Best,
Lovely

West22
Community Member

Same issue here.  The new firmware update didn't fix my issue.  I've been dealing with this for over a month and a half.  It seems to be a common problem with no fix from customer support.