Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

google nest point stopped working

Community Member

I am having the same problem that I've seen countless other people on this forum having. I have a nest and one of the points all of a sudden stopped connecting (after it has worked fine for several months).  I've tried everything that others on this forum have tried and it's just a dead-end rabbit hole of wasted time.

10 days from now a forum assistant will come on here and ask me if I've tried rebooting it, or some other obvious and equally meaningless attempt at a superficial solution.  When I tell them I've tried all that, it will be another 10 days before they ask me to fill out some form.  When I reply that I'd rather just return the faulty product they will go silent.

3 weeks from now, when I've gone out and bought another system because I NEED WIFI TODAY, they will come back on here and tell me that they are locking the thread because of inactivity.

This is how Google works. Their products work great, until they don't, and it's only then that you realize that, when you buy a Google product, you have actually also signed up to be a technical repair person for their company. You won't get any training, nor will your assistant be of any use whatsoever, nor will any of the hundred different sources of useless instructions that Google has strategically placed in every corner of the device, the internet, the blog sites, the assistant, etc. etc. etc.

You will spend HOURS AND HOURS trying to learn how to be the technician that you signed up to be, but you won't have the internet to help you because THE **bleep**ING DEVICE ISN'T WORKING.

The problem with this blog is that it is used mainly by people who have already wasted hundreds of dollars and hours of time trying to get answers that most other companies can provide you in a 5 minute phone conversation. But Google is just so progressive that they would rather give the "job" to their customers instead of paying actual trained and useful technical support personnel to actually help support their customers.

**bleep** you Google


Community Member

HAHAHAHA. I earned a **bleep**ing badge for posting that.  It's my first promotion!

Community Member

I completely understand your frustration. I just had to reboot my system and am having to do so at least once a week. My primary reports network speeds of ~300 Mb/s, but the access points report ~20 Mb/s and nothing short of rebooting will fix it. All points are on the same floor with no obstructions between them. I know Google can do better than this. I've actually been waiting for several months now for them to fix the NAT loopback issue but it seems firmware '820 is all we get for now. I recall switching from Netgear years ago for this same sort of thing -- at the time Google WiFi was less performant but way more reliable. Not sure why that changed.

Community Member

I’ve just joined this forum and saw your post. So I’m not the only one having this problem…at least I’ve had my nest for a few years. I’ll try to reboot the point that isn’t working, then just go buy a new system I guess. 😞