cancel
Showing results for 
Search instead for 
Did you mean: 

Android phone does not have "Matter devices & services"

MatterDev
Community Member

Hello,

In the page https://developers.home.google.com/matter/verify-services

It is stated that "Matter devices & services option" should be listed under "Settings > Google > Devices & sharing." That option is not available on my Samsung S20 phone.

The same page shows a QR code that can be used to expedited the update of Google Play services. The QR code does not work on the same phone.

Also, as recommended in that same page, I scrolled to the bottom of: "Settings > Apps > See all apps > Google Play services" The version on my phone is 22.49.13.

I also have a matter project created in the developer console. I have downloaded, compiled, and ran the app available on the CodeLab https://developers.home.google.com/codelabs/matter-sample-app#0

The app fails to run because the phone does not have the required Matter modules and services.

How can Google Play Services be updated to include Matter modules and services?

Your help is greatly appreciated, thank you in advance.

6 REPLIES 6

sipriyadarshi
Solutions Expert
Solutions Expert

I just checked my phone it does show "Matter Devices" option available for me.

The modules propagate with the most recent GHA and Google Play Services updates automatically. Can you make sure they are in the latest supported OS version for your phone and all of your apps are up-to-date ? 

Once confirmed , can you post the screenshot ?

>The modules propagate with the most recent GHA and Google Play Services updates automatically

Yes, that's the reason I posted asking for help. It does not update automatically. I updated Google Play Services manually to version 22.49.13 and the play store says it's up to date. 

Settings / Google / Devices and SharingSettings / Google / Devices and SharingApps / Google Play ServicesApps / Google Play ServicesApps / Google Play Services 2Apps / Google Play Services 2Settings / Software updateSettings / Software update

I have the same issue on the following configuration:

Pixel 5
Android 13 (latest January security patch)
Google Play Services Version: 22.50.14
Google Home App Version: 2.62.80.2

I tried already the trouble shoot page here and on my phone the package

com.google.android.gms.home

 appears to not be installed. I waited now already 2 weeks and no change. Package still not loaded.

As this is my personal phone i did not go the route of factory reset yet which is mentioned on the trouble shoot page and i don't really want to either.
Is this still in the space of "normal" and i can expect the update to roll out eventually?

Same here, I prefer not to do a factory reset.

This is not the recommended answer, in fact, it answers nothing, but keeps being marked as "the recommended answer". I posted the requested screenshots, please follow up with an actual answer. Thank you.

I am surprised by the lack of answers / activity in this forum, if a developer can't get their phone updated with Matter libraries, how can we expect the consumer to do that? Please help.