cancel
Showing results for 
Search instead for 
Did you mean: 

3 speakers repeatedly disconnect from wifi

melooh347
Community Member

I have 3 google nest mini 2gen speakers in my apartment, two of which are set up in a stereo pair. All three speakers are repeatedly unreachable through my iOS app - I receive a “disconnected device” error message. If I unplug and reboot the speakers, they are functional with the app for an hour or two, then we’re back to “disconnected device”. I reboot them several times a day and have performed factory resets on each one several times. Same thing - they work for a couple hours. I’m having the same issue with the Chromecast on my TV - I have to reboot it before I can use it. It really is no convenience if I have to manually reboot all the devices every time I want to use the home app or cast to my TV. 

All devices are on the correct wifi network with the correct password, as is my phone.
 I bought a new Arris Surfboard SBG10 modem/router in May 2021 and have had no problems with it or with my internet service.  This is a fairly new issue with the “disconnected device” errors, it’s been happening for a month or two. Before that, everything worked. 

Does anyone have any advice? I’m so frustrated that I’m about ready to give up on the whole system. 

1 REPLY 1

Jake
Community Specialist
Community Specialist

Hey there,

Thanks for visiting the Community.

Since this thread hasn't had activity in a while, we're going to close it to keep content fresh. I would recommend performing a factory reset on any device you are having trouble with. We hope you were able to get the help you need, but if the issue persists feel free to create a new thread, and provide as many details as possible so that others can lend a hand.

Best regards,
Jake