cancel
Showing results for 
Search instead for 
Did you mean: 

All my Google Nest Hub devices lost internet connection

Wags
Community Member

I’m in Western Australia. I got up this morning to find that all four of my Google Nest Hub devices had lost internet connection. Additionally, I could no longer control some of my smart home devices using the Google Home app, but I could control others. The internet was apparently OK, and I was able to connect using various other devices like my iPad and iPhone. I did a power off reset of my router and that fixed the problem, but I would like to know what caused the problem. Has anyone else experienced this kind of problem?

2 REPLIES 2

Nh2
Community Member

I have had this issue, which was caused by my router. I have a netgear wifi 6 router, but many similar newer routers have a dynamic switching system where the router will assign devices to the 2.4 ghz channel and 5 ghz channel as web traffic and slots allow. Our router lost power for a few minutes overnight one night, and then the next day anything connected to the 5ghz channel was disconnected. The resolution was to either unplug the nest/google device, or restart the router. This also causes some devices to disconnect when the router changes them from the 2.4 to 5 channel. You can help the issue by turning off the dynamic switching option in your router, or tagging the device as a smart home device (only some routers have this option in advanced settings). Unfortunately, any time you lose power on your router, this may happen again. Assigning all devices to the 2.4 channel may help. Shot in the dark that this is your issue, but seems like others have found this to be the cause also. Goodluck

Wags
Community Member

I suspect you’re on the right track, although I have smart switching turned off. I have a Netgear RAX40 router, and I have previously had issues with dynamic switching between bands. This is the first time this particular problem has happened, and it was corrected by doing a power off reset. Also, all of my Nest Hubs were disconnected, even though they can connect to 5G. I just checked my connected devices and two of the Nest Hubs are connected to 2.4G and two are connected to 5G.