Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Google mini 1st gen will not connect to hidden SSID wifi

Community Member

I recently upgraded my wifi and it allows for multiple SSIDs to separate out the network. I made a new network for just IoT devices to get them away from the more sensitive computers. I migrated all the IoT devices over, about 20 in all, including 3 Google Mini 1st gen, 4 Nest cameras of different vintages, 2 Nest Hubs, 2 Chromecast w/ Google TV 4k, and numerous other brands of smart lighting controls, locks, and plugs. I did all the migrating with the SSID visible, then switched it off. All the other devices reconnected, a few needed to be rebooted, but all eventually reconnected just fine, EXCEPT the 3 Minis.

Frustrated but not deterred, I tried ALL of the following:

  • Rebooted the Minis
  • Factory reset the minis
  • Reconnected the minis to the visible network (after reset) then turned the SSID back to hidden (still refused)
  • Tried to add the minis back to Google Home App using the "Other Wifi..." option (would not connect after a dozen attempts this way).

Unless I'm missing something, I have to conclude that the network code in these devices is just have poor as to not be able to support hidden SSIDs.

The other network settings are set to be "lowest common denominator" for IoT devices:

  • WPA2 only
  • No fast roaming (802.11r and v off)
  • No MAC filtering
  • DHCP

Not that any of that should matter, as I can connect them to the "full featured" network I use for phones and laptops just fine, just so long as the SSID is not hidden, and they connect to this same network immediately after re-enabling the SSID broadcast.


Community Member

Connect to a hidden network after setup
On the Nest app home screen, tap Settings.
Tap Home info.
Choose Home Wi-Fi help.
Select the Protect you want to update.
Tap Start.
Choose Other networks below the list of Wi-Fi network names.
Type in the hidden network name, password, and security type (WEP, WPA or WPA2).

Ugh, so I guess this is 25th time's the charm, or the stars are better aligned today? No, apparently the software gremlins needed to be removed via rebooting my phone.

Anyways, in case anyone else comes across this, step by step:

First step is to remove Mini from current Wi-Fi either by using the Google Home App or use the physical button to factory reset it.

Google Home App Method:

  1. Tap the Google mini from the main screen
  2. Tap the Gear
  3. Tap on Device Information
  4. Tap on the Wi-Fi Line
  5. Confirm you want to Forget the Wi-Fi

Connect to new hidden Wi-Fi:

  1. Connect your phone to hidden Wi-Fi, and the Wi-Fi CANNOT be set to isolate clients, as the confirmation step will try to direct connect between your phone and Mini
  2. From the Google Home main screen tap the + in the upper left corner
  3. Tap Set up device
  4. Tap New device
  5. Choose your home
  6. Wait as it finds the Mini (if it doesn't find it immediately tap Speaker and try again and again and again)
  7. Tap to accept the legalese and choose if you want to share info with Google 
  8. A list of visible Wi-Fi should appear, scroll down to the very bottom and pick "Other Wi-Fi network..."
  9. Enter in all Wi-Fi information including the security option, which will most likely be WPA2 for any modern network, enter password and tap Connect
  10. It should then connect. If you factory reset you'll get the tutorial screen to tap through.
  11. IF and this is likely, this did not work for you, verify the details on step 9 and try again.
  12. IF and this is likely, step 9 was correct but it still didn't work, do it ALL again, factory reset the Mini, and REBOOT your phone and start again from step 1. 

Community Specialist
Community Specialist

Hi folks,


Thanks for the help, @WillJoe123

@CSEngineer, thanks for posting. I’m glad your issue is resolved now. I’ll keep this thread open for 1 more day. If you need further help, let me know.