cancel
Showing results for 
Search instead for 
Did you mean: 

I have the same problem here with my Google Nest Hub

mfears
Community Member

My Google Nest Hub shows a gray screen with the G logo, I already tried to restart many times.

Please set up a claim for me.

Thank you,

Shirley Fears

 

1 REPLY 1

Princesss
Community Specialist
Community Specialist

Hi mfears,

 

Thanks for reaching out.

 

Since this thread hasn't had activity in a while, we're going to close it to keep content fresh. 

 

I know how challenging it can be not having a working device when needed. This is related to a similar trending issue on this link. Rest assured that our team is aware of this and is already looking into it. I'd like to gather some details:

 

  • Have you tried plugging the device to a different power outlet?
  • When was this issue (stuck on gray G logo) first noticed?
  • Was the device already in this state when you first discovered it?
  • If no, were you in the middle of interacting with the device when it happened? If so, what were you trying to do?
  • Did you unplug the device or was there a power outage shortly before you discovered this issue?


Please try these steps below that may help us fix the issue:

 

  • Place the device in Recovery Mode (unplug the device then hold down (long press) the volume up and volume down buttons while you plug the device back in. Release the volume button once the device turns back on.)
  • Attempt a factory reset once the device boots into Recovery Mode (hold down (long press) both volume up and volume down buttons at the same time.

If you have additional questions, feel free to submit another post, and provide as many details as possible so that others can lend a hand. Hope this helps! 
 

Best,

Princess