cancel
Showing results for 
Search instead for 
Did you mean: 

New Google Nest Hub - Won't Update, Device Unusable

newportknots
Community Member

New Google Nest Hub will not complete set up. Tried connecting via two different Wi-fi networks and a personal hotspot.

 

On setup, the device starts downloading an update, hangs at 0%, then shows a screen saying "Network Problem" no matter what network it is connected to.

 

I have restarted router, modem, started the device in safe mode, and done multiple factory resets.

 

Nothing has helped the situation.

 

 

5 REPLIES 5

Shelbell77
Community Member

Trying to set up my brand new hub to replace my bricked one and having exact same issue.

Jhu22
Community Member

I'm in the same exact place as you. I've reset everything, restarted the wifi, still getting the same error. 

Jhu22
Community Member

I gave it some time and did another factory reset and was able to successfully setup my Hub. Hope you have the same luck!

Robertnine
Community Member

I try anything... nothing works for me... 

Azarco
Community Specialist
Community Specialist

Hey All,

Thanks for visiting the Community. 

Since this thread hasn't had activity in a while, we're going to close it to keep content fresh.

We hope you were able to get the help you need. If you still need assistance with your Nest Hub devices, feel free to submit another post and provide as many details as possible so that others can lend a hand.

Thanks,
Alex