Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Recipe Next Step/Ingredient Command doesn't work

Community Member

When using Google Home Mini to cook, it has become pretty useless. I send the recipe from my phone, it starts to read it, gets through the first step or ingredient, can continue on to the next if I ask before it stops listening. But if it stops listening, when I then say "Ok/Hey Google, next ingredient" it either doesn't understand, or finds a recipe with the word "ingredient" in the title. If I say "Ok/Hey Google, next step" it finds Places with the word "next" or "step" in the title. This has been going on for months now, with both of my speakers.


Community Member

I am having the same issue. Any solution?

Nest Hub Max

I have our frequently used recipes saved in our Cookbook collection. I can't figure out the right combination of words to get my assistant to find a specific recipe I have saved and open it in the cooking mode. I've tried "Hey Google, show me <recipe name> from my Cookbook" and other similar phrases. Assistant always brings up suggestions from the web.


I can get to the recipe eventually by asking to open the Cookbook amd then scrolling through looking for it. Once I've got it open, it doesn't recognize any of the commands found on the Cookbook page.

To close the recipe, I try to tap the "I'm done" link at the bottom of the screen but it typically says it doesn't understand (I can't remember the exact phrasing right now). 


Is there anything I can do to get this function working? So far most of the reasons why I purchased this thing are not working out like I expected (won't play a specific playlist of saved videos in YouTube, can't view my calendar in month mode, and now the cooking mode is essentially useless). I love Google products and want it to work, but it's getting frustrating.

Same question here, waiting for an answer.

Ways to get google to fix this problem 

1)Start returning the products based on false advertising...

2)Convince influencers to feature the problem

3) Convince Apple or Amazon to make commercials showing wife messing up dinner for the in‐laws, a lady ghosting potential boyfriend after he made a disgusting meal, Kids having their bake sale ruined, baby crying over half-made baby food..Then showing Alexa/Siri having ordinary people hailed as gourmets.


Problem would be fixed in no time


Ever since the Fuchsia "upgrade",  the recipes functionality in Nest Hub is crippled.

I search for a recipe and start a recipe,  then I say "ok google,  next step",  and instead of going to the next step, it says "here are some search results for next step", and does a google search for "next step"   very frustrating.

Also,  when I click on the button on the screen to add a recipe to my cookbook,  it says "Sorry I don't understand".  I am not even saying anything,  I am clicking on the button on the screen. 

Community Member

Dealing with this exact issue right now. When I say next step it searches some TV show called next step. When I click "add to cookbook" it says I don't understand 

When starting a recipe, which I've never tried before, Google Assistant asks me to say, 'next step' when I want to continue. When I say, 'next step' it doesn't respond, and if I say, 'hey Google, next step' it searches for films and music called 'Next Step'

Anything that can be fine about this? It's basically rendered it useless for that purpose

Community Member

I have the same issue and wish it would work again. It was always a bit frustrating that it wouldn't just read the whole ingredient list to you, but at least it used to work at all.

Community Member

I am having the same issue and am eager to find a solution.

Community Member

Same issue here.. ended up finding the recipe from my computer in the next room.  I remember the first time I used this function, it used to work great.  Now I was tempted to throw google in the blender with the rest of the ingredients.

Community Member

I have started trying recipes regularly and saying "report a problem" when it stalls. It is a shame to lose this function.

Community Member

FYI to everyone else on here, Google support finally contact me directly, over 6 weeks after being told I was assigned a support case number. After having me do a factory reset, then telling me what commands I'm supposed to be using (which I've been using for years before this stopped working, and explicitly stated in my support request), I was told "this is a feature that needs an enhancement and improvement from our device developer and engineering team. With that being said, please send feedback. Just say: "Hey/Okay Google, send feedback" and add the short description of your issue that needs to be improved.". In other words, this feature stopped working, they don't know how to fix it, and we all need to just keep reporting like we've already been doing for months and maybe they'll eventually figure it out. 

Community Specialist
Community Specialist

Hi All,


Thanks for reaching out and sharing your message from Google support.


Unfortunately, there is not a solution for this issue yet. Our team is aware of the issue and are continuing to look into this situation. I'll keep you updated as more information becomes available, thank you for your patience. 

Can you please provide an update? Thanks!

We are all still waiting.  In the meantime, maybe Google should quit promoting this feature.  Sounds like some online dating service.  Sounds great online but doesn't deliver when you actually have it. lol

Community Member

Not able to find a recipe without scrolling through. It’s very inefficient. I might as well use my recipe book instead. More reliable. And efficient. I am replying on this a year and a half after the first person mentioned the same miss you. Guess it’s not on anybody’s radar. It must be on the warmer plate not the hotplate

Community Specialist
Community Specialist

Hi there, 

Apologies for the wait here, but appreciate your patience. The issues with Recipes and Commands are bug issues that we are aware of and our engineering team are working on a resolution for. We appreciate the wait and while we don't have an ETA on this, please let us know if you are still experiencing an issue with this. 


Best regards, 

Garrett DS

Yep.  My Home Hub stopped working with recipes about 6 months ago (or more..I can't remember).  We tried to fix by resetting, power cycling etc, but to no avail.  I was thinking of getting a Nest Hub Max to replace my Home Hub, but if that recipe functionality is not there, I can't justify the extra money.  The recipe feature is very important to us.  How important is it to Google?


I upgraded to the Max to see if the cooking issues were unique to the Gen 2.  Doesn’t work on my Max.  They should stop advertising features that don’t work 

Still experiencing 

Community Member

Oh yes! I’m still experiencing the problem. I would definitely like it fixed ASAP. Like many of the others, this was the reason I purchased this. 

Its a month later and still all the problems described here exist for me.  This was the reason we bought a Google display for our kitchen and we've loved it for years-now a daily frustration.

I just bought my Google Hub right before Christmas 2021, and the main reason was so I could use it for recipes, which is advertised on TV, on the box, and online. Right now it's just an expensive digital clock in my kitchen. 

Can't believe they are still advertising that as as feature. They've abandoned it for 6 months now.

Community Member

It's been over a month.  Is there at least an ETA for the fix?

Still experiencing the the issue

Still experiencing this issue.

This is frustrating and being one of your main selling points it is poor that it is still broken. 

Please fix this.

just letting you know: still experiencing an issue with this. any ETA yet? thanks.

Well when are you going to fix it. It's been 9 months that seems like someone is bad at their job...

Still having issues. So frustrating. 

Community Member

still having these issues!  This was a big thing on your promotion years ago and as I can see people have had issues for about 2 years.  How come this is still a problem?!?!

Community Member

Mine now plays 'The Next Step' show on netflix.

Community Member

YESS!!!! SO ANNOYING!! I just bought mine right before Christmas, so I had no idea people were having these issues. I thought I was doing something wrong. I have been so angry at this thing, when I thought it was going to be a fun cooking experience. 

August of 2022, still not functioning properly. Replies "do not understand" even when using onscreen controls in cookbook. Ridiculous!

same here as of oct 5, 2022


Community Member

We also have a nest hub and I was looking at a recipe on it.  Not all the ingredients/steps were shown.  There were links to '+show more' under each list.  Both links got me the response, "I don't understand".  

Community Member

Same problem here. It used to work great. Now it's an expensive paperweight.   Very frustrating. 

Community Member

"the next command" is also not working for music at least in my case!

Community Member

Same here for all of the above. It doesn't work like this video claims.