Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Settings Menu on nesthub 2. Gen is missing sleep and/or motion sensor

Community Member

I want to calibrate my nest hub 2. Gen sleep sensor. 
it says swipe up from button of screen, choose the gear symbol and choose sleep sensor. 
but my menu only has:

system settings

device information 


an picture frame. 

nothing else


Community Member

me too...

my nest hub 2 gen

 motion sensor, sleep sensor. It's not working.


i am from s.korea

Community Member

Same here!Thought it was a broken firmware.Bought a second Nest Hub…still zhe same issue. No solution from Google.Im from Germany

Hey, konntest du das Problem lösen? Habe den Hub seit 3 Tagen, und es ist echt frustrierend wenn etwas nicht geht, wofür mal gezahlt hat.

Nein.Funktioniert bis jetzt nicht.

Community Specialist
Community Specialist

Hello everyone,


Checking back to hear from you about the setup concern where the Sleep Sensing option is not available. How is it? Can you configure your Nest devices? If not yet then make sure the Google Home app on your phone is up-to-date. Go to Playstore or App Store to do the update. 


Also, if the issue persists, you can do a factory reset to restore your Nest devices to their default and original settings. Here’s how:


  1. On the back of the Nest Hub, hold both volume buttons together for about 10 seconds.
  2. Your Nest Hub will let you know it's resetting.
  3. Proceed with the setup.


Let me know how it goes.




finally it works

Its working now.

Hey Dan. I have the same problem. I already reset the nest hub. And it's up to date. On my menu setting only

- device information-bluetooth- display - photo frame. That's all 





Sleep Sensing icon suddenly disappears. I do a Factory Reset, and set Hub up again. Problem solved. Every couple of month I have to do it all again.

Did not work for me.

Community Member

Ps. I’m from Denmark

Community Specialist
Community Specialist

Hi folks,


@MattHK, @kwangrae7601, @TheMisfit138, that certainly isn't the experience we want you to have with your new Nest Hub 2nd Gen ― let's check it out. For confirmation,  do you still have the box for your Nest Hub 2nd Gen? If so, check if you see the "second generation" name at the bottom left. It would help a lot if you could do a sequential reboot first: 


  1. Unplug the power cord of your router followed by your Nest speakers.
  2. Plug them back in after 3 minutes.
  3. Restarting your phone might also help.


Check the settings again after the sequential reboot.


Tell us how it goes.




It's still not work.

I'm trying to recalibrate it.
I can't swipe up.
There is no option window.

Only down swipe option window
And swipe to the side.

When setting up after reconnection, the sleep sensor and motion sensor are set, but both do not work after setting up the device.

Is there anything planned to update the firmware?

Guik2 is imprinted on the bottom of the machine.

Its second generation for sure.Will try it tomorrow with router reset.

Did your workaround, doesnt do anything. ☹️

Community Member

It is a 2. Gen

and the above didn’t work

Community Member

한국에서도 똑같이 안되요ㅠㅠ 

혹시 남한이랑 북한이랑 코드 구분 잘못해놔서 막힌건 아니겠죠...?

그렇다기에는 미국으로 놔둬도 안되던데...


Community Specialist
Community Specialist

Hello everyone,


Thanks for sharing details about the issue. I know how challenging it is when some of the features on your Google Nest Hub (2nd gen) are not working. Our team is aware of this and looking into this issue at hand. I'll make sure to update the thread as soon as I have more information to share.


Please let us know the firmware version of your device and the Google Home app on your phone. Also, make sure to send feedback on your Nest Hub (2nd gen) by saying, "Hey Google, send feedback," followed by the keywords: GHT3 Sleep Sensing option missing on the display tray settings. These will help the team to further check what's going on with your devices. Visit this link to know more about sending feedback.

Kind regards,


Here are my device firmware info.App is newest Version iphone 12 pro max.


nest hub 2nd gen info



my phone info

i-phone 11 pro max

app version 


Community Member

same here in Holland,  missing motion sensor in settings, only,

system settings

divice information


photo frame


Community Member

Nest Wifi router: 
Model H2D
Software version: 14150.376.62


Nest Hub display (brand new)
Model: 2nd gen
System firmware version: 324896

Google Home (iOS and iPadOS)
Version: 2.63.110

Community Member

Same issue in Denmark 

Community Member

Same issue here in the UK. Running iOS 16.3 on an iPhone 11 Pro.

Technical information

System firmware version: 324896
Cast firmware: 1.56.324896
Language: en-GB



Community Member

The Google engineers seem to have fixed this now (for most of us). 
So I recommend everyone (again) do a factory-reset of their Hubs by holding both volume buttons down (on the back of the Hub) for ten seconds, and then setting up the Hub again via the Google Home app. 

I've just done this to mine and it FINALLY works! 

MattHK hub works.jpg


Community Member

If you have sleep sensing set up on any other gen 2, you only get one per account.

Community Member

I have the same issue.

 Located in Iraq.