Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Sling TV no longer plays on Nest Hub Max

Community Member

All of a sudden my hub max won't play sling tv.  It indicates it's "playing CNN on Sling", then indicates “sorry something went wrong when your ready give it another try”.  It has worked for over a year before now.  I tried unlinking and relinking Sling TV on Google Home with no change.  I tried just starting the Sling App on the display, and get the same message.  I rebooted my modem, router, and hub max with no change.  I had to accomplish a full factory reset of the hub max to fix the issue.


Community Member

I'm having the same problem. Reported it to Google, but of course no response. I'm tired of fooling with them, so tomorrow they are getting replaced with Amazon's 10 inch Echo Show. They work way better than Google. Every update Google sends out causes issues for it not working. And Google doesn't seem to care about getting these glitches fixed and very poor customer service.

I had an 10" echo show and I switched it out with the google because Alexa didn't provide very good answers to my questions.  This was the first issue I have had in over a year and now it's working good again. I don't think Alexa has improved much so I'm sticking with google.

Glad to hear it's working good for you. I've done multiple factory resets and unlink and relink the Sling account. After being idle for 30 minutes and you give it the command for Sling, it won't work.

Let me know if you have any suggestions.


You’re right, it won’t play Sling after a time.

I signed this device up for the Preview Program to get a newer firmware installed to see if that fixes the issue.  I'll post results after the firmware updates.

I've had mine on the preview program for 4 months now and the last update was September 8th. Nothing was fixed. Another thing that quit working was speaker groups. The only ones that don't link up are the Nest Hub Max. If you manually include them, they will play. So that's another issue going on along with Sling.

Whats aggravating is that Google knows of these problems, but won't address them right away to fix what they messed up. It may be months down the road before we see a fix.

Keep me posted if you get any results.

It finally upgraded to the preview firmware.  That was a mistake, now it has lots of issues.  Turned off the preview program.  Will it go back to the old firmware that worked?

Once that new firmware loads, sorry to say that you're stuck with until another firmware is updated and released. I'm pretty sure that's what happened to my units because that's when everything went downhill.

I can tell you that the Amazon Echo Shows put Google to shame. The Echo's are fast and link up to your speaker groups flawlessly. I've switched over to Echo Shows and only have 2 of the nest hubs left and they are getting ready to be replaced.

Pulled out my old Echo Show 8 but I don't see Sling TV listed under Settings-TV & Video services.  May have to wait for firmware to update.  I tried to get it to update, it indicated it was downloading, but nothing has happened and it's been several hours.

If it stays stuck in updating, unplug it for a bit then try again. Be sure it's in the right account to show Sling, meaning in the account the echo show is registered too. It will only display Sling in the registered account holder.

Hope it works out for you.

Seems to be working again. Someone at Google did something to fix it.

Yes, mine is working again as well.  I put my echo show 8 back in it's box.