Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Something went wrong. Try again in a few seconds.

Community Specialist
Community Specialist

Disclaimer: This thread was migrated from our previous version of the Google Nest Community. You can continue to receive updates on your thread issue here or simply ask, browse or more in the new Google Nest Community.

Original poster: Stephanie Divito 


Tried rebooting and unplugging all first gen home speakers (mini, home, and hub). Every time I say Hey Google (to any of them), it says something went wrong. Try again in a few seconds. Or there was a glitch. Try again in a few seconds. This has been going on for a couple months now. I'm pretty annoyed. Should I factory reset all (9) of them?
207 REPLIES 207

Community Member

I have this problem with one of my 3 Home Minis - the first time I use it after an interval (30 mins?) it says there was a glitch or something went wrong, but immediately after this, it works OK. 

It's within 7 ft of the router wifi, and I've tried all the solutions I've seen on these forums. Most of them work for a short while, but then the problem comes back.

I've had these minis for a couple of years, all bought together, and this problem started a few months ago.

Community Member

When will this be fixed? Constantly happening on all devises and a brand new hub max. If this is not going to be resolved let me know so I can transition to Alexa 

안나요  나와해주세요

I AGREE.  In fact, that is a fantastic idea to switch over to Alexa.  

Community Member

I've had two minis and a hub working for almost a week now.  Turning off IPV6 was the solution.  Well, not really, as it breaks other things.  While it gets the assistants working, it underscores that this system is broken.  

Community Member

I have Google mini, Google audio and Google hub max and all of them have been doing this for a few months now, it's so annoying, they will say there was a glitch and the then if you ask right away again, it works. When is Google going to fix this? I'm very close to getting rid of all Google hardware and moving to alexa, I need to buy a smart doorbell and I'll probably go with the ring doorbell and ring floodlight cam as Google don't even have that. Such a shame as I've stuck with Google for so long. 

Community Member

Google Has a Glitch I'm having the same problems its been going on almost maybe 3 to 4 weeks now restarted my device and wifi. Can't figure out what the problem is wish there was a fixed !

Community Member

Has anyone got a resolution yet?  This is driving me crazy my google next is nothing but a glorified digital photo frame.   

Community Member

Disabling IPv6 on my modem router fixed it for me.  YMMV.

Google really need to sort this out.


Community Member

Similar issues as everyone else. Had the Google Home for several years. Lately she is getting dumber. Takes a long time to respond. Often doesn't respond at all, even if you are standing right next to her. Comes up with the "something went wrong" response. At one point quite a while ago she forgot how to control our lights, then magically she remembered again without us doing anything to cause either situation. Google, I'm not sure what you are doing in terms of software development, but this seems to be a bit of a cluster. Glad I haven't bought too many Google products like nests, etc. Not a company that seems to be particularly good at this or maybe they don't really care. Used to have a decent music streaming option which is now gone. Maybe our Google Home has outlived its usefulness and needs to go. I used to recommend to to friends. Not anymore.

Community Member


After some serious digging I found that my Xfinity gateway was a few years old and with some changes they recently made to the service it wasn't suddenly not connecting to the devices as quickly as it had been. The first time is ask it a question it would struggle to connect. 

I contacted Xfinity and requested a new gateway. Once installed everything worked perfectly again. 

So in conclusion, my issue was router related. Though I hadn't changed anything on my end, software updates from both companies had made my equipment the problem. If you have cable internet start there and save yourself a frustrating few weeks. 

I'd be curious to know if IPV6 is enabled in your new router.  Disabling it is the only way my three devices will work.  I know others report the same result.  

No, I believe the whole IPv6 theory is a red herring. I've never had IPv6 enabled and have increasing problems with all devices.

To me, this seems much more likely to be to do with the mechanism they use to see which device is closest to the person giving the command. I often see the issue when a further away device answers instead of the closest one and eventually the closest one says there has been a problem once the other has finished responding.

@Grevane Definitely not a red herring IPV6 is normally enabled by default in new routers.  I, and numerous others can only get our Google/Nest devices to worth with IPV6 disabled.  Not enabled as it normally should be.  This definitely points to an issue.  

So how would you explain those of us who get the same symptoms with IPv6 already disabled? You can't just ignore those because they don't fit with a theory.

Without empirical evidence and supporting error log data collected potentially by Google, there are far too many cases where disabling IPv6 doesn't help to attribute the symptoms to specifically IPv6.

Which is why I'm suggesting it's a red herring and at best only part of the puzzle if any at all 

What is IPV6 qnd how do you disable it?

Community Member

Internet Protocol version 6 - it provides all the internet addresses we'll need for the 'internet of things'. The old version, IPv4, (don't know what happened to IPv5) just doesn't have enough addresses.

You should be able to disable it in your modem/router settings. On my router, there are two settings, one in the advanced internet settings and one in the advanced LAN settings. In each case, there's a checkbox you can uncheck which disables IPv6.


Don't disable it.  READ up or above on what to do about the glitch!


Community Member

I've looked into this a bit more and it appears IPV6 is enabled on this router but it is currently running IPV4. I'm certainly not an expert with this stuff but I have my doubts that was the issue. 

@seerstudio wrote:

I've looked into this a bit more and it appears IPV6 is enabled on this router but it is currently running IPV4. I'm certainly not an expert with this stuff but I have my doubts that was the issue. 

Did you try disabling IPv6? none of my kit uses IPv6, but when I disable it Google Mini works instantly and when it's enabled Google Mini fails the first time of asking and takes a while to respond the second time.

Community Member

My router had IPv6 enabled, and it was handing out IPv6 DHCP addresses in addition to IPv4.  By disabling IPv6 on the router suddenly my google homes started responding the first time (after I rebooted them) and my Chromecast with Google TV which was failing and couldn't download an update suddenly could download the update and worked fine.  My guess is they are trying the IPv6 address first without checking IPv6 connectivity to their DNS or anything, it eventually fails and then they try IPv4, but they don't remember IPv6 isn't working...

Community Member

WHY do WE (the customer) have to TRY and figure out what the problem is with this product?  I mean, c'mon...we pay 199.00 bucks (give or take), shouldn't we just be able to plug it in, follow the prompts and USE IT?  I want to return my device!  It doesn't work and google NEEDS to man up on these defective HUBS!  Someone mentioned switching over to Alexa products and I believe that is the solution.  If you check around there are MANY of these google hubs being sold on ebay and now I know why!  They are DEFECTIVE! 

Community Member

It doesn't seem to let me. It's not a setting that I can change. I looked into it on their site and ran a suggested test that did show it was enabled but on my dashboard it shows IPv4 is what's running. I have a sneaking suspicion it's IP related. A friend who does home automation said he's run into that a few times in the past. After my new router was up I looked and that had changed, but again I'm no expert so I have to think back and it started when google home updated. It did act like it couldn't connect the first try and then on the 2nd attempt it worked. It just appears to be a mismatch of the software and hardware I had. 

I really do think google needs to respond with an official solution. I just hope my experience helps some people get it fixed in the meantime. 

Community Specialist
Community Specialist

Hey everyone,


Thanks for your patience as I understand this has been a frustrating experience. I appreciate all of you sharing your feedback, tips and various troubleshooting steps.


I have a few quick questions to try some steps and also gather some additional information. Could you try them and share with me once you've done so? 

  • What questions or commands are being asked when this issue occurs? Is this happening with all the questions you ask?
  • Are your Personal results settings enabled?
  • Can you confirm that your device recognized the question correctly?
  • Could you please check the language settings in Google Home app? Is it set to the correct language?
  • Could you please check the quality of My Activity audio recording

I'm looking forward to your responses and I appreciate you taking the time to also try these steps!

Community Member

 have a few quick questions to try some steps and also gather some additional information. Could you try them and share with me once you've done so? 

  • What questions or commands are being asked when this issue occurs? Is this happening with all the questions you ask? Turn on the lights, what time is it (commands asking google home to search the web and interact with other google home items)
  • Are your Personal results settings enabled? yes
  • Can you confirm that your device recognized the question correctly? yes, because sometimes it says "there's been a glitch" then follows the command
  • Could you please check the language settings in Google Home app? Is it set to the correct language? English and it's correct
  • Could you please check the quality of My Activity audio recording? they are all crystal clear.

FYI these are the other steps I've completed:

Same issue for months, multiple tickets open with Google. I have 1st and 2nd gens with the same issue. 

  1. I have reset my entire system multiple times.
  2. Checked google home settings
  3. Checked router and node settings.
  4. Split my network into 2.4 and 5 Ghz
  5. Connected to an outside network via mobile hotspot, immediately saw the Glitch issue.

It is definitely an issue that google is ignoring or doesn't know how to fix. The only common denominator is google products.

Case number is 5-3131000031810 (After troubleshooting, still seeing the same error)

Case number is 0-9501000031734 (After troubleshooting, still seeing the same error)

Here's the workaround we should try: (This didn't work.)

  1. We'll need two devices.
    • The first phone will act as a router. Turn on its Data connection and Hotspot.
    •  Connect the second device to the Hotspot connection.
  2. Factory reset your Google Home Mini device.
  3. Set it up using the second device.
  4. Make sure to connect Google Home MIni to the Hotspot.
  5. Monitor it for a few hours. Check if you will still get the same error response whenever you give it a command.

11/6/2021 CASE # 2-4231000031807 REQUESTED WARRANTY REPLACEMENT FROM GOOGLE - Still waiting for it to be escalated....

In my case, I am asking to turn on the lights.  Yes, I am confident the device understood the question.  Yes language, and yes to all the rest.  Like so many, it reliably works with IPV6 off, and fails with it on consistently.  

What questions or commands are being asked when this issue occurs? 
-This problem occurs regardless of the question being asked such as, "Hey Google, how's the weather today?" or any prompts such as "Good Morning, Google", "Hey Google, play country music", or "Hey Google, volume down". It occurs with every single interaction with our Google Home and Google Minis. Even while it's playing music (after having to be asked a second time to play music), if we try to give it a direction such as, "Hey Google, stop" or "Hey Google, volume 5", it responds with an error message telling us to try again later or try again in a few seconds. If we respond quickly enough after the error (as in, within maybe 10 seconds or less?), it will then follow whatever direction we give to it even if we tell it to do something else. While playing music, we can say, "Hey Google, stop". It will have a long pause before responding with one of the two error messages asking us to try again later. We can then give the same "Hey Google, stop" OR give a completely different direction "Hey Google, volume up", or ask a question and it will respond appropriately. Interestingly, when it gives us the error message it often speaks in some sort of British sounding accent. When it responds to our second question or command a few seconds later, it uses its normal voice.
Is this happening with all the questions you ask? 
-Yes.. And also with all commands or prompts such as "Good morning, Google". There isn't a single thing we have found that we can say to elicit a proper response from any of the devices.
Are your Personal results settings enabled? 
-"Personal results at Home" are turned on for three of our four devices. This does not seem to have an impact on the issue as we get the same responses on all four devices. We have two Google Homes and two Google Minis on this network. Personal results are turned off for one of the Google Homes.
Can you confirm that your device recognized the question correctly?
-No. I cannot confirm it recognizes the FIRST command or question correctly because it does not respond to the FIRST command or question with anything but an error message. It DOES respond appropriately to whatever command or question it is given a few seconds later. **When I open the Google Assistant app and view "My Activity", it does not show the first command/questions to which we received an error response. It only shows the question or command that was said AFTER the error message was received and we tried a second time.
Could you please check the language settings in Google Home app? 
-I initially had two languages set because I speak two languages...Dutch (Netherlands) and English. I turned off the second language (Dutch) and still get the same results from all of the devices.    
Is it set to the correct language? 
-Yes, it is set to English.
Could you please check the quality of My Activity Audio Recordings 
-The quality seems to be fine for the activity it kept track of, but it only appears that maybe 1/3-1/4 (or maybe less) of the prompts/questions are even being recorded in "My Activity".
I sure hope this helps! It's quite a frustration as we have made many purchases based strictly on the fact that the box states, "Works With Google Home" or "Works With Google Assistant". We don't have a very smart home and we actually don't have any of these devices connected to our Google Homes or Minis, but I like that we had the option to do that if we ever decide to. At this point, however, it seems pointless. It's much faster for me to ask Siri most of the questions I'd normally ask our Google device...I never thought I'd be able to say that since this requires finding my phone and picking it up. Being able to just say, "Hey Google" from any room nearby was MUCH more handy.
One other thing: We've noticed that sometimes our devices (at separate times) will very randomly give us an error message...usually it's the one about there being a glitch and to please try again in a few seconds. This can happen when I am working silently, haven't been on the phone or talking to anyone, and definitely didn't say anything to prompt any response from the Google Home or Google Mini. It occasionally happens at night while we're in bed also. It's very random and doesn't happen daily as far as I know (unless it's happening more often than I realize, such as in rooms I'm not near when it happens).

So frances..Frances... people have answered your query. Like 3 months ago. You wanna answer anyone or just ignore us? Also, tbh those questions indicated that you clearly weren't reading the posts on the thread,  which isn't all that comforting. My system also started this glitch

What commands is it using? Any command.

Are personal results enabled? Yes.

Yes it's the right language.  How do you think I know it's saying it has a glitch? 

Check recording quality.  Huh?

Additional problems I am having:

Randomly the chrome casts all stop working. They are my only way to watch anything not on disc. 

Alarms with music go off but don't play music. Or they play random music that was not requested. What good is an alarm that doesn't go off? 

Spotify commands seem to be unable to recognize most songs and artists.  It's commonly playing different music than is requested. 

Seriously,  this is a multi billion dollar company. This is WHAT YOU DO. Make your stuff work for crying out loud.

Community Specialist
Community Specialist

Hey all,


Sorry for the late reply. I wanted to follow up and see if you are still in need of any help? Please let me know if you are still having any trouble from here, as I would be happy to take a closer look and assist you further. 

Best regards,

Community Specialist
Community Specialist

Hey all,


I wanted to check in and see if you are still in need of any help with your device? Please let me know, as I would be happy to assist, and answer any questions you may have.

Best regards,

Community Specialist
Community Specialist

Hey all,

I want to ensure you are good to go, and everything is working properly. Please let me know if you are still having trouble, as I will be locking the thread due to inactivity. 

Best regards,

Community Specialist
Community Specialist

Hey all,

It has been a few days since the last reply, and I am going to lock the thread at this time. If you have any questions, please feel free to create a new post. 

Best regards,

Community Member

Like I said earlier, I have always run without IPv6 enabled and i still get issues.

I think there is a lot of clamour to attempt to blame this on IPv6 because someone on Reddit said they fixed it by disabling IPv6 when in truth, they probably fixed their own very specific issue by simply reconfiguring their router and rebooting it.

You really have no idea for sure whether you're even having the same issue as that person. Your general symptoms might be similar but there are a lot of complex technologies at play both within your home, Google's datacentres and the internet in-between and in reality, the chances of us fixing this by randomly suggesting router configuration changes for something we have absolutely no knowledge of how is built are very very slim.

But I can 100% say this issue exists with IPv6 disabled so this is not the magic bullet to fix this.

Community Member

Looks like different setups have different problems. I know mine is caused by enabling IPv6 and fixed by disabling it. I've tested it several times ¯\_(ツ)_/¯

Community Member

Someone above mentioned getting an Alexa so let me tell you my side of the story. I have a Google hub probably first generation and I originally bought the Lenovo Google assistant. Only the Google hub does this. The Lenovo works just fine. What does that mean then? I've been having this problem with the hub for about 6 months and I've had the Lenovo for 2 years and never had an issue.

Community Member

Any news on a solution? 



Nope. Appears they're still working on it. Albeit very slowly.


Community Member

Every speaker (have 3 google/ nest minis, the newest ones as well) is doing this.


For mor simple commands they seems almost ok (turn on the bedroom light etc), but even for these it sometimes happens.


where it happens every single time is for the “Goodnight” routine, or for ANY routine.

you see the little google lights flash around, then “Sorry, there has been a glitch, try again in a few seconds.”

i have made no device or network changes in the last few week.and i have VERY good mesh wifi coverage with TPlink P9’s covering the whole house with minimum 4/5 bars in each room.

This seems to be an unprovoked error that is not going away and is getting progressively worse…???!


Following - I'm having the same issue and posted in another thread.

If it helps, mine seems to have self -resolved after i restarted each of my router/access-points one by one