Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Speaker Groups no longer responding to spoken requests!

Community Member

We use Google Home to the maximum in out house with 69 devices using the service.

Part of this setup is 8 speakers comprising of Max, Home, Nest Display, Nest Audio etc...

Anyway, as of a couple of days ago when asking Google to "play on all speakers", "bedroom speakers" or any other group she responds "Sorry, I don't understand". The groups are still visible and selectable in the Google Home app. 

I've tried:

Factory resetting all devices

Reinstalling the Google Home App 

Deleting and recreating speaker groups 

Reset Google Wi-fi 

Still nothing works, if I hear "Sorry I don't understand" one more time I'm likely to burn the house down with all the Google products inside. 

These devices have worked pretty much perfectly for years, but the past 6 months of so they've become so unstable, and with key functionality being removed as part of the Sonos ruling I'm definitely suffering buyers remorse.    

Anyone else having this issue? 


Community Member

Im having same issue recently, impossible to get radio playing on my home group (a combination of speakers and Chromecast).

I got round this previously using action blocks. But even now it doesn't understand that either. 

@google needs to get this sorted out

Community Member

Yep, the G-men have stuffed things even further.  I can confirm over the last week, all my routines which used Group Speakers have failed. eg play radio on "Group Speaker Name".  I can use the routines with an individual device, but as a group... it has been G-crippled.

Once again, these money centric techo theives have removed features that were part of the products as paid for, as they still refuse to licence the technology, from the respective owner(s), that they used to entice customers and sell products for profit. Hmm, dubious legal context here!  

Google actions are at least consistent, .. ... "Stuff the customers!"

I have a work around though, it will work until th G-men screw us over again.


Play the radio (possibly other strams but untested) to a single device.  Then go to the Home App, click on the Media orb, then select additional devices.  Group Playing!  This also, for the moment, works with a "group" speaker, which will auto-fill the individual devices.   Give it a whirl.

For guaranteed reliability, which Google refuses to provide (though we have already paid for it), we may as well run miles of speaker cables around houses to dumb speakers.  These will not break, won't need resetting, don't get WiFi issues and work perfectly, every time.  

Seriously Google, you have no respect for existing, loyal customers, using them as a cow would grass,:  Eats it up, gets the life force from the it, absorbing it into its framework, the **bleep**s it out, with no further concern of how it keeps it alive.

Google, customes are important to your existence, do the right thing here, finally, fix your mess, and return satisfaction to absolutely dissatisfied customers.

Community Member

Works for streaming SiriusXM channels.  

I have two Chromecast Audio's (little pucks with 3.5mm jack outputs) tied into my Home Entertainment system and a stereo in garage.  It's a PITA to have to do this work around, but it works.


Same issues. I've chatted with Google.  No acceptance or acknowledment that there is an issue.


Community Member

How did you chat with them? 
Over the last few days I have asked google to play (name a band) and it comes back saying sorry, i cant find any devices to play music on. I have 8 speakers and 2 displays!


Community Member

Wow, it seems that this issue continues to persist. Currently, my Google Home (GH) devices are functioning normally, just as they were before this thread started in February. However, I have noticed an increasing number of reports from other users experiencing similar issues to what I had.

Please refer to my ‎02-19-2023 01:44 PM post below, which contains a link to the Nest Community support chat. I strongly recommend ensuring that you receive a reference number and obtain the full transcript of your chat.

During my chat session with the Google tech, I attempted various solutions to resolve the problem. Firstly, I created a separate home and transferred all my devices to that home, but it had no effect. Secondly, I voluntarily deleted all my devices and added them back one by one, but that also had no effect. Additionally, I made sure that all my devices were connected to the same 2.5G wireless band, but once again, it had no effect.

Ultimately, I was instructed to issue the following voice command to one of my devices: "Hey Google, GHT3 unable to play music on audio group." I can't recall the exact response from GH, but it didn't instill any confidence in me. In the end, it appears that none of the recommended actions proposed by Google to this community led to a resolution. The problem seemed to resolve itself, presumably due to Google issuing a patch or fixing something on their end.

I hope this information is helpful. I also made an effort to find current Reddit threads and other blog entries describing this issue and documented it on this and other Nest Community forums to raise more awareness. We were successful in doing so, but despite the friendly and seemingly helpful nature of Dan, the Community Specialist, he never truly offered a solution that resolved the majority of the reported issues. It took approximately two weeks of dysfunctional GH and diligent documentation on as many forums as possible for this to be resolved. I believe this was the only approach that actually yielded results.

Community Member


Changed Google products to Apple and life expectancy skyrocketed. I would use G-wokemen products over Apple IF they would be RELIABLE. But nooo.

Yep, confirming IT'S BACK UP AND RUNNING! .... for now.... until they break it again..

Community Member

Having same problem: when I use a voice command to play music on a device other than the default speaker, the response is “Sorry, I don’t understand.”  Frankly,  I don’t understand either. This was working just fine.  It seems to me that Google’s procedures for rolling out software changes are not very robust.  Does anyone test these things before they are released? This is the second feature  in the last few months that suddenly stopped working. As I don’t even use many of the features, I have to wonder how bug-filled the software really is…

Community Member

Thank goodness it isn't just me, I'm slightly relieved to learn others are having similar issues. 

This simply isn't good enough, hopefully this is a technical issue and not another feature withdrawal. I'm still incredibly annoyed about group volume controls and other functionality that has been removed. 

Unfortunately, I am heavily invested in the Google ecosystem, so feeling trapped, disappointed and angry by the constant erosion of service and functionality.     

Community Member

Ah yes, the key is we believe and hope Google has "an" ecosystem, akin to our friends at Apple and Amazon.  This is a simpy false. (let alone that Google cares for its customers)

Google is a series of strategically unaligned competitive microcosms.  All ignorant of the other, blown in different directions by marketing and tech geeks, often eating and destroying the other as they all evolve, without guidance nor care for the inhabitants of each microcosm.  

As an inhabitant of several microcosms, I find the reality brutal, as I watch my investment of time resources and hard cash, dissolve into dysfunctional discontinuity.

I won't even bring up the joke of coexistence between Ring devices (advertised as Google Home compatible) and the Google heap. .. a simple infinite bending of the truth.

Let's face it Google struggle working with Google based products, there is small hope for inter-ecosystem compatibility.

I too hate my decision to invest in the Google space, and similarly feel trapped.  I hate worse the jibes from Amazon and Apple customers laughing at our ever repeated pain and anguish.

The cheetah doesn't change its spots, I do not expect Google to change its philosophy of care toward its supporters, nor cease generating newer microcosms that eat existing stable ones,   It seems nonsensical to Google to evolve one, harmonic, compatible ecosystem, that actually works as promised, having stability and longevity.  This builds brand loyalty, like Apple's  Google's brand is rapidly sliding into the pit,, they simply don't get it and perhaps never will.

Community Member

Same issue here - cannot play to a group from a spoken command. Casting to the group directly works.... But clearly that doesn't help spoken commands or routines. 

Community Member

On top of the major speaker group issue, I'm finding a lot of spoken commands don't work anymore.

The growth of other AI like chatgpt is making the Google assistant look useless! I'm thinking I've wasted thousands on google devices.

Community Member

Similar issue, as of yesterday my google devices refuse to recognize speaker groups to play music on...   "Play music on the main floor" results in a "Sorry I didnt understand" when its worked for the last two years Rebooted, checked firmware versions, everything but no luck. This is one of my favorite things about these things and if its not working any more well, that just sucks.   11 speakers, 8 nest mini version 2, one google mini version 1, one google nest display, and a sony waterproof one and two days not working 

I did this mistake also. Had that many Google products and zero reliability. What I did was throw them into trash and bought Few Apple smart speakers. Yes it was expensive change, but my life expectancy skyrocketed.

Community Member

My Speakers group functionality also went flakey.  I have two Chromecast Audio's (little pucks that have a 3.5mm output) and use to be able to stream SiriusXM to both at once.  Now when I ask google to stream to "speakers" it sends it to the last one on the list in the group.  Both work, because I can tell it to stream each .

Going to try the work around listed above.  (EDIT: the work around above works)

Community Member

Having the same issue as well here. Voice commands to play on speaker group fails. Command setup in routines work intermittently so that could potentially be a workaround is to build a command over top of the command possibly? 

Community Member

I have been having the same issue since yesterday. My assistants don't seem to recognize "play this on x speaker" or "play this on x speaker group". Manually casting from Spotify to the speaker or speakers works fine, but the voice commands associated with that action are not recognized.   

Community Member

Same issue here since Tuesday.  Cannot use voice commands to cast to a speaker group for any type of music-- Pandora, Youtube Music, radio streaming, etc.  I can get it to play on a google nest display, then use the cast button on the screen to cast to a speaker group.  Casting youtube music and Pandora by phone using the cast icon works too.   But voice commands and routines no longer recognize any speaker groups.  I have deleted and created new ones to no effect.  

Community Member

Action taken, not fixed.
This Reddit page talks about confirming all your nest/GH speakers are on the same wifi radio if you have dulal 2.4/5g radios.  I had originally set all of them up to use my 2.4 SSID.  In fact, my older devices *used* to only be compatible with 2.4g, but I noticed that several of them were connected to my 5g SSID-- HOW?  

I removed the devices and connected all of them back to 2.4, confirmed that ALL of my nest/GH devices are using 2.4g, and rebooted all of them again.

Still no resolution.  No nest/GH device is even aware of a speaker group.  I command "hey google, play <radio station> on <speaker group> and it tells me that it doesn't know how to help me with that.  My nest display says something similar and displays a google search.

Again, I can at least start an audio stream on the nest display, then use the cast button on the display screen to cast to the speaker group and that works.  

But, voice commands and routines still do not recognize speaker groups.

Community Member

I've tried a few things now, including switching my Wi-Fi to 2.4G, no difference whatsoever. 

Contacted Google and like the rest of you they've denied all knowledge of this issue and suggest I reset my entire system again and associate all 69 devices back to a new home.

I wouldn't waste your time with Google support services as they have absolutely no idea what is happening.

Yet again appalling service from Google, who persistently show a blatant disregard for customers.    

Community Member

I'm having the same issue when it worked just fine a few days ago and for years.  At first a few still worked but after power cycling everything now no speaker group will cast from voice at all. It says sorry I dont understand or it plays music on a single speaker instead. Please fix this Google.

Edit: I contacted support and now they are saying they are aware of this issue and are working on it. They don't have a time frame though so its anyone's guess when this will be fixed. I hope soon though.

Community Member

I can't believe they still haven't replied with a fix for this yet...

Community Member

No fix yet on my end either.

Community Member

UPDATE 2/21/23: It seems to be working now!


A few days ago I noticed I cannot send music to other devices in my house. For example, "Play jazz on office speaker" replies "Sorry, I don't understand." If I'm at the office speaker and say, "Play jazz," it works fine. This happens on my Nest and mini devices. My default music service is YouTube Music. Ugh 😞

I think this pretty much sums up everyone's experience here.  This subreddit led me to this forum.    I started experience these issues early last week.  Google searches for this most recent issue haven't been that great-- primarily because of ALL the other associated and similar problems with nest/GH speakers since the Sonos lawsuit bubble up with any Google search.  

But, you're definitely not alone and it's not just happening to you.

Community Member

I'm starting to see more relevant Google searches related to this problem, which seems to span a consistent group of related symptoms.   

Community Member

Community Member

I just ended a support chat session that I started on

Pretty straightforward, I scrolled to the bottom and chose the "Contact Us" button, which led me to a simple form to identify the product-- in this case, "Google Home" then a brief description, which I wrote, "Google home voice commands no longer work with playing audio. Speaker groups no longer recognized."  

This led me to a lengthy chat with tech who had me create a new "test" home and move my speakers into it, then create a new speaker group and try to initiate voice commands to play audio.  Sadly, it did not work.  The tech had me hold for about 3 minutes while they spoke with their "senior support."  The tech came back and this was our exchange:

5:20:34 <Google Tech>: I have checked with my Senior Support and this is an emerging issue that we have
for audio group.
5:20:55 <Me>: any resolution eta?
5:21:14 <Google Tech>: As of now this issue is still under investigation.
5:21:23 <Google Tech>: Here's what we're going to do.
5:21:34 <Me>: is this documented anywhere on in Google's Support portal?
5:21:37 <Me>: okay
5:21:41 <Me>: standing by
5:22:02 <Google Tech>: First, I would like you to send a feedback by using a voice command "Hey Google
send feedback."
5:22:16 <Google Tech>: Then say this keyword GHT3 Unable to play music on audio group.
5:22:26 <Me>: okay, one sec while I do that
5:22:36 <Google Tech>: Sure! Thank you!
5:23:23 <Me>: issued
5:23:45 <Google Tech>: After that, I will escalate this case to Higher Tier of Support for further updates on
their end, you can still use the email that I have sent if you need assistance or updates about
this issue.
5:24:07 <Google Tech>: Once I have an update from the team, I will email you with the details.
5:24:09 <Me>: i would like updates
5:24:14 <Me>: thank you
5:24:59 <Google Tech>: No worries! I will take care of this case for you and update you, kindly give the
team atleast 24-48 hours for a response and I will send the details to you.
5:25:08 <Me>: thank you. may I have a copy of this chat?
5:25:20 <Me>: is that something you can email to me for me to remember what we did?
5:26:05 <Google Tech>: Sure, one sec


After a little Googling on that feedback code, I believe it should work for others.

For those of you who have about an hour to give away, I was issued a reference number and sent an email, so that's probably close to a "ticket" and something most likely tracked by their support tiers. The more of those coming in from unique users *may* help get more visibility to Google.

Cool, I've just sent it from here too, thank you for sharing this...🙂

Community Member

Have the same issue.

Music does not play with command “ok google play music on {device name}” or “{speaker group name}. But command works if a manufacturer name used (e.g “play music on Chromecast  / JBL Link 10”).


Important: everything work as expected if a command is sent via Google Assistant App (iOS), while Google Home Mini does not recognize Device/ Music Group names (e.g. Balcony speaker), though recognizes individual manufacturer device (eg JBL link).  Curiously, in the reply Google Home calls the device with Device name, not manufacturer name.

Community Specialist
Community Specialist

Hi folks,


This is not the experience we wanted you to have, let us help you. A few things: which Nest speakers are we working with? When did your issue begin? Were there any recent changes made? To the ones who did the reset, was it the same steps as you see in this link? What are the commands you've given and what is the error message?


It would help a lot if you could do a sequential reboot first: 


  1. Unplug the power cord of your router followed by your Nest speakers.
  2. Plug them back in after 3 minutes tops.
  3. Restarting your phone might also help.


Once done, change the speaker group name. Follow the steps below:


  1. Open the Google Home app.
  2. Tap the speaker or speaker group that you wish to change the name.
  3. Tap on the gear icon at the top-right corner to open the Device settings page for the speaker.
  4. Tap on the Name option.
  5. Customize your speaker's name and tap SAVE to continue.
  6. Do the same on individual speakers and try the command to play music.


For more information, see this guide.


Tell us how it goes.



Community Member

Hi Dan,


I have one Gen 2 and three Gen 1 speakers, I haven't changed a single thing and un until a few days ago, everything has worked for a few years without a single issue, then a few days ago all I get is the "sorry, I don't understand" message...


I have done the reboots and resets, changed the group names, but still get the "sorry, I don't understand" message, I can start music going on one speaker and then add the others using the Home Assistant app, but it doesn't using voice commands...





Community Member

Hi Dan, 

Thank you for the reply and suggestions. 

The issues start approximately two weeks ago, no changes to my Google Wi-Fi setup or speakers for at least 12 months. 

We have 2 Google Max Speakers (stereo pair), 2nd generation Nest Displays, 1st generation Nest Display, 2 original Google Home Speakers and 1 Nest Speaker. All have worked flawlessly with speaker groups for years. 

We have a couple of speaker groups "All Speakers" & "Bedroom Speakers" these could be chosen by using the following commands  "Okay Google, play xxx on 'xxx speakers'". 

I have restarted my Google Wi-Fi multiple times, all speakers have been restarted repeatedly. 

I have even gone through the lengthy process of factory resetting all speakers and starting from scratch with a new home and renaming all the devices. 

None of this has worked and Google continues to respond with the infuriating "Sorry I don't understand!" this issue also impacts any routines that contact speaker groups, causing the routine to stop mid-instruction. 

My Galaxy 22 Ultra & Z Fold 4 have been restarted multiple times during this time.  

Looking at the responses in this thread it is clear to see there is an emerging issue that is impacting users. The help received from Google has been less than satisfactory, with employees suggesting there's no known issue before repeating the standard fix mantra. 

I'm very disappointed, and while I don't expect an instant fix, it does feel like the biggest battle is to get Google to acknowledge there's an issue in the first place.    

Thanks for the suggestions all the same Dan, I appreciate your time. 

Community Specialist
Community Specialist

Hello everyone,


Awesome! Glad to hear that this has been sorted out and thanks for sharing it in the Community. Thank you for your patience.


Could the other Community members also confirm if the issue is fixed on your end?




Interesting that the Google assistant app on ios works - seeing same behaviour. 


But on Android or via the Nest/Google devices themselves, see the 'sorry, I don't understand' behaviour. 

This 😄 Maybe the whole G-Men issue in one post. EVERYTHING works in Apple etc. But Google's own products won't work in Google's own OS. 😂

Community Member

Just started working again for me....