Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Can't enter serial number

Community Specialist
Community Specialist

Disclaimer: This thread was migrated from our previous version of the Google Nest Community. You can continue to receive updates on your thread issue here or simply ask, browse or more in the new Google Nest Community.

Original Poster: Tracy Foor 

CAn't enter serial number into app

104 REPLIES 104

Community Specialist
Community Specialist

Hi Tracy,

We're sorry to hear about your setup issues! We know the installation process can be quite a frustrating hassle. Let's work together on this.

Can you clarify a few questions for me?
- Which model of thermostat do you have? (Nest Thermostat, E, or Learning)
- Are you receiving a specific error message on the Google Home app, the Nest app, or your thermostat's display?
- Are you the original account owner of this thermostat, or rent/own a home with a Nest Thermostat installed?

I look forward to your reply. We're happy to help get your thermostat online!

-From Garrett DS, Community Specialist.

Community Member

I have the nest learning thermostat

I entered the key and the app says to choose the number matching the display, and there are no numbers to match to on my phone app

Community Member

Why are you asking about a thermostat?  I have the outdoor wireless camera

Community Member

Learning, it is mine. Just bought it

I have a nest camera

Community Member

Nest thermostat, I get to page to select serial number and screen is blank

Same with me. This is 6 months after you!


Scanning Qr code doesn't work. Pairing error. I presume everyone else has tried scanning, it doesn't work so are trying to add manually. But the input page has  no entry box. Nowhere to input numbers. Just says enter 14 digit key, then doesn't give you anywhere to input it. 

Who'd have thought trying to connect one goggle product to another would prove so problomatic@

I have the exact same problem. It asks for the last four digits in the serial number and then there’s no place to enter it. These cameras are pieces of junk. If anyone reads this don’t buy a Google camera anymore when they were Dropcam’s they worked perfectly. I’ve had them for over 10 years now that it’s gone over to Google it’s terrible and you can’t get any help from customer service. They just ignore you.

Did you ever get any help or find a customer service number that can help. I’ve not heard back from them since April 23, 2023

Yeah, they replied talking about ring doorbell, which is not even what I was asking about. Absolutely useless customer service.

Did you get this resolved? If so, how??

Community Member

in my case it was due to me confusing a zero with an O. 

Community Member

in my case I was confusing zero with the letter O. 

I never did get it resolved. Can’t use the camera. I think the issue is if you buy a used camera you’ll never be able to connect it to your own Wi-Fi. It’s just a guess on my part but I’ve heard it before.

Community Member

Same issue for nest cam. Stuck and can’t complete setup

Having same issue with the nest learning thermostat, how is there no response to this!!!!!????

camera not thermostat

Community Member

It allows me to put in the six digit.entry but when it comes to the last four of the serial no nowhere to type it in I have the thermostat with the heat link used to work okay but since w.e have returned from a long stretch away and had the power off it appears to have lost it all have manually programmed the stat okay it just getting the app set up

Community Member

I have the exact same issue. Added a screenshot.


I have a nest learning thermostat. I doing setup, it wants me to select a number from a list in the app.  I don’t see it.


I think this can happen if you mistakenly attempt to install a Nest Learning Thermostat in the Google Home app rather than the Google Nest app.

It loads fine in goggle nest app. Which is supposedly defunct. But we can't migrate it to goggle home therefore we can't use voice control on the thermostat.


When you install the Nest Learning Thermostat in the Google Nest app, it is supposed to AUTOMATICALLY appear in the Google Home app, provided that you're logging into both apps with the same Google (gmail) Account and have assigned the thermostat to a "room".

However, in recent months many customers in this forum have reported this isn't happening. Many of these customers have used this workaround to fix the problem: In the Google Nest app, create a new, temporary Google Nest "home/structure". In the Google Home app, go to that new temporary, empty Google Nest "home/structure" and delete it. This action seems to force the 2 apps to sync and the thermostat then appears in the Google Home app.

This work around worked for me. I don't know if it was a coincidence or whether Google supplied an update fix. But I now have Nest synced with my Alexa,although Alexa shows the temperature in Fahrenheit instead of Celsius... Still, small victories. So many thanks for your suggestions. ☺️

As soon as I created a new "fake" room. It automatically added the Google NEST and it was accessible through Google Home and I could control it through voice through my Google Mini. Easy fix 🙂


Not original owner. Best outdoor camera with a solar oanel

Community Member

Nest Learning Thermostat. Just cannot get the list of last four digits of the serial. Original account holder and it is a new thermostat.

The app can not find the serial number.

Just keeps circling the wagon!




The Nest Learning Thermostat and Nest Thermostat E get installed in the Google Nest app and the Nest Thermostat get installed in the Google Home app.

As stated before. Yes can install to nest but can't voice control. Why are goggle forcing us to install their equipment on a system that has supposedly been superceded by nest?

Community Member

Learning thermostat no error message and I am homeowner

Community Member

It’s not a thermostat it’s a camera. Which I indicated at the start of this most painful process. I have entered the set up code. Next the app asks me to choose the last four of the serial number from a list but the correct serial number does not appear. 


Regarding your attempt to install your camera, this seems to be your first post in this long thread on thermostat installation, so there does not seem to be anything you've indicated yet in this "most painful process".

You could make sure you're using the appropriate app for the install. If you try to install one of the older Google Nest cameras (those that only get installed in the Google Nest app) in the Google Home app), or if you try to install one of the newer Google Nest cameras (those that only get installed in the Google Home app) in the Google Nest app, you can get the result you're reporting--no serial number listed.

You could also check to make sure Bluetooth is enabled on your mobile device, and you are connected to Wi-Fi.

And if you are re-installing a previously used camera, you could make sure it was previously removed from the Google Nest app or Google Home app (as appropriate), and was successfully factory reset (

Community Member

They stated it was a camera several times-and the support response came back with the fix of a thermostat.

I just had the same issue and it is time-consuming and painful. My issue was that I was using an O instead of 0 for the code. Instead of an error message, it just sits there and does not display the list. 

Community Member

It is a nest camera

Community Member


I own the house