cancel
Showing results for 
Search instead for 
Did you mean: 

Can't link xiaomi home and google home anymore

Kamoulocks
Community Member

Hi,

I'm able to link my xiaomi home account and my google assistant.

When i try, i got a error message that tell me this :

could not reach mi home, please try again.

Tried to reboot the phone, uninstall/reinstall Xiaomi home app and google home app.

It suddenly stop to work so i deleted the link between the 2 account and now i can't make the setup again, always the same error message.

 

Any tips please ?

 

Thank you.

557 REPLIES 557

Andy4
Community Member

You have to link with yeeligth

Unfortunately that only looks like it works for lighting systems and nothing else. 

Cowiez
Community Member

Link the smart things with yeelight

Later, instead of mi home, Google home recognize device tru smart things 

I don't get the bulb listed after getting message yeelight account linked but my yeelight app has bulb listed. Can someone help? 

Stili
Community Member

This one worked for me!!!! Thank you!!.

"Link the smart things with yeelight

Later, instead of mi home, Google home recognize device trought smart things."

Locke
Community Member

Same problem today 03/11/21. Cannot link to google home that show offline. Mi home app can use.

Thailand

Janph76
Community Member

Same here in Thailand. Deleted “No Responses” device and can no longer link Mi Home back to google home

Kitachi
Community Member

Just bought a Xiaomi IoT, and can't link it to Google Home... How glad am I to see this thread... 🙄

hmcontreras
Community Member

I have the same problem. I did the same thing, I tried to link my Mi home app to both android and iOS but it keeps on crashing. 

Mafoeta
Community Member

Same here. But I can control my lights from the MiHome app

Because you're controlling the lights directly - not using any third party software. This problem is on Google's side.

JASCISC
Community Member

igual en México. 

juouyang
Community Member

Same here and did the same thing. Unlinked and now cannot reach

Force to install Mi Home App, and since i bought my plug in china, i have to login as china to control the smart plug with Mi Home App

 

 

 

kcifuentes
Community Member

Same Problem! 😥

touchingewe
Community Member

I have the exact same problem.

amitsamson
Community Member

Hello community,

Since last night all my Mi Smart Devices stopped working on Google Home app and couldn't be controlled using Google Nest Speakers.

I tried to "Reconnect Account" and also tried to "Unlink account" and add again.

Getting error: Could not reach Mi Home. Please try again.

Tried clearing the app data; restarted the phone and google home devices; uninstall - reinstall Mi home and Google Home app. Still facing the same issue.

Is it just me or others are also facing the same issue?

@GoogleNestTeam, please look into this on priority.

Google Home - Mi Home connection errorGoogle Home - Mi Home connection error

LyRa
Community Member

I have the same problem.
Unlinked Mi Home account to resolve different problem and can't link it now.

EM
Community Member

Me too

NirG
Community Member

I'm also facing the same issue 😞

My Mi lights stopped responding, so I unlink the connection to Mi Home and since then I can't re-link it.
Tried to reboot my device, uninstall the Mi Home App nothing works.

Is it a regional or global thing? I'm using the Mi Home Israel Region.

@GoogleNestTeam, any idea what's going on?

LilloHd
Community Member

Same problem in Italy

Me too!

Same problem in Romania

This worked great for me:

Install Samsung Smart Things App and connect Xiaomi Devices in this way:

Add devices: search by brand - Yeelight and the devices will be linked to Smart Things first

Then go to Google Home and add Smart Things.

Thank you for this workaround. It worked for me 

Same problem here. I'm from Europe, so... It's likely a global problem.

Same here since the night of 2nd of November, same error, from Mexico using Singapore region. 

Jeph
Community Member

Same in Italy, @GoogleNestTeam do you have news for us? 

Same exact thing. Israel region. 

Doubi
Community Member

Same here, not sure this is Xiaomi API issue or Google Nest Issue.

Doubi
Community Member

Same here ,any solutions?

Same here unlinked to add new Mi devices and couldn't link Mi home to Google home anymore from yesterday.

Reporting from Poland

ditto

Same, got a new Robo vac yesterday and have been struggling to link the Mi Home account to Google Home/Assistant since then. 

P.S: I am in Australia, so definitely a global issue.

If it’s a Roborock, you can load the Roborock app and pair that with Google to work. 

Me too, same problem in Italy

Same here in NZ. All my MI Home devices can no longer be linked. What happened?

Yang
Community Member

Same here in KR. Mi home App doesn't work now on Google home.

Ramon
Community Member

Same on Spain. Working with Samsung's smarthings but failing with mi home and meross apps.

NirG
Community Member

Is it not working only in Google home or you can't link it also through Samsung's smartthings itself?

*Trying to understand if this case indicate if it's a Google home issue or Mi Home issue.

LilloHd
Community Member

Hi only in Google Home