cancel
Showing results for 
Search instead for 
Did you mean: 

Google Home app crashes when setting up Nest Wifi Router

monica_c
Community Member

Trying to set up my Nest Router and the Google Home app keeps crashing when I try to go to the next step after the device has been found.

I’ve tried with different devices via Google Home app and nothing changes, it keeps crashing.

How can I fix this and set up my new Nest Router?

19 REPLIES 19

monica_c
Community Member

I’ve tried checking for updates, re-installing the app, quitting the app, signing out, as well as unplugging the router and rebooting it, but nothing changes.

After the device is found, when I hit next, it tries to load the screen and then it goes white. Can’t finish setting it up!

 

Navi2
Community Member

Mne robi to iste

Jeff
Community Specialist
Community Specialist

Hey, monica_c and Navi2.

Sorry for the setup issues you're having. That sounds really frustrating and confusing. I would be happy to help you both resolve this. Let's take a look at the situation.

Before I jump in too deep on troubleshooting, can you tell me what error you're getting, or is it just stalling out at the white screen and not giving any sort of error? Doe the app completely lock up, or is it just not progressing in setup?
If you can give me a little more detail with what you're seeing, I think we can get this worked out. I look forward to hearing back from you both. Thanks.

monica_c
Community Member

Hi Jeff! 
I get a blank screen. So once the nest router has been found, when I hit next, it tries to load with the loading icon over a white screen and then freezes on the white screen.

@monica_c Same issue here. iPhone 12 Pro. Newest software update (as of 12/20/2021) on phone. White screen after google home app finds the proper device. 

we’re you ever able to get a resolution?

No 😞

I’m still waiting for a reply.

monica_c
Community Member

Can you assist us please?

Jeff
Community Specialist
Community Specialist

Hey, everyone.

I know it's been a while, but we're still looking at this internally and I'm hoping to hear more about a fix soon. Until I hear more, I'll keep checking in on the thread and I'll post updates when I have news.

Thanks.

monica_c
Community Member

Any updates Jeff?

I’m still getting the white screen 😞

Jeff
Community Specialist
Community Specialist

Hi, monica_c.

I'm still waiting for an answer on a fix, but in the meantime let's try resetting your connection to the cloud services. Often times this will clear up those communication hangups. That process is below.

Open the Google Home app.

  1. Tap the WiFi icon.

  2. Tap Settings.

  3. Select Privacy settings.

  4. Toggle Nest WiFi cloud services OFF and wait for 30 seconds, then back ON.

Once done, close the Home app and perform a full network restart to ensure that the new settings are in place. To do this, I would recommend doing a power cycle on your network.

  1. Disconnect the power adapter and the Ethernet cable from the Nest WiFi router.

  2. Disconnect the power adapter from the Nest WiFi points.

  3. Disconnect the power adapter from the modem. Allow all devices to stay disconnected from the power for 5 minutes.

  4. Connect the power back to the modem only and wait for it to fully back up. All lights should be lit up before moving to the next step.

  5. After the modem is back online, connect the Ethernet cable back to Nest WiFi router's WAN port (globe symbol port).

  6. Connect the power back to the Nest WiFi router and to the Nest WiFi points. Wait until they're all fully back on.

After running through that process, try the setup again. If you're still stuck in the same spot, please let me know. Thanks.

monica_c
Community Member

Thanks Jeff.

I got it to connect finally following SebbyW’s advice to come back to the app after a few minutes, right after the white screen appears.

Thanks for your support!

Jeff
Community Specialist
Community Specialist

Thanks for the update, monica_c.

I'm happy to hear that you got this worked out. As we have our answer here, I'll go ahead and close up the thread, but if you need anything else at all, please feel free to start up a new discussion.

Thanks.

MightyD
Community Member

I’m experiencing the same issue

SebbyW
Community Member

I’m getting the same issue trying to setup, assume no resolution yet

SebbyW
Community Member

Managed to get it to work, after app stopped responding I left the app - returned a couple of minutes later to be prompted to enable the camera to scan the QR code- it’s all setup now. Hope you have the same luck

jyy
Community Member

same issue as everyone else, get a blank screen when selecting router setup

Landforce
Community Member

Same issue here as well. Cannot find a solution….

mttreed
Community Member

Same issue here. Have setup many Nest routers in the past. Typically so easy. This is frustrating.

mttreed
Community Member

Ended up with the same result as Sebby W. Left the blank screen, came back a few minutes later and the scan QR code screen appeared. Best of luck!