cancel
Showing results for 
Search instead for 
Did you mean: 

Google Camera with Floodlights won't finish installation

osujolly
Community Member

I have physically install the lights and camera. I have went through the set up and it gets the last step and "Something Went Wrong appears"

1. Both Camera and Lights appear in app

2. Floodlights can be turned on and off from app

3. During installation the camera detects a person

4. After failed installation, the camera is in app, but when clicked it asks to finish install or remove device.

I had a call from Google/Nest help, but they hung up on me about 30 seconds into explaining the above... Now I'm on hold again.

 

Please give me a solution or let me know if I need to return item.

1 ACCEPTED SOLUTION

osujolly
Community Member

After an hour twenty on the phone with a nest support person, we returned the device and got a new on shipped to us today. It took less than 5 minutes to install and work correctly

View solution in original post

8 REPLIES 8

osujolly
Community Member

I have tried the hold button on back until light turns yellow. It still will not finish installation.

mayrockcreech
Community Member

Having the same issue. Outdoor (battery) finally just came online but Outdoor wired floodlight cameras won’t “finish.” The lights are controllable but the cameras are not. AND getting alerts/notifications so I know they work but Google Home app can’t “finish” or control them.

Hbrendle
Community Member

We’re having the same issue. Three cameras with floodlights installed but the fourth is having the issue above. We’ve pressed the button on the back to reset several times, removed and reset from the app, moved the router to just under the unit but the same thing happens as above. Hopefully someone can provide a solution!

FedUpWNestSuprt
Community Member

Having the same issue. I’ve tried factory resetting the cam and reset wifi. I get to the point in the set up that it connects/reconnects and then when it searches for wifi network, it just craps itself.

SDSilva
Community Member

Same thing has happened to me. I have been trying to set up two. 

osujolly
Community Member

After an hour twenty on the phone with a nest support person, we returned the device and got a new on shipped to us today. It took less than 5 minutes to install and work correctly

Brad
Community Specialist
Community Specialist

Hey Folks.

 

I am relieved to hear that this issue has been resolved for the OP! At this time, I'll go ahead and lock this thread. If you're still experiencing problems, feel free to start a new thread and we'll be happy to help.

 

Best Regards,

Brad.

Roger_1
Community Member

I have the same exact problem