Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Camera with Floodlight not Connecting

Community Member

I cannot connect my nest camera with floodlight to my Google Home app, since it's gone offline, and i have tried: 

1. Resetting the camera, via the button on the back

2. Trying to add device from both my google hub and my iPhone

3. Uninstalling Google Home app on both iPhone and google hub

4. Resetting my internet 

5. Manually adding with code vs. barcode 

6. Disconnecting and reconnecting electricity to the advice 

All my other cameras are connected and working perfectly. The light on the camera in question works as normal, in that its triggered by motion. 

Any help or guidance would be great. 




Community Specialist
Community Specialist

Hi Daraflats,


Thanks for reaching out here in the Community. To know more about this issue, I’d like to confirm, how long did you press the button at the back? What is the light status of your Nest Camera? 


Give these steps a try:

  1. Locate the reset pinhole on the back of your Nest Doorbell.
    Tip: The reset pin on your Nest Doorbell (battery) is located below the USB port on the back of the doorbell.
  2. Insert and hold the pin (you can use an unfolded paperclip or a thumbtack):
    • At 10 seconds, the status light will blink yellow four times, and you’ll hear a countdown tone.
    • At 12 seconds, the status light will be steady, solid yellow while the doorbell starts the factory reset, and you’ll hear a confirmation tone.
  3. Release the button. Your Nest Doorbell will restore to its factory settings.
  4. After the factory reset, your Nest Doorbell will appear as “Offline” in the app until you remove it.
  5. To remove it from the app, open the app, then tap Settings Nest settings icon Remove device Confirm.

Hit this link for more information and looking forward to your response.




Hello - i've tried resetting via the back button 5/6 times, including following the instructions you laid out. The camera still won't connect, when i go through the add device process, it always ends with 'something went wrong' 

Community Specialist
Community Specialist

Hi Daraflats,


We’re sorry to hear that. Let’s check this out — could you fill out this form and let me know once you’re done?


I appreciate your help, Emerson.




Completed. Thanks 

Community Specialist
Community Specialist

Hello Daraflats,


We got your form — thanks for filling it out. Our team will reach out to you via email to further assist you.