Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Doorbell will not power up after reset

Community Member

Changed address and connected Nest Router to new network.

Doorbell would not connect after several attempts even trying to set as new device.

Reset unit and now unit will not power up.




Did you hold down the reset button for at least 12 seconds, using these instructions?

Have you tried charging the doorbell?


Hi, the doorbell is fully charged and yes, did follow both options as indicated in the link.

when connected to the charger, the white light is visible. When disconnected from the charger, that white light disappears and there is no response from the doorbell when either of the options used.


You could try contacting  Support:

Community Member

Thanks for your advice.

Got onto support and instructions quite different to those available when searching. 
Using a paper clip to do a factory reset, insert it in the small hole located on the back of the camera, between the charging port and screws. Hold till you hear an alarm, twice. Takes about a minute. Then via the app, tap + symbol, then select Set up new Device and follow the prompts.

Problem solved 


Community Specialist
Community Specialist

Hi folks,


CNV1, perfect! We’re glad to hear that it’s been sorted out. As we got our resolution here, I'm going to mark this thread as complete. I'll be locking this thread if we won't hear back from you again in 24 hours. Should that happen, feel free to create a new one if you have more questions or have other concerns in the future. 


Thanks for the help here, MplsCustomer!