Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Where do Nest Cam Videos go when downloaded from the Google Home App?

Community Member

I have to start with saying that I absolutely hate the Google Home app for the Nest cams. The lack of a browser interface is frustrating enough, but the crappy UX in the Home App is just insult to injury. But I do have a legitimate question....

Using the Google Home app, I view one of my cameras and find activity. While viewing that activity I have the option of downloading that clip. I did that. Many, many times. Where does it go? It's not in my photos or videos on my iPhone, and it's not in my "Files" folders. Did the app really save the clip? Or is it just toying with me? (I feel like it's just toying with me).




When I download clips on my iPhone, they go into my camera roll, and it also appears in Photos. The first time I did it, I was first asked to grant Google Home permission to access Photos, and I still get a version of that question when I download clips.  The message also says "Google Home needs permission to use your camera in order to scan your card."


Community Member

Thanks for the reply. I did that, but they're still not appearing in my camera roll.


When you say "I did that", what did you do?

On my iPhone, I have two ways to download a clip:

1. I can view the event, select the "More" icon (the 3 dots) in the upper right, and select "Save clip to device".

2. I can select "Event details" and click on the "Download" icon in the upper right corner.

The clip is downloaded to my camera roll after displaying the message I included earlier.

The first time I downloaded a clip, I was asked something about whether I wanted to give the Google Home app permission to access everything, or just the photo being downloaded. I can't remember the exact wording, but I selected the latter. Since then, I get the message I included earlier, and I select "Keep Current Selection".

Community Member

What I see is a hamburger menu on the bottom right. When I click on it, "Save Clip" is an option. I click on that, it asked me if I wanted to give Google Home access to my camera roll. I said yes. It then said "Downloading..." but never downloaded. This was when I first posted last night. I did it at least 5 times.

I tried again just now, and it works (saved to my camera roll).


Community Specialist
Community Specialist

Hello everyone,


@turbojimmy, thanks for getting back to us and we're glad that it's resolved now. We’ll consider this one complete so let us know if you have other questions or concerns as I will be locking this after 24 hours. Feel free to start a new thread and we'll be happy to help.


I appreciate the help, MplsCustomer.