Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Can't cast SiriusXM to any Chromecast device - error 1001

Community Member

Was scouring the internet for the particular error that I'm getting, but haven't found a single case that is recent or relevant.

The problem is that I can't cast SiriusXM via mobile app or desktop browser to any of my Chromecast devices. This includes speaker groups and Chromecast Audio devices.

Any time that I try from Chrome (have tried Edge as well), I select the cast button, then I select a device, I hear the device "connect" (it plays that little tune) and then I receive this error:





Chrome Version 100.0.4896.75 (Official Build) (64-bit

If I try to cast from my phone, I get the same "Oops, something went wrong" message, but I don't see the error 1001 on it. It appears to be the same error though.

Oddly enough, I can stream just fine from other sources, like or whatever. I have disabled ad-blockers, pihole and anything else that might be causing this to no avail. Mind you, I've been casting SiriusXM for years, but it just simply stopped working a couple weeks ago.


Anyone else have this problem?


I do seem to be able to cast my entire screen from a desktop computer to a Chromecast device and SiriusXM will play through the TV, but that isn't where I want to listen to music.

On a side note, I have called SiriusXM support and they were unable to resolve. We removed the app on my phone, removed the streaming source from Google Home and re-added it, logged out of my account, logged back in, etc. I knew these troubleshooting steps wouldn't help, since it wasn't working via desktop browser either, but we tried.

I have posted on Reddit as well just a little while ago, but figured I should post it here instead.

1 Recommended Answer

Community Member

I'm honestly shocked but disabling the cast integration on my home assistant setup restores the ability to cast:

View Recommended Answer in original post


Community Member

Glad you got it working again. Still failing here. I do have a ticket open with Sirius (after much pushing), but they've been radio silent on that ever since. Not sure they took it seriously.
I have sent feedback from GHome app and put the CCT3 tag in the body, so we'll see if that leads to any results. It is interesting that Unifi seems to be a common thread (At least for the few that reported their network config). But weird that it impacts Sirius and nothing else.

Community Specialist
Community Specialist

Hello JvdMaat,


I appreciate you for sending feedback. I'll update this thread once I hear from our team. Thanks for bearing with us.




Community Member

same issue here

Community Member

Late to the party but I am also experiencing this error with SiriusXM app as the only app failing... I'm casting to a speaker group. But individual devices fail also. Using a TP-Link Archer AX11000 router and have one Netgear R7000 in AP mode... The last time I remember casting SiriusXM it worked but this was many months ago.

Anybody have any luck with this?

Community Member

I am having this problem too with the Sirius XM app on Android . I always get a "Chromecast error" when trying to cast to one of my 15 Chromecast audio.

My router is a Comcast XB7 . Access points are Unifi NanoHD.

Most of the Chromecast audio are wired via Ethernet (with USB NIC), not using Wifi. The phone is obviously using Wifi, though.

Community Member

same problem 😞

Community Member

Same issue here. On UDM pro router and cannot cast SiriusXM. Everything else works fine.


Community Member

Sorry Guys (and Gals). Still a problem for me as well.  Haven't heard a thing from Ubiquiti support on the forum yet and it's been several months.  Maybe if we flood their forum we may get someone to actually look into it. At this point, it doesn't seem to be a Chromecast issue, seems to be related to UI stuff and for only SXM for whatever reason. Check out:

Community Member

I just disabled the SSID on my 5 Ubiquiti NanoHD and U6-LR .

I enabled Wifi and the SSID on my Comcast XB7 router.

I still could not cast the SirirusXM app from my S22 Ultra smartphone to my Chromecast audio, or to my Chromecast with Google TV. Both of them are connected to the network via Ethernet, BTW.

Only the phone was connected via Wifi, to the Comcast XB7.

This tells me that the Chromecast issue with SirirusXM isn't specific to Ubiquiti Wifi access points or routers .

I experience the exact same issue on a ubiquiti network at one location and a Samsung connect wifi network at another location. Definitely not a ubiquiti network issue.

Community Member

@Txwindsurfer and @madbrain 

Hard to say what's to blame then.  Would be great to finally find a culprit though!


I think it's just a bug in the SiriusXM app.

the app AND the website?

Community Member

I have had the same issue for a very long time with both the Sirius App and the website.  I have an Asus Router and Access Point.  I have enabled everything I can imagine to get this to work Mutlicast, IGMP Snooping, ... 

Everything else works fine casting (every once in a while a cast from another app will stop for no reason, but I can always restart them).  SiriusXM is the only one that I consistently can never get to work from my phone or browser.

It works if I ask the device to stream SiriusXM directly.

I have contacted SiriusXM multiple times about this, left them bad reviews, been told someone will help me multiple times, but I have never had a single suggestion from them on how to fix it.

I kinda feel like it is an issue with the number of streams limit, I think Sirius might be a bit to aggressive with that and the handoff from the device to to chromecast device breaks because of it.

Community Member

I cannot cast to any Google home devices either from my Sirius XM app. Keep getting CC-101 error on the screen.

I have found a work-around!!!  Instead of using the SXM app directly and then casting it, I have found that if you use the google assistant it works - go figure.   I just use my phone and do this:  "Hey Google, play Sirius channel xx on 'chromecast device name' ", that it works perfectly.   Kinda points the finger at a problem in the SXM app - I know, shocking.  All I know is that this method has worked perfectly for me - use it every day.  Hope it helps some of you.

Community Member

I'm having a similar problem but it's only with the SiriusXM Xtra channels. The others I can cast without issue. I used to be able to cast the Xtra channels but recently changed my subscription type from streaming only to streaming plus car. Not sure if that caused the issue.

I have the same problem, have you found a fix?

Yeah I cancelled Sirius. Their support does not care.


Yes, I still have the same problem. I'm casting a regular numbered channel on four speakers right now but still can't cast any of the Xtra channels.

I have talked to SiriusXM over the phone and they acted like they have never heard of the problem before. I got an email after the phone call 

We received your inquiry about your unresolved issue. The Corporate Solutions Team is handling your case 071823-****** which is currently under investigation. We will contact you soon and you can expect a response within 1-3 business days with a resolution or an update. 

Thanks for letting me know. I'm very interested in what your hear if in fact you ever hear anything.

Community Member

Probably 3 years ago, I complained in my review of the SiriusXM app in the Google Play Store.  At some point, SiriusXM responded to that review and asked me to submit a detailed bug report to an email address.  I did that, with pictures and a detailed explanation.  No response.  I followed up 2 or 3 times and still nothing.  

Super unfortunate but not at all surprising. 

Community Member

I'm going down this rabbit hole again.  I just had to cancel my subscription because of the insanely high price to get a discount (you probably know the annual drill). I was browsing around the different support pages on SXM's website today and happened across this page:


online account center.jpg


After clicking the Online Account Center, I received a page that showed that I had two accounts.  One was the initial account with some random username and password that Sirius generated for me. I remember years ago that something happened where I didn't remember the password and I had to get a password reset.  Around that time, I think that's when my Casting stopped working.  I feel like the account using my email address and password that I'm using now to login is what is preventing me from casting.  I'm going to work with support to see if these two accounts can be merged somehow or if I can try signing in with the random username that they provided to see if that gets casting working again.


Anyway, the URL is:

And when I view that address when logged in, I see two different accounts:




Working with support now. I think when casting was working, I was logging in with the ****yXkW account and now that I'm using my email address, I can no longer cast.  Wonder what you all are seeing when you login to the Online account center? 


EDIT - Sirius Chat support didn't show any other account numbers associated with my account, which is what I believe is causing our issues. Somehow there was an original account generated when I first signed up for streaming, then some sort of password reset created a new account and that one won't allow for casting it seems.  Will call into support tomorrow to see if I can get anywhere.  I attempted to upload screenshots to the chat with support, but they all failed to upload (go figure).

Community Member

I had the same thing with multiple accounts a year ago. I had them fix all of mine about a year ago. The problem with streaming the Extra Channels started about 2 months ago.  We have 4 different radios on our account and each one has a Streaming Log in, we each have the same problem on each log-in.   We would stream the 80s on 8 Workout channels every day, then one day it did not work. I thought maybe it would get fixed at some point then we tried to stream other extra channels and none of them worked. We can stream the basic channels you can listen to in the car.

I have logged out and changed accounts on both the Google Home link and the Apps. I'm running the app on both my Android phone and Windows computer.  I have 3 different home setups in Google Home and none of them will stream the extra channels anymore. 

Community Member

Just called SXM support, they weren't very helpful and disregarded the fact that I had multiple accounts, they escalated to their support team and said they'll call me on Monday for a follow up to see if it's still a problem.

Community Member

I'm honestly shocked but disabling the cast integration on my home assistant setup restores the ability to cast:

holy cow dude... I didn't even know that was enabled but that fixed it for me as well!  been over a year without being able to cast and now it works.  Thanks so much for the tip!!!

Community Member

That fixed it for me three !

Well, "fixed" rather, since I use the HA automation to automatically turn on my amplifiers when a Chromecast Audio starts playing. Disabling the HA cast automation means I have to turn on the amps manually, and thus isn't a real solution.

So funny that after over a year we're finally figuring this out.  Had no idea that HA could even be involved in the casting process, I'm still shocked! However, for you, is there a way to maybe just plug in a wire to your amps to physically trigger them? Luckily, my Yamaha Receiver includes a remote 12v trigger output for my amp. Understood if you like HA doing that for you instead, or don't have that ability, I get it.  Hopefully the HA developer can figure out a fix in the near future, now that we know that it's breaking things and have it documented. 

I use 4 receivers with 7.1 multi-channel inputs and 12 Chromecast audio. 3 CCA on each receiver. Even if each receiver had a single 12V trigger, I would need 3 12V triggers per amp.  And the CCA doesn't have trigger out either, anyway. So, I don't think there is a hardware solution to this problem. My solution is to have the amps on smartplugs, and HA powers on the right amp when the HA Cast integration detects that any of the 12 CCA is playing.

It works fine when I cast from Plex, or cast device audio from Android. Just crazy that it breaks SiriusXM.


Wow sir, you have an impressive setup then! I can't imagine you using this in a "home" setting but maybe a business. I like your solution though, sounds like something I would do!  Smart plugs are worth their weight in gold. Let's just hope the developer can figure out a fix.

I'm using HA / CCA and SiriusXM n a home setting, in a mansion.

The receivers were basically free on craigslist (older, non-HDMI models). The CCAs were cheap enough. Getting all that software to work seamlessly is a PITA. I also hope a workaround will be found that allows HA to coexist peacefully with SiriusXM.

This is an incredible find!  We have been round and round trying to even find the cause, let alone a solution.  I will also add, in addition to HomeAssistant, I also use Homeseer and have the HS4 Chromecast plugin installed.  This plugin also blocks the cast function for Sirius.  I have notified the developer, but you can imagine what I felt like when just disabling HA, and it did not solve the issue.  Went over to HS, disabled, and casting worked!

I assume there is a standard implementation that these developers use, and it does not play nice with Sirius.  Or maybe Sirius is the culprit.  Regardless, I really hope the HA and HS devs can find a workaround.

Thanks to everyone for not giving up!

Community Member

We're fairly certain it's pychromecast - HS4 is probably using it too.

I opened an issue on their github:

Just casted SiriusXM on my bedroom speaker for a second just to watch it work. Crazy to think how long it hasn't worked and what the problem was.

Glad it's working again though and I finally have an answer to why it stopped in the first place.

I was really hoping this would fix the problem.  Unfortunately, it hasn't for me.  I disabled the Cast integration in home assistant and rebooted.  And again, if I use the SiriusXM app on Android or the web interface with any browser I get the message: "Opps. Something went wrong. Please try again."  I can play on my cast devices by telling Google Nest speakers to play a particular channel from SiriusXM on xxx speakers (where xxx is the name of a cast device).  But from any app or program trying to cast to a Nest or Google speaker will not work.  Ugh 😬


Ugh, I'm sorry to hear that! I'm fortunate enough that this was the fix for me. However, knowing what I know now, if some third party device can affect casting from SXM then I can only assume maybe something else on your network could be affecting it? I had no idea that HA would cause this or even close. Don't know what else you may have installed or listening on your network, but I hope you find out!

do you also by chance use Music Assistant (it's an additional integration to Home Assistant and they both use the upstream pychromecast library).  If so, also try disabling MA since other folks in the github thread have suggested that was required as well.