Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Chromecast not found when trying to configure

Community Member


I have a chromecast 2nd gen that has been working flawlessly for years. Today I couldn't cast to it but it showed in the home app. 


I did a factory reset and the message to use google home app to set up appears on the TV.  In the bottom left corner of tv screen it says chromecast3420.

When I search for new device in google home app on my phone it says it can’t find any devices. I tried connecting the wifi directly to the chromecast, did not help.
I tried restarting the chromecast, my phone, the wifi....nothing helps. 

Any ideas?


Community Specialist
Community Specialist

Hi ElviraB,


Has there been any changes on the router settings or network connection? What is the status of the LED light on your Chromecast 2nd Gen? Try these steps:


Reboot your router/modem, then your Chromecast 2nd Gen and TV. Restarting your phone might also help. After the reboot, do a factory reset on your Chromecast, turn off cellular/mobile data, if you’re using an iOS device then enable the local network access(Phone’s settings>Privacy>Local network of Google Home=enable). Once done, go to your phone's WiFi settings, then connect directly to the Chromecasts hotspot. Open your Home app and try the setup again.


Keep me posted.




Community Specialist
Community Specialist

Hey there ElviraB,

Do you have any more questions or need any additional help? 

Thank you,

Community Specialist
Community Specialist

Hey ElviraB, 

Do you have any more questions that we can address? If not, I'll go ahead and lock up this thread in 24 hours.

Just checking up,