cancel
Showing results for 
Search instead for 
Did you mean: 

Google TV remote forgets the TV programmed to it, and even loses connection of the Chomecast

ungern
Community Member

First time setup was perfect, the Chromecast installed the remote (new batteries, status "Good") nicely, got the update to v26, and I got to set up the remote with my LG TV. Already after an hour or two, the remote forgot the TV commands (IR). On a press of volume up, the white light just slowly started blinking. Read all forums, so I disconnected the remote, reconnected, didn't even register on the Cast. Did a reset, reconnected using the Android app, it got a different BT address (!) actually, then it worked with the TV again after setup. This time I kept it on FW v22.2 to test. In the evening, it didn't even work with the Cast. Batteries out, buttons hold, all the tricks in the book, finally could connect to Cast. Today, it was dead again. It starts the Cast and navigates, but the TV IR isn't transmitting as it should. The TV is still listed in the remote settings. This is the worst user experience I've ever had with a gadget. Besides doing a 59th reset of things, anything else magical worth testing, or just return?

Using the phone as a remote is cumbersome, as it has to be unlocked every time, don't suggest this. The remote should be able to store settings and keep them, not too much to expect I think.

 

PS. The "labels" required in this forum make no sense. Not releated to any of iOS or Android, nor to "issues casting" or similar....

17 REPLIES 17

Kjdg
Community Member

I am having the exact same issue.  Hope we get some advice for google hole to re-recognize my TV device.

 

telping
Community Member
I have the same problem, firmware 26,5

ungern
Community Member

OK, until Google decides to fix this (which I hope won't include them saying "The new 4K CCwGT will feature a new remote...." telling us it's just buy a new one to solve this, there's a workaround, if your TV has HDMI CEC control (which most do in 2022).

Found this on Reddit, should work fine for other TV's than LG too. Linking to OP for credits, under r/Chromecast/, post "Can I use my LG CX remote to control Chromecast TV since I lost my Chromecast TV remote", answered by u/Appropriate_Lack_710  

  • To get my other remote (LG's magic remote ... same looks as the screenshot you gave) working with the chromecast through HDMI-CEC I had to:
    -go to the "device connector" screen (within the LG TV settings) and
    -reset the profile the TV was using (it always recognizes stuff incorrectly ... for example, it recognized my CCwGTV as a satellite box).

    So in my case, I went to HDMI 2 and chose reset .. then exited the device connector screen. The device will show as "other", but that's okay and hdmi-cec should work for you ... like the direction pad, the center button (I don't think the scroll works), and the back button.

    If there's an overlay active on your TV (like, if you hit a button and "HDMI 2" shows up as a bar on your screen), just click "back" button and control will resume with the CCwGTV.

Can I use my LG CX remote to control Chromecast TV since I lost my Chromecast TV remote 

ungern
Community Member

Update:
Yesterday afternoon the remote decided to remember the TV's command for volume up/down. This morning it had forgotten again. Distance to TV doesn't matter, I can shine it straight into the receiver, and I have checked that IR is working. On press of volume up or down, the LED lights up and slowly blinks twice.

telping
Community Member

I think I solved the problem in my remote, at least for what I want him to do.

disable hdmi-cec on the chromecast, and use the chromcast remote's infrared 

2 days without problems.

Of course I had to configure the remote control to use the correct configuration for the brand of tv I use.

On tv it was not necessary to deactivate hdmi-cec.

From what I was able to find out, the remote control had configuration losses or blockages whenever I used the hdmi-cec, it sent infrared commands and stopped sending them and then ended up blocking.

I hope it helps until it is resolved at the software / firmware update level.

ungern
Community Member

Doesn't work for me, and besides, the CEC part is actually good to have, as the TV remote can also control the Cast, so whichever you pick up, you're good.

Jeran
Community Specialist
Community Specialist

Hey there ungern,

I'm really sorry that your Chromecast Voice Remote is acting up! This situation sounds pretty frustrating, so I'd be happy to help you figure this out. First, go ahead and follow these steps:

  1. Check for pending remote software updates. Go to Settings Remotes and Accessories Remote update Continue. The remote might briefly disconnect during the software update.
  2. Forget the Chromecast Voice Remote. Go to  Settings Remotes and Accessories Chromecast Remote Forget.
  3. Pair the remote. Go to  Settings Remotes and Accessories Pair remote or accessory, then follow the instructions on the TV.
    Note: If applicable, the customer can also press the button on the Chromecast device for one second to start to pair.
  4. Remove, then replace the batteries in the Chromecast Voice Remote.
  5. If the steps above don't work, perform a factory reset.

Let me know if those steps help or if you had any other questions or concerns.


Best regards,
Jeran

ungern
Community Member

Hi Jeran,

I've done all that, and more. Even after the double factory reset, the remote just gives up on being connected. My LG TV is not even possible to control via IR anymore, the remote doesn't emit IR signals, it doesn't even light up the white LED on button press.

This morning, working fine for a while, pressing Voice assistant button just disconnected the remote from the CCwGTV, leaving me to stop the YouTube clip using other means. This remote is a complete piece of junk. 

ungern
Community Member

Yesterday I gave up, and returned the CCwGTV and got a new one. This time everything worked like a dream all day, volume of TV was controlled via IR successfully, no misbehaviour.

I get up this morning, the power button wakes the device and turns the TV on via CEC. Clicking the volume buttons make the remote LED blink twice quickly and twice slower pulsating, no volume change on the TV. Also, the remote stupid responding to any other buttons (D-pad, back, etc.) for 5-10s. What the hell is wrong with this FW?! 

Remote is updated to 26.0.

ungern
Community Member

Actually, the Voice command button also results in the exact same behaviour. The cast shows Speak now.... notification on screen, the LED flashes a described earlier, no data sent to the CCwGTV and the remote dies for 10s. This is not related to the TV at all! This is a remote/CCwGTV thing.

telping
Community Member

I think the problems also remain, less often but they are there.

in a week with it blocked twice trying to move the volume, one time the power button did not work I had to remove the battery that is next to the volume buttons and it worked again.

meanwhile we bought two more CCwGTV HD for my daughters the problem persists including 10 second stops without being able to move the menus and the volume buttons with the same problem as the first CC, mine is connected to a samsung without hdmi-cec and these last two of my daughters are connected to an lg tv of the same model with hdmi-cec activated.

even so, I think that the one that doesn't have hmdi-cec activated has less problems.

both have the same firmware 26.5

seems to be a firmware issue, related to switching between system commands sent via bluetooth or infrared.

telping
Community Member

I just saw the video and the symptom is the same on my remote controls, led flashing like that

ungern
Community Member

Today I saw, while in the CC menu - Settings - Remote, seeing the Voice remote "Connected", when I clicked the input button (lowest right) which should switch input on the TV via IR, after blinking LED, the remote status in the menu changed to "Disconnected" after a few secs, then reconnected and again stated "Connected". Yes, Google has to address this...  @Jeran 
I can't even program again the buttons for volume/input after re-adding the TV to the remote after "forgetting" it. Major bug.

ungern
Community Member

Video of the actual disconnect happening when trying to send IR command.

https://drive.google.com/file/d/1k8S2cpzh5KN0hRZx8BvHcaCXuXquODQM/view?usp=share_link

Jeran
Community Specialist
Community Specialist

Hey there ungern,

 

Thank you for your patience on this; I appreciate it. This is a pretty strange bug, and I think it would be best if you spoke to Chromecast Support regarding it. If you don't mind, would you be able to fill out this form to have Chromecast Support reach out to you? They would have the tools to dig a little deeper to find out what's happening here.

 

Best regards,

Jeran

ungern
Community Member

Hi,

I've done that. Just received a replacement unit (my 2nd replacement) and am setting it up. I did actually test the new remote with the existing CCwGTV, and the disconnect manifested itself within two minutes. It's a shame though that the new remote is poorly assembled and the snap fittings display gaps.

I'll still report back here with my findings, regardless of "now all is good" or "fail again". If this unit also exhibits the same problem, support will escalate this issue to the SW department. I have a sense of this being somehow bizarrely related to the coding for LG TV, as other people are using the IR with no problem.