cancel
Showing results for 
Search instead for 
Did you mean: 

Having to hit cast twice

Jambo04
Community Member

Hi,

Ive used Chromecasts for years but have found that with the Google TV dongle I frequently have to hit "cast" twice in order to get my show to play. 

This is especially true when the TV is off and I'm using the "cast" function to both turn it on and play my show. It's almost like you cast once to turn things on, then have to cast again to get the app to open and for it to play the show. 

This was never a problem with the old models and it is common to both me (android) and my wife (iOS). It is the same across different apps (Netflix, Amazon, Disney) etc. 

I know many others experience this same problem, how has this not been addressed? The latest blog post about improvements does not even mention it. 

At this stage I am looking at downgrading to an older model of Chromecast without Google TV. 

28 REPLIES 28

Ashepherdson
Platinum Product Expert
Platinum Product Expert

I run into this occasionally, only on one specific Chromecast that I know for a fact has a weaker wifi signal than my others.  Can you try moving the Chromecast temporarily to see if improved signal fixes this ?  

Jambo04
Community Member

It's on the TV next to the router and we have Google WiFi hubs, deffo not a signal issue. Besides when a prior gen Chromecast is plugged in there it doesn't have an issue.

Ashepherdson
Platinum Product Expert
Platinum Product Expert

Okay that helps, at least we can take that off the possibilities list.  So it's a CCwGTV unit that's not always accepting the cast command.  When you hit cast for the first time, does anything appear on the screen at all?  I know with mine sometimes I see a grey box show up on the homescreen which has some text along the lines of "receiving casting stream" or something similar.  If I select that, the cast begins.  If that's what your seeing then I suspect it's simply a software issue, and hopefully the Google team will address that with upcoming software patches.  

 

Jeran
Community Specialist
Community Specialist

Hey there Jambo04,

I'm just checking up on this thread, did you have any more questions or need any additional help? 

Thank you for helping out on this thread, Ashepherdson!

Best regards,
Jeran
 

Jambo04
Community Member

Hi Jean,

Thanks for checking, no this issue is ongoing. I've literally just had it again where I've had to hit "cast" once to turn the TV on and then again to make the app (in this case Amazon prime) open up before anything would play. 

At a stage where if I still had my told Chromecast model I would have swapped back! Could it be an issue with my particular device? I have tried a hard reset. 

 

Jeran
Community Specialist
Community Specialist

Hiya Jambo04,

 

I'm sorry to hear that you're still experiencing this issue! Out of curiosity, does this only occur with the Amazon Prime app, or all apps? Also, are you able to test it from another device, such as a computer or tablet, to see if the problem persists? That way, we can narrow down the issue a bit more.

 

Best regards,

Jeran

Jambo04
Community Member

@Jeran wrote:

Hiya Jambo04,

 

I'm sorry to hear that you're still experiencing this issue! Out of curiosity, does this only occur with the Amazon Prime app, or all apps? Also, are you able to test it from another device, such as a computer or tablet, to see if the problem persists? That way, we can narrow down the issue a bit more.

 

Best regards,

Jeran


Yep all apps, all devices (iOS and Android and desktop). 

It's like the Chromecast needs one cast attempt to wake itself up. Then another to actually cast. 

Jeran
Community Specialist
Community Specialist

Hey there Jambo04,

 

Does your TV have any power-saving options enabled that may be affecting the powering on via HDMI-CEC? I have a Vizio TV that has a Power Saving Mode that cuts power to the HDMI ports, so I would have to cast twice for it to register what I am trying to do. 

 

Best regards,

Jeran

JenniferV
Community Specialist
Community Specialist

Hi Jambo04,

 

It's us again. How's it going? Did you manage to get your device working?

 

Thanks for the help here, Jeran.

 

Regards,

Jennifer

JenniferV
Community Specialist
Community Specialist

Hello there,

 

We haven't heard from you in a while so we’ll be locking this thread if there’s no update within 24 hours. If you're still experiencing problems, please feel free to start a new thread and we'll be happy to help.


Thanks,

Jennifer


@JenniferV wrote:

Hello there,

 

We haven't heard from you in a while so we’ll be locking this thread if there’s no update within 24 hours. If you're still experiencing problems, please feel free to start a new thread and we'll be happy to help.


Thanks,

Jennifer


Sorry I hadn't had a chance to reply. But I know that I'm not the only one with this issue, see the thread here. 

 

https://www.reddit.com/r/Chromecast/comments/vxzwz3/ccwgtv_having_to_cast_twice/?utm_medium=android_... 

JenniferV
Community Specialist
Community Specialist

Hey Jambo04,

 

No problem at all. could you please try to plug in the Chromecast into a different HDMI port on your TV? Also, if possible, try to plug in the Chromecast into a different TV screen and check if the same issue persists. 

 

Thanks,

Jennifer

Hi. I just recently purchased 3 new CCwGTV units, and updated all to the latest firmware.

The two-times-to-cast problem occurs on all my units, for all apps, of which I primarily use Sling, Prime, DirecTV Stream. 

I'm happy to hear of others who find this two-times--to-cast annoying. I was about to revert back to my previous ChromeCast Ultra units.

Bill Adams

JenniferV
Community Specialist
Community Specialist

Hello there,

 

BillAdams, I'm sorry to hear that you're also experiencing the same issue with your Chromecast. Have you already tried the suggested steps provided in this thread? If yes, how was it?

 

Jambo04, how's it going? did those steps help?

 

Thanks,

Jennifer

Hello Jennifer. Yes, I performed the steps before I made my post. In addition, this problem occurs when attempting to cast to all 3 of my televisions. This problem was not evident with the previous ChromeCast devices, both original version and Ultra.

Thank you,

Bill Adams

JenniferV
Community Specialist
Community Specialist

Hi BillAdams,

 

Yikes! We'd like to take a deeper look into this — could you fill out this form and let us know once you're done?

 

Thanks,

Jennifer

Hi JenniferV - I have good news to report. As I sat down to fill out your form, I began the testing process to ensure I duplicated the steps and apps I have been using.

Coincidentally, this morning I upgraded my iPhone 12 Pro Max to iOS 16. I no longer have casting problems with any of my 3 ChromeCast with Google TV units. 🤯

I tested each of my apps; YouTube, DIrecTV, Amazon Prime, etc., and everything works as it did with the previous version ChromeCast units.

Apple just released iOS 16 this past Monday.

I am scheduled to receive my iPhone 14 Pro Max this coming Friday. It will come pre-installed with iOS 16. Once I bring it online I'll test with it and report back.

Thank you!

Bill Adams

JenniferV
Community Specialist
Community Specialist

Hey BillAdams,

 

Woohoo! I'm happy to hear that this has been sorted out and thanks for sharing your resolution in the Community. I'll wait for your update — no rush.

 

Best,

Jennifer

Jambo04
Community Member

Hi,

 

No power sharing modes enabled that I know of, certainly has the same power set up as when I use the old model of Chromecast. I've recently switched back to the old model and once again have a properly functioning device. 

It seems like the Chromecast with GTV is just either not as good, or my one is broken?

BillAdams
Community Member

Jambo04, are you casting from an iPhone?

I just found the cast-twice problem was solved for me by upgrading my iOS to 16 earlier this week. 

Bill Adams

Hi sorry no I'm on Android. Have now swapped to the old Chromecast and it works fine. 

 

Any advice on getting a refund from hope for a device that doesn't work as it should? 

BillAdams
Community Member

I have nary a clue about returns. 🤷🏼‍♂️

I had the exact problem you had,  but found it wasn’t a CCwGTV problem. 

Bill Adams

JenniferV
Community Specialist
Community Specialist

Hey there,

 

BillAdams, thanks for the help here.

 

Jambo04, what's the OS version of your Android phone? Could you please check if there are any pending updates on your mobile device? 

 

Keep me posted.

 

Thanks,

Jennifer

Android 13, this was also a problem with android 12, and it's also a problem for my wife with her iPhone so it's nothing to do with that thanks. 

It could be that it's a network problem, bu to again I see no reason why this should be a problem with a new "better" CcwGTV and not an old model. 

JenniferV
Community Specialist
Community Specialist

Hi Jambo04,

 

Got it. We'd be happy to take a look into this for you. Please fill out this form with all the needed information then let me know once done.


Thanks,

Jennifer

JenniferV
Community Specialist
Community Specialist

Hello there Jambo04,

 

We haven't received your form. Were you able to fill it out?

 

Thanks,

Jennifer

JenniferV
Community Specialist
Community Specialist

Hey Jambo04,

 

It's me again. How's it going? Still need help?

 

Regards,

Jennifer

JenniferV
Community Specialist
Community Specialist

Hi Jambo04,

 

Just checking in to make sure that you've seen my response. Please let me know if you still need help as I will be locking this in 24 hours if I won't hear back from you again. Feel free to start a new thread and we'll be happy to help.


Thanks,

Jennifer