cancel
Showing results for 
Search instead for 
Did you mean: 

How to claim the Google Chomecast Gen3

Krittamet
Community Member

something wrong with my Google chomecast gen3 after using for 3 months roughly. At the beginning around 2 months, it work properly!!

screen show on my TV shown like this. It is problem with flat cable?? Display screen is able to display properly when I switch to Live TV.

Can I claim to get new item ??

0A03E148-5342-46C9-9C5F-37C8CA76109C.jpeg

 



1 ACCEPTED SOLUTION

djtetei
Gold Product Expert
Gold Product Expert

First, check the TV HDMI input port is working, by connecting other device to it and observe if it displays the image signal correctly. Alternatively, you can try to connect the Chromecast device to another TV.

If the HDMI port is working ok, reboot the Chromecast device by unplugging it from the main power grid for about 5 minutes then plug it back in.

View solution in original post

3 REPLIES 3

djtetei
Gold Product Expert
Gold Product Expert

First, check the TV HDMI input port is working, by connecting other device to it and observe if it displays the image signal correctly. Alternatively, you can try to connect the Chromecast device to another TV.

If the HDMI port is working ok, reboot the Chromecast device by unplugging it from the main power grid for about 5 minutes then plug it back in.

Hi DJtetei,,

Thanks a lot for your advice. I tried following as your recommendation. Now it become work properly! Again thanks a lot!! 

Jeran
Community Specialist
Community Specialist

Hey there!

It looks like djtetei was able to help out Krittamet, so I'm locking the thread. As always, feel free to make a new thread if you have any more questions or concerns.

Thank you for your help, djtetei!

Best regards,
Jeran