cancel
Showing results for 
Search instead for 
Did you mean: 

Receiver and Chromecast with Google TV

JamesL1
Community Member

Trying to run my Chromecast with Google TV through a Sony STR DN1060 av receiver. I get sound but no video. Any suggestions would be appreciated.

1 ACCEPTED SOLUTION

JamesL1
Community Member

Everything was hooked up correctly but was still just getting sound and no video. I discovered that google home had identified the receiver as a smart speaker since it had come with googlecast and I had run music through it before. I reset the receiver to factory specs and did a reinstall of the chromecast with google tv and everything worked great.

View solution in original post

4 REPLIES 4

Rags
Community Member

Hi James…

hope you had connected your SONY AV Receiver as per instructions of the AV receiver as well as your TV connection instructions. Normally if you connect AV receiver with your TV’s ARC or eARC HDMI port you shouldn’t get any problem with sound. Can you check that.

JamesL1
Community Member

Everything was hooked up correctly but was still just getting sound and no video. I discovered that google home had identified the receiver as a smart speaker since it had come with googlecast and I had run music through it before. I reset the receiver to factory specs and did a reinstall of the chromecast with google tv and everything worked great.

Jeran
Community Specialist
Community Specialist

Hey there JamesL1,

 

I'm glad to hear you were able to get everything working again! In that case, did you have any other questions or concerns we can address?

 

Best regards,

Jeran

Jeran
Community Specialist
Community Specialist

Hey there!

We haven't heard back from JamesL1, and it's been a few days, so I'm locking the thread. As always, feel free to make a new thread if you have any more questions or concerns.

Thank you for your help, Rags!

Best regards,
Jeran