cancel
Showing results for 
Search instead for 
Did you mean: 

Devices appear in two homes

Delong55
Community Member

Hi, I have two homes set up in Google Home Android app. Several (10) devices are showing up in both homes. The erroneous ones show up under "Other Cast devices" in the incorrect home.

Any ideas?

3 REPLIES 3

Juni
Community Specialist
Community Specialist

Hi Delong55,

Thanks for posting here in the Google Nest Community.

I wanted to follow up and see if I could be of any help. A few things: Is this a Nest device? If so, which Nest device? By any chance are you using multiple accounts? If so, have you checked these accounts if this device is linked to any of them? If it’s a third party device have you tried unlinking them from your Google Home app assistant settings? Check these steps below that might help you.

Remove Nest devices from a home:

  1. Open the Google home app .
  2. Tap your device > Settings > Unlink or Remove device > Unlink or Remove.

Remove third party devices:

  1. Make sure the customer's mobile device is connected to the same Wi-Fi or linked to the same account as the speaker or display.
  2. Open the Google Home app .
  3. Tap account (the customer’s initial or their profile picture).
  4. Verify the Google Account on screen is the one linked to the speaker or display. To switch accounts, tap the down arrow icon and then choose another account or Add another account .
  5. Select Assistant Settings and then Home Control.
  6. Under Linked services, tap the home automation partner and then Unlink account and then Unlink.

Check this helpful article too.

Remove Google Nest devices from the Google Home app

Let me know how it goes.

Thanks

Juni

Delong55
Community Member

Hi, thanks for your help.

All 10 devices were "cast" devices, such as Chromecast, Google Home speakers, hubs and nest Wi-Fi hubs.

I see now that the problem has resolved itself. Those 10 devices are no longer mirrored in my second home.

Juni
Community Specialist
Community Specialist

Hi Delong55,

I’m glad your issue is resolved now. I’ll keep this thread open for 1 more day. If you need further help, let me know.

Cheers,

Juni