Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Bought new Nest Protect, setup fails

Community Member



Bought this weekend 3  Nest protect Battery operated devices, downloaded the nest app and started initial setup.
First device was ok.


second device fails all the time, when I ping the IP of the device that has been setup propperly, it fails. self-test true the app cannot be started. in other words after initial setup the device is loosing connection and cannot be contacted again. therefor the second device cannot be added to the nest network.


My Network is of the advanced type.

- Cisco ASA5506 Firewall/ Router
- Cisco CAP2602i Accesspoint
- WIndows AD domain with DHCP and DNS setup


allready tried:

- other accesspoint

-restart of the Cisco Accesspoint
- Reset Nest App
- reset NEST protect devices and start over
- Tried other VLAN outside my Microsoft Domain and DHCP (but with Router DHCP activated)


I cannot say that I don't have any know-how about Computer IT, but this thing is at this moment the biggest rubbish I have bought if a newbe should be able to install them...

During setup I have seen a varaity of error codes: P018, P008, P024, P023, P030 
bottom line is, only the first can be setup (but looses connection) the other 2 cannot be added.

Please help me, Or should I send them back?


Community Specialist
Community Specialist

Hi fonstein,


Thanks for reaching out here in the Community and for sharing the steps you’ve done to resolve this issue. There are still some steps that you can do to pair your Nest Protect back to the Nest App. Just a reminder, the Nest Protect can only connect to the 2.4Ghz bandwidth of the internet. 

Give these steps a try:

  • When setting up multiple Nest Protects they should be placed on a table near your Wifi router.
  • Perform a reset to factory default.
  • While pairing they should have a blue light pulsing, indicating that they are ready to be set up. If not, just press it one time. 

If the issue persists:

  • Make sure Bluetooth is on. Turn Bluetooth off, then back on to refresh the connection.
  • Put the mobile device on airplane mode, then turn on Bluetooth and Wi-Fi.
  • Restart your phone and your Wi-Fi router.
  • Reset the joining device to default.

Keep me posted.




Community Specialist
Community Specialist

Hey there,


Checking in — did you get a chance to try the troubleshooting steps shared by Emerson? If so, how did it go? Let us know if you need anything else.


I appreciate your help, Emerson.



Community Specialist
Community Specialist

Hi there,


Just checking in to make sure that you've seen our responses. Please let me know if you have other questions or concerns as I will be locking this in 24 hours if I won't hear back from you again. Feel free to start a new thread and we'll be happy to help.




Community Member

Take a scroll thru a few pages of this protect forum, and you'll see problems with devices, Google failing to process warranty claims, replacing devices with 7 year old units, etc. I would return while you can and find literally any other linked smoke alarms. 

Community Member

So I have a Update.


Made a New network on a simple WiFi router, on a Separate WAN IP address i have (5 in total)
now they work. So the problemis that when they are behind my Cisco ASA 5506 then they Fail.

With a simple costumer device they work....

So now I must find out why they fail behind the ASA firewall

Community Member

Hi Fonstein and Nest Support,

I got nothing to add here. I'm in IT myself, have some pretty good knowledge when it comes down to troubleshoot, but I got the exact same issues. I'm not using an ASA tho.

Edgerouter 6P v2.0.9-hotfix.6

Unifi AC AP Pro Access Point

My "IoT" vlan only broadcasts on 2.4Ghz; Bluetooth enabled; Mobile data disabled; Practically sitting on my Access Point; reset everything what there was no reset; Created a new House in the Nest App; Removed Thermostat from the app; and a whole lot more. I think I spent about 4 hours on this issue and it's starting to become a real pain!

So to summarize:

Pairing the first unit is not a problem. Tried both units individually, both units work. As soon I'm trying the pair the second one, it's gets to the "Setting up the Nest network" dialog before it is able to finish. So far I received errors P003, P021 and P018. It would be very helpful to know what is actually going on. 

Each time I'm trying to add the second Nest Protect, I'm getting a different result in error codes. And none of them are right. I tried about every combination, ending up with the same result.

For testing I have ALLOW_ALL policies between all my vlans. I can use my normal ssid for my phone, and setting up the Nest Protect in my IoT network. As long you have the correct policies in place this is NOT a problem. But just to follow the advice here, when I'm using the IoT ssid on my phone as well, it does not make any difference.

I have no doubt this is something in my network, and I have no problem to resolve it myself, but without a proper code and solution (and please don't give me any restart or reset advice), I am unable to resolve this.

So for starters:

1. I would like to know on a network perspective, what is needed for Nest Protect to work. Is ipv6 required, do I need to enable multicast on my router?

2. My Nest Protect is running firmware If not mistaken there is a new firmware available, but it's not possible to manually download and install the new firmware. What the F# Nest? My Nest Protect V2 was connected over 24h and still not getting the firmware. Where is to update firmware button??

3. I can change the spoken language but it's getting applied within a few days (days?). Why not instant.


So basically, my experience so far with Nest Protect V2: I am absolutely not happy. Setting up is a pain, the app sucks, the error codes sucks and all documentation points absolutely nowhere. 

Now, please proof me wrong. Let me know what I've missed. Give me some specs how my network should look like. Which option did I forget?

Same story as fonstein, will return everything if I don't get this working. These units are way too expensive to be such a pain to install.

I'm waiting for your reply Nest Support.

Community Member

When creating a second house in the Nest app I can pair both Nest Protect devices, but of course these are not linked. One of these 'houses' already contained the Nest Thermostat so that is not a problem.

Will try to keep these online for the weekend and see if we are getting a firmware update.

Community Member

I got my issue resolved. Found a way to trigger the firmware update.

Keep button pressed for 5sec until you hear a message regarding network settings. That should trigger the Nest Protect to update itself! In my case I got both units updated in their own house within Nest app.

After that I reset the second Nest Protect to factory default. Switched back to my first house with my thermostat and nest protect and added the second Nest Protect without issues. 

In between I did changed nothing on my network. I am quite sure this is a bug in the firmware I was running.


Now: 3.5rc3

The release notes do not mention anything! 

Well, at least this worked for me, and hopefully for a lot of you guys that are reading this!