Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Protect will not connect to WiFi

Community Member

I purchased my six Nest Protects (2nd gen) a couple of years ago.  Half of them are battery and half are wired.  I eventually got them all connected to WiFi and installed.  Things went fine for a while.  Then one unit would show disconnected from WiFi.  A few days later that one would be fine without me doing anything and another one would show as disconnected from WiFi.  This jumping around continued with eventually all but one of the units showing as disconnected from WiFi.  And one of those units showed no power (wired unit).  I waited a month to see if they would reconnect, but they did not.

I have removed all of the Protect units, removed their batteries and done a factory reset on all of them.  I haven’t had any problems with my ASUS ZenWiFi AX6600 (XT8) WiFi Router (2.4 and 5.0), but just in case I’ve made some changes or confirmed status as indicated below.

  • Router – Confirmed router firmware is up to date.
  • Router - Changed SSID to separately identify 2.4G and 5.0G.
  • Router – By default DHCP lease time is set to 86,400 seconds (over 2 hours).
  • Router - Enabled IPv6.
  • Router - Turned multicast on.
  • Router – Turned off modem and router and restarted them after 30 seconds.
  • Router – Confirmed AP isolated is off.
  • Router – Confirmed MAC address filtering is NOT enabled.
  • Router – Confirmed firewall off.
  • iPhone – Set connection to 2.4G network.
  • iPhone – Confirmed WiFi is working with other apps and devices, including Nest thermostats.
  • iPhone – Deleted Nest app and reinstalled.
  • iPhone – Verified that Nest service works.

I also have two Nest thermostats on a separate Home within the app and they seem to work fine and connect to the WiFi without problem.

After hours of work, I was able to get one Protect connected to the Wifi network.  I have since tried adding each of the other Protects and none of them complete.  The connected Protect shows as working fine in the Nest app, but when I try to connect another Protect it doesn’t appear to be able to contact that connected Protect and the one I’m trying to add doesn’t connect to the Wifi network.  The Nest app will ask for the network, ask for the password, and ask for a room name.  But it always ends up saying Something Went Wrong … couldn’t connect to your WiFi network….  P006(3.10).

Any suggestions would be appreciated.



Community Member

Similar here, KEDavis, except no second home and I don’t have either of my two Protects connected. I have spent weeks off and on trying to connect them. 

Community Member

When I initially connected my Protects I couldn't get them to connect to the same Home within the app as my thermostats were on.  I saw online someone suggested creating a separate Home on the app for them, which worked.  It never has been as easy as they show on Nest's videos.  Took me days to get them on.  I guess I'll have expensive bricks hanging from my ceilings now if cannot connect to the Wifi.  I also noted that other brands of smart smoke detectors have similar problems.  Don't know if they are as persistent as the Protects, but they are there.  Beyond me how you can have dozens of other devices that connect to Wifi without an issue, but these smoke detectors just seem to be a perpetual problem.

Community Member

I found another community member had posted a solution by which you take your nest thermostat, off-line or connect it to a device hotspot. Then they were able to get they Protects connected. Then the Wi-Fi network was changed once connected. This worked for me as well.

Community Member

JeffinBama, I saw that suggestion once before and tried it without success.  Since you were successful with it I tried again using my wife's iPhone to set up the hotspot.  Nest app didn't pick up the hotspot as a wifi network.  I manually added the network name and pw, but then the Protect still would not connect to it.  Same error message.  I suspect the hotspot is using wifi since cellular service in our home is virtually zero and we have to use wifi to connect to cellular.  So the hotspot is probably going through the same wifi as the previous tries.  I cannot figure out why this is.  Seems like it would be something with wifi, but then why do none of the other devices in our home have any problem connecting to it.  If was only one or two Protects, I'd assume the Protects were faulty, but I have six and they all show the same results when trying to add them.  Is a puzzler.