Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Cannot get past error m15 when installing Nest Learning Thermostat

Community Member

I purchased a new Nest Learning Thermostat. Everything appears to have physically installed properly, however I cannot get it to work with the app. I have two wireless networks at home and can connect to either of them just fine when I manually connect to them from the thermostat itself. I then can pull current weather for my zipcode and pulling the logs I see it reaching out to the broader internet. I have tried the following so far and all result in an M15 error.

1. Reset the thermostat many times.

2. Reinstalled the app on a Galaxy S10 phone.

3. Installed the app on a different phone. A OnePlus 9 phone.

4. Tried connecting through two different vendor Wireless AP's

5. Changed one of the networks to 2.4ghz only.

6. Made sure * was whitelisted on the network and disabled all filters.

7. Tried to ensure the software on the theromstat is up to date.

When I tail the logs on the wireless routers and I can see it connected to the wireless network, but it will never register with the app. Not sure what to do next.


1 Recommended Answer

This was resolved for me by setting up my phone as a mobile hotspot and using that to register. Once it was registered I moved it back to my home network and everything has worked fine since. Best of luck.

View Recommended Answer in original post



When you say you cannot get it to work with the app, do you mean the Google Home app, the Nest app, or both?

The Nest app installed through the Play store.

Also what is the exact TD error code associated with your M15? Then check this

The app goes through all the way to the finishing portion and then just hangs. From there it returns error TD009 (18.1). I have tried restarting both the app and the phone and have tried a completely different phone as well.

Ok thanks. Do you have multicast enabled on your router for all devices? The Nest thermostat requires full multicast support.

Multicast is enabled and I have other IoT devices using it that work on the network currently such as Philips Hue lights and a Ring doorbell.

Ok. When you performed item 5 in your original email, was your phone connected to the same 2.4ghz network as the thermostat?

It was. Each time I have attempted to add it to the app I have made sure to add it from the same network. The phone seems to connect to the thermostat and lets me choose a network. From there it tests the network. Then it appears to try and connect. The phone goes to finalizing and then it just hangs there as if it is hanging on the actual registration of the device and appears to timeout.

Interesting. I assume you just bought it? If yes I would just exchange for another one to rule out any possibility of factory defect. 

I see 3 possibilities:

- A factory defect. Easy to rule out by returning it

- An obscure incompatibility with your setup. Unlikely considering your due diligence and all the additional items we covered

- A Nest Thermostat you thought you bought new but that was actually a return. Somebody else set it up with the Nest app and it is actually already registered hence conflicting. This will also be resolved once you exchange it.  

The nest app


nest app


Ok. Do you have any other Nest devices in your house? Like a camera, protect, or other thermostats. 

This is my first Nest device.

Community Member

 am having the exact same issue and error codes.  I have attempted almost every tip on the internet with no success.  The Nest is not new and was working.  After changing the router we have run into this issue.  The router is a dual band router and the 2.4 GHz and the 5 GHz have different names.

This was resolved for me by setting up my phone as a mobile hotspot and using that to register. Once it was registered I moved it back to my home network and everything has worked fine since. Best of luck.

Community Member

Same issue i faced today while replacing a Gen 1 Nest Thermostat with a Google Nest Thermostat.

Device did not recognize any Wi-Fi networks nor was I able to connect to Nest App, I took off the device and moved it closer to the Nest doorbell and other thermostat at which point it detected the Wi-Fi network but still would not connect to Nest App. So I used my iPhone as hotspot, connected to Thermostat and connect it to Nest app vie cellular network. I then installed it back on second floor and switched network to Wi-Fi.. no issues since (fingers crossed).

Community Member

So I've been running into this issue since I had reset my network for like a month. I had recently got my own router, and did some not so average networking things. The issue was the firewall, so before utilizing a hotspot check your firewall settings and/or if your using a PiHole check that as well. 🤦🏾‍♂️ Going to mess around with it more to see if the router outputs a log entry when it blocks the setup of the device.

Community Member

I finally found a simpler solution (courtesy of phxflyboy) to the problem of not being able to get my Nest thermostat setup completed by the Nest App.  My Wifi is fine, the thermostat is online.  I tried starting from factory install, deleting/reinstalling the app but to no avail.  When I got to the point of install where the app takes over, it would ask "what room is this in", then the app promptly froze for minutes.  Happened over and over.

Guess what: at this point, set your phone down and go do something else.  Patience is the key.  It took about 5 minutes, then suddenly, my thermostat install was finished by the app and Google Home recognized it immediately!!  If only the app added one simple sentence at this point:  "this make take several minutes, your app may appear to be stalled".

Community Member

I ended up replacing my Nests with a different brand..

Community Member

I was almost at the point of doing the same thing (after a week of trying to get the thermostats setup the the Nest App and recognized by Google Home).  I am so glad I finally found phxflyboy's solution because it worked!  All Nest needs to do is fix the freeze, or at least tell people in the app that you gotta wait at least 3-5 minutes for it to self unfreeze.