Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Google Assistant suddenly not able to control Nest Thermostat

Community Member

For more than a year, I've been able to use voice commands with my Google assistant (Nest speakers, Android phone) to control my Nest thermostat.

About a month ago, my voice assistant stopped responding appropriately, instead saying "sorry, it looks like that thermostat hasn't been set up yet..." Or "actually, the thermostat doesn't have that capability."
I can control the thermostat just fine using the thermostat itself, or the Google Home app on my phone. It is specifically the voice Assistant which does not work.
I have deleted and reinstalled the thermostat three times. It works correctly for about an hour or so I would guess and then stops behaving the way it should.

Community Specialist
Community Specialist

Hello j_jetson_s,


Thanks for reaching out. This certainly hasn't been easy on you.


Please factory reset your Google Nest speakers and set them up like a new device. Verify if it can now control your Nest Thermostat or if the issue persists after some time.


Keep me posted.






Thank you for your reply and your attempt to help. I did a factory reset on all three of my Nest speakers and added them back into my Home system. That did not resolve the issue.


When I ask the Google Assistant, either with the Nest speakers or my Android phone, it's simply response, "it looks like that thermostat hasn't been set up yet." It has a couple other responses that are different versions of the same thing.


Frustrating as I've done nothing to my Home environment for over a year and suddenly the Assistant cannot control my Nest thermostat. It can read the temperature and the humidity, but otherwise the Assistant tells me that the thermostat is not set up.

I appreciate your time and attention, thank you.

Community Specialist
Community Specialist

Hi j_jetson_s,

Just an additional question, is your Nest Thermostat assigned in the same Home as your Google Nest speakers, and is within a room? Have you tried to restart or reset the Nest Thermostat?


Hello, thank you for your reply and questions.  I just double checked: all of my devices are registered to my home address and all of the devices are assigned to specific rooms. The thermostat itself is in a room with a Mini speaker.


Since this problem started, I have done a factory reset on the thermostat three times.

It will function correctly within my Google Home environment for a few minutes, and then it will stop working with Assistant again.

Community Specialist
Community Specialist

Hi j_jetson_s,


Thanks for trying the steps. Now that you have performed a complete reset to your devices, could you please try saying this command: "OK Google, sync my devices"?


Let us know how it goes.




Thank you so much for continuing to help me!

Embarrassingly, I decided to say "Hey Google, turn off the thermostat" one last time, before asking the devices to sync.  This time it worked! I don't know when or why it started working again, and that's disappointing.

I DID go ahead and ask Google to sync my devices anyway, and it said that job was complete.  So, for the moment, everything is working as expected again.  Thank you so much for your attention and energy!

Community Specialist
Community Specialist

Hi there,


Awesome! We're glad to hear that this is fixed. I'm going to mark this thread as resolved. I'll be locking this thread if we don't hear back from you in 24 hours. Should that happen, feel free to create a new one if you have more questions or other concerns in the future.