Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

2 (only) onhubs as mesh network - tplink suddenly lights off

Community Member
Hi everyone. This is my case:
- devices: 2 onhubs (1 asus 1 tplink)
- starting point configuracion:
-- app: google wifi read-only mode (not migrated to google home)
-- both at the same google account
-- each emitting different SSID
-- different ISP for each
-- both networks working perfectly
so because someone in google decided that my property --that cost me $400-- will be bricked...
goal: to set a "mesh" network up with (only) both onhubs as officially allowed on for the eternity before the inevitable, unacceptable bricking at the end of this year.
- understood (correct me if i am wrong): 
a) that this (final, hopefully eternal) network's settings won't be able to be modified after the armageddon
b) firmware updates wont come
c) renaming connected-device's names, or setting device-priority or changing family-settings will be allowed because those filters are part of the google-home-app and not the routers themselves.
d) more google-wifi points could be added in the future
steps I have done on may 22/2022
1) from google-wifi app network 1 - factory reset asus (waited for completed update) - disappeared from network 1 as expected
2) created a new google account and link it to google home app
3) from google home app - created "home-1"
4) added the asus onhub to "home-1". up-to-date firmaware. worked perfectly.
5) switched off the asus
6) from google-wifi app network 2 - factory reset tplink (waited for completed update) - disappeared from network 2 as expected
- instead of add onhub tplink as wifi-point in "home-1" i did the following (i have red that to be able to add it as a wifi-point i first needed to let tplink updates its firmware as a primary router), so
7) from google home app (same google account) - created "home-2"
8 ) added the tplink onhub to "home-2". up-to-date firmaware. worked perfectly.
now started the problems: 
- as planned, tplink must be "detached" from "home-2" to be able to be added as a wifi-point in "home-1"... (but factory reset wasnt an option because firmware must be the lastest one) so
9) deleted "home-2" expeting that this action will unlink/free the tplink onhub to allow me to add it to "home-1" later
10) switched on the asus onhub - booted and worked as expected (with modem)
11) switched on the tplink onhub - booted and worked as expected (without modem)
tried a lot of times. 
tried moving the tplink to another electricy sockets. 
getting always lights-off after 10/seconds
i also tried to press the "reset" button located in the router, but same thing.
any help or comment will be very appreciated.
thank you very much

Community Member

update: google support declined to provide some help (by chat). the agent was focused to convence me buy a new router. what he didnt understand is that who is going to purchase a new product from a brand that doesnt answer a simple support question ?

well, i could recover my router.

being unppluged, i pressed the "reset" button and while holding it i plugged the router and wait for 10 seconds  (a white light appears) and then unpressed the reset button. then the lights switched off again, but after 15 minutes the router revived and started to wait for a set up process.

the first time i tried this solutions (factory resetting it by hardware) i holded the reset button for more than 15 seconds, and the lights turned on a blink red, so the documentation says that the factory reset wont be achieved.


but the main question remains: now the router is factory reseted and its firmware is not updated.

so what is the procedure to follow to add it as a wifi-point of another google-home network on which its primary router is another onhub...






Community Specialist
Community Specialist


Sorry for the frustrations you're having with the OnHub setup. While the cutoff date is approaching for the OnHub service support, you will still be able to use them after the cutoff if they are already set up for use. You will no longer be able to manage settings after the cutoff, however. With your situation now, I was hoping we would see a bit more input from the community, but it seems as most users have moved onto Google WiFi or Nest WiFi. I think you may be running into a lot of issues still using the old WiFi app, however. With support for the WiFi app completely finished, Home app is the best way to be trying to interface with any devices in your home at this point.

Do you plan to migrate to Home, or are you planning on sticking with the WiFi app? Is there a reason why you prefer not to migrate to Home?


Community Member

Hi @Jeff thank you so much for your answer. some clarifications:

1) i dont use wifi-app anymore. 

2) i tried to set a 2-onhubs mesh using the lastest version of google home app, with also the lastest version of the iOS

3) i also did it with a new, virgin google account to avoid anything that could interfiere with the implementation

4) so a new home and a new network were created. both onhubs where factory reseted.

5) the first onhub was set up perfecty (and actually i am connecting internet throught it)

6) when tried to add the 2nd one google-home app actually detected as a wifi-point and starts the process of creating a mesh network with it, and everything is fine until the last step, where it says that connection could be established (it is!) so it aborts

7) the 2nd router hasnt any issue, because if i set it up as a main router of another network it works perfectly

😎so the problem is the last step of the creation of a mesh using google home app and only 2 onhubs

any idea ?

btw: have you seen my other post ? could you help us answering the questions ?

for some reason me, as the poster, am not able to reply to it anymore. (the message saysSorry, either you cannot reply to this topic or you have not verified your email address by clicking on the verification link in the email we sent you when you registered. If you did not receive an email from us, or need us to resend it, please visit your User Profile page.) (???)

thank you again,





Community Member

I think the same is happening to my tplink onhub doesn’t get recognized in the google home app. I also have older google wifi mesh set up to the onhub. I tried to switch a wifi point with the onhub. Maybe I didn’t wait long enough for it to complete connection. Past few days the onhub is too slow to stream and it doesn’t show or test in the Home app.