Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

After having Google Wifi for years, my internet now drops twice a day apparently due to DHCP

Community Member


I'm not sure why this has happened recently, but everyday at 4:38 PM and again at 12:38 AM, my wifi drops for a minute then comes back. I believe this is due to the DCHP lease going off at this time (12:38), but I'm not sure why it would happen again at 4:38 (unless it is one of the mesh point routers).  I tried to go through the google app to see if I could change this reset time to occur at 3:00 AM (and only happen once instead of twice) but I have been unsuccessful.

Has anyone else had this happen or know of a solution? My main machine is a Windows 10 Home Machine.  It has worked fine for over 2 years then just randomly started.



Community Member

Just bumping to see if anyone can help with this, it is driving me crazy.  Thanks.

Community Specialist
Community Specialist

Hello everyone,

Thanks for reaching out and sorry for not getting back to both of you sooner.

Please make sure that your Preferred Activities is disabled. Change your DNS server and toggle off and on your Nest Wifi Cloud services. Here's the guide: open the Google Home app > Choose Favorites > Tap Wi-Fi > Network Settings > Privacy Settings > Toggle off then on Nest Wifi Cloud services > Save. Once done, perform a 2-minute power cycle and let me know if there are any changes with your network.

Let me know how it goes.


Community Member

Having similar disconnects issue, and on my pc i can clear notice that I have no IP, on apple TV more difficult, but I can see buffering happening and see that while trying to stream google home application is showing no traffic from apple tv and then it gets busrts of traffic causing image quality degradation. Really bad experience with Wifi Pro mesh network. 

I'm not if this helps, but i got this: 


Easdasd:~ rkkkkkk$ arp -a

xxxxxxxx.local ( at f2:c7:25:ab:9e:5a on en12 [ethernet]

? ( at (incomplete) on en0 ifscope [ethernet] ------> Wifi interface

Looks like im getting incomplete ARP from the wifi router... not sure what that means