Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Google Nest Mesh Wireless Router- Lexmark wifi not connecting

Community Member

Hello ,

I have recently bought Google Nest Mesh Wireless Router and successfully setup. It is connecting to all home device like laptop, mobile phone. i have tried to connect with Lexmark color laser printer MC3326 but not able to connect to the printer. The error is got when i tried to setup via Lexmark mobile assistant to google nest Wi-Fi and i received this error -  "Error- An error has occurred when setting up your printer. Check your printer and try again."

I have tried factory reset printer and tried again but still same error. 

I have then tired ,my old Optus wifi router which i was using before this new google nest mesh wireless router and managed to successful connect.


please help


Community Specialist
Community Specialist

Hello RD2189, 

Thanks for posting here in the Community.

A few questions: how far is your Lexmark Color Laser Printer MC3326 from your Google Nest Wifi router? Can your printer connect to both 2.4 GHz and 5 GHz connections? What other troubleshooting have you tried aside from a factory reset? 

Please power cycle your entire network before getting your Lexmark Color Laser Printer MC3326 connected. Let me know if the same message pops up. 

Best regards, 

Community Member

Hello Lovely,


Thanks  for reply.

Yes i have checked and printer can connect to 2.4GHz.

1) i have teied connect printers another wifi modem and it worked and connect straight away.

2) have updated firmware of printer via Ethernet

3) factory reset to printer 

4) Completely setup google nest again after factory reset. NEST connects to all other device except wifi printer .

5) have contacted lexmark and they saying it is google nest connectivity issue with printer.

So currently i have old wifi modem connected to printer wirelessly. So i need print i will connect to old optus wifi modem and rest of the internet browsing i will connect to nest. 

Please help.


Community Specialist
Community Specialist

Hi RD2189,


That certainly isn’t the experience we want you to have and apologies for the delay. A few questions: are you using a modem/router combo from your Internet Service Provider (ISP)? Also, do you have any paused devices?


Since you've tried other troubleshooting steps, kindly give these a shot to see if it works:


  1. If you're using a modem/router combo, set that to bridge mode to avoid double NAT issues.
  2. Make sure that there is minimal to no interference (concrete, bulletproof glass, metal, mirror, etc.) and the points are no more than two rooms apart.
  3. Remove any special characters in your network name and password.
  4. Turn off IPv6:
    1. Open the Google Home app Google Home app.
    2. Tap the Wi-Fi coin  and then Settings Settings.
    3. Scroll down and tap Advanced networking.
    4. Scroll down to IPv6.
    5. Toggle the switch off Toggle button off.
  5. Change your DNS server into on the primary and on the secondary server. Hit the save/ floppy disk icon on the upper right.
  6. Unplug the power from your Google Wifi devices for 2 minutes.
  7. If the issue persists, try factory resetting your network. Take note that this will delete all network data.


You may skip any step that you’ve done already.


Let us know how it goes.