Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Google Nest Wifi Pro setup process and errors

Community Member

Had a terrible time setting up the Nest Wifi Pro 3 pack to replace my old Google Wifi.
Setting up the first unit (router) went smooth - no issues.
But when trying to add additional units and create the mesh network, this failed several times. Units were not able to connect. Tried everything I could think of, including restarting wifi on my phone, rebooting and even resetting the units. They just wouldnt talk to each other.
Eventually I tried setting them up with an ethernet cable between them, and then I was able to add them and create a Mesh network without error message.
But even if Google Home now claims that all three units are part of a Mesh network, I only get internet connectivity from the main router. The other two units are blinking orange, and no devices are able to connect to them - Except if I connect a device to the LAN port on the unit.
Example: Main router is located in the living room. Approx 20 feet away the next unit is located in the hallway. I have a Eufy Homebase hardwired to the Hallway AP (and Homebase is not configured for Wifi)
But the Eufy Doorbell and homebase is working as is should, and I get notified and can view video from the doorbell.
Wireless devices have good coverage in the living room, but not anywhere else in the house, even if in close proximity of the two access points. It seems the two Access Points are not transmitting the wireless network at all. In the basement, where the last unit is placed, I have no wifi coverage, but if I connect a switch to the LAN port, I can hardwire my stationany computer and NAS.
I cannot see any way to fix this. The two AP's are blinking orange, even after restarts (with or without LAN port in use)
And the Mesh network, even if Google Home is claiming that it is healty, does not work.
How can I fix this without spending another 7-8 hours troubleshooting and trying (and failing)?

191 REPLIES 191

Community Member

Seems both access point are in Bridge mode. Is this correct? Seems they should be in Access Point mode (or something similar)

But I am not able to change mode, because this configuration is greyed out.

It is hard to say without knowing more information like any errors you were getting trying to do wifi vs. Ethernet setup. Once the device is setup as an Ethernet connection you cannot change it. I have mine connected via Ethernet and it says "wired" connection and not bridged. 

I'd recommend to remove the APs from the Home app/factory reset them, check to make sure you have the latest update of the app installed, and try to set them up again. Make sure you allow the AP to fully boot and follow the Home app prompts. If you still get connection issues, contact Google Support. They can help you set up the APs and troubleshoot any issues you may be having.

Here's the Google Support article for setting up Nest Wifi Pro APs:  Set up Nest Wifi Pro or Nest Wifi 

Community Member

The error messages I get are when trying to add additional units to the router and create the Mesh network.

These include (translated from Norwegian, so may not be 100% accurate):

  1. Nest Wifi-configuration failed (Something went wrong. Try to start configuration process again)
  2. Wifi-point is out of range (Move Wifi point closer to the router and try again) - It is places in almost free line of sight approx. 20 feet away)
  3. Did not find any units. Make sure the units are turned on and available for pairing (Pop up alert during Mesh network creation)
  4. Something went wrong (Make sure you are connected to the internet and try again)


All these come in sequence while trying to create a mesh network between router and the first access point.

I have tried to restart the AP during the process and waiting until the blue LED starts flashing. Usually the process continues to next step which is "Adding unit to network"

I tried to factory reset the AP only and adding it to the network without cable, and this worked after the 1 error message. But even if the mesh network is created the LED on the AP is flashing yellow. The difference is that yesterday (before reset) Google Home reported that everything was OK and worked properly. I now identifies the AP to be without internet connection.

Tried to read tips and tricks from users (unfortunately Google Help does not provide useful tips in my case), and this seems to be a common issue, but especially with IOS users. I am using a Google Pixel 7 Pro, so I am not sure what I can do.

I thought the next step could be to factory reset all three units, delete my Google Home and reset the app, and then try setting everything up again...

Community Member

I have got the same problem.     Same thing happened when I replaced the points

Hi. My workaround was to set up the hole Nest mesh network with another ISP (used my phone as internet provider through an old router). Then the setup  went fine and then I connected the Nest router to the Altibox router/modem. One ting, I could not use the Home app on my phone when it was sharing internet so I used a second phone for the installation 🙂

Thanks, I will try that:-)

Community Member

Worked great😀👍

Could you please explain in a bit more detail. I am struggeling with the same issue and Altibox and is not an expert. You used two phones. One of them as internet provider via an old router. How did you get internet via the old router? Got some old routers but looks like they need a cable to get internet.

Tar det på norsk jeg 🙂 jeg brukte en USB-C dongle med ethernet plugg mot telefonen. Og da en nettverkskabel mellom dongle og inn på internettporten på routeren. Prøvde å gjøre oppsettet med samme mobil men det fungerte dårlig. Men med Home appen på en annen mobil gikk det fint. Når alt var oppe flyttet jeg bare nettverkskabel fra gammel router til Altibox. 

Hadde en prat med Altibox på telefon i dag. De sier at dette nå skal være løst. 

Jeg satt opp mine bokser hjemme hos noen som har en annen ISP og bare flyttet de hjem så fungerte de etterpå. 

Har ikke tenkte å resette boksene for å verifisere at det nå fungerer å sette dem opp mot altibox 😇

Tusen takk for svar. Da prøver jeg det,

Altibox har tydeligvis fikset problemet. Satte opp 4 stk i dag. Gikk som en lek. Måtte trykke på factory reset knappen på 2 av de , men det regner jeg med kommer av all køddinga jeg har holt på med. Da senker julefreden seg i Horten med topp trådløst nett og jeg sletter annonsen min på der jeg har hatt de til salgs. Takk for tilbakemeldingene. 

I dag gikk det bortimot smertefritt å installere alle tre nodene, dog tok det sikkert nærmere en time før alle oppdateringene var fullført.
Takk til alle dere som har mast og mast på Altibox og Google. 
Jeg må si at jeg opplevde Google support mer på ballen enn Altibox.

Altibox innrømmet aldri at de hadde et problem, hvilket bryter med enhver regel om hvordan man behandler kunder.


Community Member

Facory reset of my Wifi (Google Nest Wifi Pro), deleted my home and created a new one.
Tried to set up wifi again, but after router is set up sucessfully and I am able to connect to Wifi and have internet access, the next unit just won't connect and create the Mesh network. (Same errors as original post)

Decided to delete the wifi and setup my old Google Wifi (1 gen) and this went by without any issues. Following the same procedure, letting the app (Google Home) tell me what to do and when...
Result: No issues. Mesh network created, all client devices connecting without any issues and everything working as intended (and as it did before I decided to upgrade to Nest Wifi Pro)

It baffels me that the new does not work.

Is it because of WPA3 (even if it is disabled by default it seems my Pixel 7 Pro uses it)?

Is it because of IPv6 (I tried to disable it and reboot before adding additonal units)?

I have no idea, but as far as I can research, alot of people have had issues with Nest Wifi, and now it seems the Wifi Pro have inherited these, all tough there are not many reports online (yet).

Google Wifi Pro was released in Norway last Thursday (Oct. 27th), the day I bought it, and I have spent most of the weekend to try to get it to work.

Hoping to get more information and tips, otherwise I will return it to the store.

Community Member

I am in the same boat, with the very same problem, and by scanning for wifi signals found no trace of the two accesspoint, while the master works as expected. All wifi devices in the house can connect to the maste and works, but with slow speed.
The customer care peaple are the real "God dag mann. Økseskaft." type of support.
It is an uphill experience.

Nice to hear that I am not alone, but very sorry that you are struggling too. I think we are on the same level of frustration.

I had expected more from a Google product that aims to be fool-proof and user friendly.

Money spent does not justify the product, so I will continue to use my 1. gen Google Wifi until I find an better product/brand.

OR someone helps me find a solution

Gold Product Expert
Gold Product Expert

Please try the below solutions and let me know if it solves the issue. I would also recommend contacting Google Support (if you haven't already) and log a ticket as well as sending feedback/a bug report through the Home app.

Fix your Google Nest Wifi or Google Wifi network 

Another possible solution that has helped others:

  1. Start setup

  2. Skip QR code

  3. Manually join device network (password is same as device code)

  4. Enter device code into setup

  5. Let mesh setup fail

  6. Unplug device and plug it back in

  7. Wait / click the partially setup WiFi device in the Google home app until it meshes


There is also a known issue setting up the mesh network via the Home app on iOS (if you are using an iPhone): [Updated] Google aware of Nest Wifi point setup issue on iOS ('The operation could not be completed'...

I did try to add the AP manually by joining the device network, instead of scanning the code, but as far as i can tell the result is the same. I still struggle with getting the AP to communicate with the router and establishing the mesh network. By trial and error, rebooting the nodes, manually joining, restarting the process several times, Google Home did report a successful mesh network with three nodes, but only the router had internet access. The two AP's did not broadcast any wifi signal, and LED was blinking orange. (The further away from the router I got, the worse the signal was. In my basement I had no wifi, even if sitting next to the device.)

I think I have spent almost 20 hours and tried "everything" I could think of and what internet says (since this is also seems to be an issue that Nest Wifi (previous version) also have experienced...

Spent 15 minutes (!!!) setting up my old Google Wifi (1. Gen). Using the same process, letting the app guide me and everything went smooth as silk. I have an IT background, and regard myself as tech-savvy, and I am not able to get the new system to work.

I have decided to return the WiFi Pro.

Community Member

Try turning off Private Relay if you're setting up using an iPhone or the equivalent on Android for setting up the second router. 

Thanks for the tip. I am not able to find this setting (or something the resembles) in the Pixel 7 Pro menues. I read that IOS users had the same issues as I have, and that there seemed to be a workaround. Unfortunately I have not found one for the Pixel 7 Pro. (I tried setting up the Mesh network using my Samsung S10+, but got the same errors)

This worked for me. I was using iOS devices running the latest software (no betas) iPhone 14 Pro and iPad Pro (2022). 

Problem Solved:

I was using iOS devices to install the Nest WiFi Pro and had "iCloud Private Relay" on. I turned that off and went through the install process again. The install process went fine no issues, a software update was even installed prior to finishing and going through a Mesh Test. The Mesh test showed "Great Connection" between the Points. 

My speeds are double what they were with the previous nest WiFi and 4 Points. 

Community Member

I am having a similar issue. I was replacing a whole bunch of Apple wifi nodes (all connected via Ethernet) with a 3-pack of Nest WiFi Pro. The first one went in smoothly, followed the app prompts and had no issues. It shows good. I'm trying to connect the other two in the same manner (direct Ethernet connection) and the installation fails on both of them. I did a factory reset of the WiFi Pros, restarted my Xfinity XiFi Modem/Router, without any success. The only help content I can find on these issues is here in the community (not on Google sites).

Community Member


One observation from all my tests and trials is that the Google Home app changes the wifi network between the "Home network"- meaning the wifi network from the Nest Wifi Pro Router to the 
"New device network" - meaning the temporary wifi network of the new device.
Several times my phone ond therefore Gooogle Home ended up on  the Mobile network instead, 
and did not go back to either the "Home Network" or the "New Device Network".
And then the installation process failed after many minutes.

My phone is a Samsung/Android. I have no clue about any "Private Relay", but as far as I understand it is a Apple/Iphone product.


I think you may be on to something, because I also noticed the switching between networks and mobile network during installation, and it always fails when trying to connect to device when not connected to any Wifi network. I have tried to manually restore the connection to either my network, or connection to the "setup" network broadcasted by the unit (by Unit/Device name and code printed underneath). Sometimes I do get further and am able to connect AP to the router, but the Mesh network is not created or broadcasted correctly, even if Google Home reports that all three nodes are part of the Mesh (only the router is actually broadcasting the Wifi signal, like mentioned earlier).
It's really frustration, and the two error reports I sent to Google through the Home app are still unanswered)

On android, it’s called private DNS. 

Private DNS was set to off

Private DNS was/is set to off for me as well

Not applicable

same problem here. Spent more than two hours on phone with support but still no solution

Community Member

I am having the same issues as the OP.

  • Tried two different iPhones, both version 15 and 16.
  • Tried an android device.
  • Factory resetting all routers numerous times.
  • Switching to another router as my primary, to rule out HW failure
  • Took my nest wifi to a friends house to rule out modem failure
  • Tried modem in bridged and un-bridged modes
  • Reinstalled Google Home app

same exact results as OP. Only other thing I can think of is trying another ISP (currently Altibox, who states on their website that they have a non-standard setup for Google wifi)

Not applicable

Got a mail from google today saying there is no fix in the next few weeks, so the question is «keep and wait for fix, or return to google»?

I will return mine.

Already set up my old Google Wifi (1 gen) and it works.

Community Member

I got my 3-pack set up after turning off the "iCloud Private Relay" as mentioned above. My problem now is that the nodes max out at 150mbps. I have wired connection from the node to PC and wireless backhaul. 

The Nest Wifi Pro was a replacement for an ASUS Mesh, consisting of 3 RT-AX92U. That system uses a 2nd 5Ghz-band for bachhaul, and delivers 350-400 Mbps in the same spot as the  Nest Pro (My line is 750) . So far the Wifi 6-backhaul on the Nest Pro delivers lower speeds than the 5Ghz on the ASUS, and the Nests will go back to the store. 

Community Member

I have the same problem, also norwegian. Just want to comment to se if there comes a fix... 🙂

Have the same problems, and I have private cloud set to off, and have also tried to set the 2nd and 3rd ap up with android phone, and it’s no difference.

Hopefully it will become a solution to this shortly.

Community Member

Same issues for me. 

Community Member

Are all you other norwegians using Altibox as ISP? Maybe the problem lies there... 

I’m on Telia, and my main issues got solved by deleting everything (including the home app) and setting everything up from scratch. I get ok speed now, but looking forward to this:

Community Member

Tried deleting everything, including the my home, and reset the Home app (deleted all data, and reinstalled the app), but that did not work for me

Maybe that could be the case. I have contacted Altibox, and they have not heard of this. They have logged a ticket and will investigate if the issue lies with them.