cancel
Showing results for 
Search instead for 
Did you mean: 

Google Nest router upload speed drops over time, but download speed has been consistently good.

SN311
Community Member

Hello, I just got the Google nest wifi router about 10 days ago.   Whenever I run speed test, doesn't matter which site, but I mostly use Bell's, the upload speed would be good, a little over 10 Mbps per my internet plan.   However, if I do it a few times more, the upload speed would drop, so by the 4th of 5 th time it would be down to 6 or even 5 Mbps.

Download speed would remain good regardless of how many times I run speed test.    Is there anything I can do, or should I get an exchange when I am still within the 14 day window?    I have already try the power cycling the modem, the router, and restart network using Google home.   The upload speed would always go back to normal right after I did a "restart network", but as soon as I ran speed test a few times, upload speed would drop again.    

Thank you

9 REPLIES 9

olavrb
Platinum Product Expert
Platinum Product Expert

Have you tried disabling all preferred activities? Worth a try.


I don't work for Google.

SN311
Community Member

I haven't tried that yet but will, if I have to.   I did use the chat help and the agent told me it was because double Nat that slowed things down.   She told me to try using bridge mode on my Bell HH3000 that is a modem router combo, unfortunately that modem does not support bridge mode and their tech support did not know how I can use DMZ and disable DHCP alternative.

Out of frustration, I decided to mess around with the HH3000's settings and the thing locked up, the only way I could try was to factory reset.    After that, the upload slowing down issue went away.   It seemed to have return yesterday so I tried the same trick but on the first two factory reset, problem remained though less severe in the sense that even after doing speed test several times in a roll, upload speed would only slow down to about 6 Mbps at the most.    I then did one more reset, and it has been good since, with download speed consistently = or > 10 Mbps, topping at 10.7 Mbps in areas where my mobile phone is connected to the wifi points via mesh.    The top speed for that, if connected to the Nest router's wifi is 11 Mbps.    I am going to leave it alone for a few days, if the issue return then I'll try your suggestion.

Thank you.

EdwardT
Community Specialist
Community Specialist

Hi folks,

 

@olavrb, thanks for the help!

 

@SN311, how's it going with your Google WiFi? Still need our help?

 

Thanks,

Edward

SN311
Community Member

Not at the moment because the last modem/router factory reset seemed to have fixed it, but only time can tell if the fix would hold, because I don't know how such a reset (details in my response post to olavrb) could have fixed the issue.    Thank you for following up, appreciated.

EdwardT
Community Specialist
Community Specialist

Hi SN311,

 

Thanks for the update. Let us know if it happens again so we can investigate further.

 

Thanks,

Edward

 

SN311
Community Member

Will report back in a few days, if it still works then I think it will continue to work.    

Thanks again

EdwardT
Community Specialist
Community Specialist

Hi SN311,

 

Just checking in. We understand that you might be busy — you can always let us know here if you have more questions and we'd be happy to help!

 

Thanks,

Edward

EdwardT
Community Specialist
Community Specialist

Hi SN311,

 

It's me again, I wanted to check back in to see if you have other questions and concerns. Feel free to let me know if you do. 

 

Thanks,

Edward

EdwardT
Community Specialist
Community Specialist

Hi SN311,

 

Just checking in to make sure that you saw our response. Please let us know if you have any other questions or concerns as I will be locking this in 24 hours.

 

Thanks,

Edward