Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Google nest not connecting with PlayStation Network

Community Member

Ok so weird one here: 


Up until now I’ve had no issue with my Nest and PlayStation.

Over the last 2 weeks my PlayStation 5 will connect to the internet with NAT type 2 but is unable to access the PSN network.  If it does access it, it will drop as soon as I load up a game.  

I connected my PS5 to both my  phone hotspot and my apartment building’s wifi and they both allow me to connect with PSN.  The building’s wifi is the same ISP carrier as mine as well. 

I’ve tried everything.  Factory reset of the nest, static IP addresses, changing DNS servers.  Plugging in via LAN, creating a guest network.

I’m at a loss, especially because the PS5 has no trouble connecting to PSN through a different wifi network and everything has worked fine for years up until now.


Community Member

Same thing happening to me, I also have been experiencing issues with Nintendo store on my switch… on PS5 I can see folks online, and can browse the store, but the connection fails when attempting to download any games in my library.


If I connect directly to the router then I am able to access the PlayStation store and complete downloads. Do I just need to ditch google WiFi at this point?

Community Specialist
Community Specialist


Hi folks,

@BenO13, @Rjchops62, that certainly isn’t the experience we want you to have and apologies for the delay. A few questions: are you using a modem/router combo from your Internet Service Provider (ISP)? Also, do you have any paused devices?


We appreciate you doing the troubleshooting before posting. It helps a lot to narrow things down. To go further, give these steps a try:


Turn off IPv6:


  1. Open the Google Home app Google Home app.
  2. Tap the Wi-Fi coin  and then Settings Settings. 
  3. Scroll down and tap Advanced networking.
  4. Scroll down to IPv6.
  5. Toggle the switch off Toggle button off.


Let us know how it goes,