Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

“Hey Google” not working on Nest Wi-Fi points

Community Member

I bought 1 Nest router with 2 Wi-Fi points. Initially everything works fine after setup. Occasionally one of the Wi-Fi points didn’t respond to the hot word “hey Google”. After plugged/unplugged, it had come back working again usually. However, these couple days both of the Wi-Fi points don’t respond to the hot word, and the usually unplug to fix no longer work. 

here is what I have tried:

- Unplugged/plugged both router and Wi-Fi points

- turn on/off the mic

- Restart Wi-Fi points

- Restart network

- Factory reset Wi-Fi points

- Factory reset network

- Force quit and reopen Google Home app

- All device has latest firmware updated


After resetting everything and setup like new, the mesh test returned great connection on all points, BUT they still don’t respond to the hot word “hey Google”.

A few things I noticed:

- in Google Home app, the icon sometimes has color and has “play music” button; a few seconds later these color dots disappear along with the button. Looks like it lost connection?? Same goes for the detailed settings of the device. Sometimes the UI display; sometimes it lost connection.

- when hitting the play music button, it says “Unable to play music on this device at the moment”. My Spotify account is connected by the way, and plays just fine on my Google Home speaker.

- tapping on the middle area of the point doesn’t trigger anything.

- the points can respond to hot word while setting up, but it says that the assistant hasn’t been setup yet, so I think the mic works just fine. But after a successful setup, it didn’t respond with any word.


How do I fix this?


Community Member

I have the same issue since last week 

I have the same issue for a few days. Tried resetting each point and the whole network but nothing works.

Community Member

Mine happened around the same time as well

Have you contacted support? I contacted them but since I am in Israel and the product is not supported here they would not help me.

Community Specialist
Community Specialist

Hey, everyone.

Sorry for the late response here. It's been some time since this was posted, but I didn't want it to go without it being addressed. For everyone in the thread, are you still seeing this issue, and if so, have you tried any troubleshooting at this point? I've noticed some have tried resets and a few other steps, but if you've tried anything else, please let me know and we can dive deeper into this.


Community Specialist
Community Specialist

Hi, everyone.
As we haven't had any activity here recently I'm going to go ahead and close the thread. If you have more to add, feel free to start a new discussion.

Community Member

Having the same issue

Hi, Are you located in the US? I am in Israel and when I contacted support, they would not provide support since Nesh products are not supported in Israel.

Community Member

Same problem here. Used to work with factory reset but its not anymore. No support here as well. This is kind of suck ><