Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest wifi randomly going offline

Community Member

For the past week my Google nest Wi-Fi go randomly off-line. There have been absolutely no other changes in my network or environment that could cause this. I’ve had no issues prior to this. 

I can see a couple of posts in the forum of a similar vein, has anybody been able to solve this issue? Is it a firmware problem?

I’ve done a full factory reset which hasn’t helped, and in fact seems to have made it worse. 

Setup: Router (firmware 13729.57.27) and 2 points (firmware 1.54.267572)

any ideas?





1,464 REPLIES 1,464

I also am about to scrap the Google hardware for something else. This is clearly a newly introduced software problem since it's affecting so may people with different ISPs and home setups. Google? Hello?

Community Member

Do we have any concrete updates Jeff? It's becoming unbearable having to reset several times and losing connection at key moments throughout the day...

Community Specialist
Community Specialist

Hey, everyone.

I know it's been a while since we discussed this issue here in the thread. We've seen some app updates and small bug fixes over time, so I wanted to raise this back up and see if those here will still seeing the same issues as before or if they were cleaned up by now. I would also be happy to pick this back up for anyone individually that was still struggling with disconnects on their network. If you're still having issues, please let me know.


Community Member

Yes, continual drops of connection

Community Member

Jeff - you can see the entire thread here, right? There are several people who've posted on frequent connection loss in the last week. 

Just for grins, I'll go get my system out of the basement and hook it up again this weekend. I'll then connect my dog's wireless collar to the Google wifi network. It notifies me via text when it loses the connection to the collar or if my dog gets close to the boundary. 

Since switching to Netgear in December, zero notifications of disconnection.

Community Member

This issue hasn't stopped being discussed here, it has been ongoing and I am still having the same issues just this weekend.  Signal drops on the access points constantly.  Nothing has improved.

Community Member

it is still a mother **bleep**ing mess.  Constantly screwed.  **bleep** google


Community Member

Still happening.... in my case.

When you say some "We've seen some app updates and small bug fixes over time..." what does this mean? Are you saying that there has been a new firmware push for routers and mesh points? 

Are you just trolling this desperate and hugely impacted community?

@Jeff - your statement comes across as inconsiderate and belittling of those who have posted here in the past month.  I reset my devices yesterday.  The firmware is still on 13729.57.27; indicating no changes have been pushed in the past several months.


Let me explain my current network setup:

I have an internet connection that goes into a Sophos firewall.  From there, it has a leg into a DMZ on a switch where my servers live.  My desktop has its own direct connection to the firewall.  None of these devices lose connectivity to the internet.  This includes the past 2 months of tracking.  They are all on UPS systems, and have 100% up time since I patched them in November.


My wifi is on its own dedicated connection off the sophos firewall.  Also has a UPS system.  I have tried the other NICs and different cords to rule out any physical topology issues.  My primary device is a google nest wifi router (h2d).  The entire mesh consists of an additional 2 nest wifi routers (h2d), 1 nest wifi point (h2e) and 3 google wifi points (2x ac-1304 / 1x nls-1304-25); for a grand total of 7 mesh devices.  I live in an old farm house with a bunch of out buildings. This setup gives great coverage with “great” or “good” connections between all mesh devices 95% of the time.


The system goes… unresponsive at least once a day.  At least one AP goes unresponsive every few hours.  When this happens and someone is home, they tell the primary router through the google home app to restart the entire network.  When it comes back online 5 minutes later; everything works great, until one of the key hops to where said person is using the wifi goes unresponsive again.


I say unresponsive- because they do become unresponsive.  They no longer respond to pings; no longer pass traffic.  They can still be connected to, however.  Sometimes, they briefly go into a “setup mode”, and you see the setup mode wifi being broadcast.  Sometimes, you get an extra of the “same network name” as what network you expect as if they disjoint from the rest of the network and no longer are part of the wider mesh.


This all leads me to believe you have several bugs.  I’m a senior network engineer by job description.  I bought these back in the day because they were simple and easy to set up.  (I work at work, I don’t want to work at home too)


Help me (and everyone else) by getting this product fixed.  To point out the obvious, it looks like you’re just here to play lip service in a pale attempt to prevent a lawsuit until all warranties are expired.  It… disappointing.  Prove me wrong, please.

Dragged the system put of the box in the basement to check firmware. Same version of firmware,  13729.57.27. Will let it sit on for a day to see if it updates. Ironically, it went out about 10 minutes after being plugged in...

Community Member

Jeff, still having this issue. While I haven't posted before this issue has been ongoing for months. I see the access points go offline and then have to walk around to the 3 and unplug them in order for them to reconnect. Please tell me Google doesn't think this is fixed. 

Community Member

This happened as recently as once or twice a week the last several weeks. Including last week. Reset (unplug / plug) 'fixes' but take up to 10m for wifi and points to come back up. Which is unacceptable and untenable during a work video call or during the work day. Then a few days later the issue will happen again.


Frankly individual trouble shooting isn't going to help, as multiple people on this thread (and other pals of mine with Google wifi have reported to me) have tried that multiple times with Google support. Moving points (sometimes into the same room!!!) Dns settings, ipv6, bridge modes, blame Verizon or ISP, factory reset, use 'less points' (wtf) they have all been tried. 


Honestly there's clearly a fundamental issue with the ability Google mesh to repair itself when it gets into a bad state. This has been ongoing since last fall. Support is aware when we call them but can do nothing. Frankly beyond unacceptable.

We have all asked for more concrete info on what exactly the engineering is saying the issue is, and why it is not a prioritized fix. Can we get any of them to participate in this forum?? This is a production bug that has shipped and has not been fixed for months, I can't believe that's how a product team is being run. 

Community Member

New here but same issues as everyone else.  Drops at least once a day and only a power cycle of everything will fix it for a few short hours.  

Not applicable

It’s happening to me everyday, all day and also in the early evening.  

I have recommended Google WiFi to so many people, and now I’m embarrassed   

Without time to chase this, I’m forced to move to another system. I have chosen to try  eero Pro 6 tri-band mesh Wi-Fi 6 router.  Fingers crossed. 

Thanks for the suggestion, it's been over a year and they still haven't solved this problem.  Wish I could sell the units I have, but I really can't in good conscience sell people stuff that only works partially. 

I had the exact same thoughts! I would love to recoup some of the $ I lost on this flaky system but I will not push it onto someone else. 

I followed the same path as you. A few weeks with the Eero Pro 6 now and so far, so good. Hoping it remains reliable. These systems should be rock solid given how expensive they are! 

Community Member

I don't know how you're monitoring this thread, but there are multiple new comments and replies on this thread daily, because the issue is ongoing and Google has been dismissive and ignorant of the issue in regards to it's customers that have these defective devices. 

Community Member

Still the same issue

Community Member

How can you not see all the current/ frequent comments? Surely you've just somehow missed them all...

Community Member

This is happening daily. It drops in the middle of important work meetings and it out for 5 minutes before coming back online by itself. It’s honestly pretty embarrassing when it happens. 

That was the last straw for me as well. Netflix going out saying "Not Connected" at night was annoying, but when I lost 4 client Zoom calls in the span of a few days in December I gave up and went with Netgear. I documented more than a dozen disconnections a day for one week straight in December with the Google devices.

Since I unplugged Google? Zero outages in more than 3 months with Netgear.

Every month, I heard, "We are aware of the problem and are looking into it." And every month, the fixes don't solve the problem. I pulled the Google equipment out of the basement over the weekend, hooked it up, and within minutes had it disconnect!

Buy something, really anything, else.

Your daily reminder, @Jeff - had to reboot the system again this morning as some devices went unresponsive.  Still no firmware update.  Still a problem.  Do you still need a daily reminder?

@Jeff - this is your regular reminder that this is still an issue even on the new firmware.  I just had to restart the whole network again.  The new firmware did NOT fix the issue.  Please escalate this to your supervisor.

Community Member

Definitely still a problem!

Your regular reminder - I again needed to reset my devices today, including a hard reboot of one of them.  They are on the new firmware.  They still have issues.  Please advise.  @Jeff 

please escalate this issue to your supervisor to be addressed.

I confirm. This is still not fixed !

Community Member

I just started having the same issues.  Rebooting the router only fixes the router signal. All the mesh nodes remain offline  and need rebooted to bring them back online. 

What hardware has anyone changed to that is reliable?

@Jeff - this is your regular reminder that this is still an issue.  New firmware did not fix it.  This thread has not died.  The problem has not gone away.

Absolutely, I can still see a lot of disconnects.

Community Member

How do you notice they things are disconnected? Does it notify you?

@Jeff And this particular thread is not the ONLY one reporting these issues. I was just seeing some other that started separate topic for the same thing. Take a look. 

Community Member

@Jeff how is that possible to have this issue running for such a long time ? We're all wondering if there's an engineering team actually working on this product!

Community Member
  • It must be raining where you are as your bored! Dude this will never be fixed! Jeff isn’t real. He's an AI BOT. Going on 2 years now. 

Community Member

@JeffI have the latest firmware on my nest system.  it has been two weeks so far with no issues.  I hope it continues.  Are you a real person?

Community Member

I’m definitely having this problem… my router wi-fi software version is 14150.43.80

What am I supposed to do?


a reminder that this is still an issue and has NOT been resolved

Community Member

Yes. Nothing has changed. The points drop out randomly multiple times a day and don't come back online. The fact that there is no fix almost a year after first reports is a sad indictment on how Google feels about it's customers.

Community Member

I continue to have the same issue as everyone else. Why must I get rid of this expensive equipment because you can't correct the flaws. The first post about this problem was over a year ago. Your GOOGLE , fix your problems are create a way to get our refund on this equipment.

Community Member

Maybe google team needs to do more googling to find the solution 🤣