Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Random disconnects of Google WiFi with Verizon FIOS

Community Member

I used to have the Verizon WiFi router connected to the Verizon ONT and all was fine.

I then purchased a Google Mesh with 3 units and spread them across the house (Thought I'd get better coverage). Initially, I connected one mesh unit through ethernet to the Verizon router. I configured the mesh as a different WiFi SSID and all worked consistently well for months.

To simplify things, I decided to get the Verizon router out of the way, and connected the same Google Mesh unit directly to the Verizon ONT (Via ethernet). It initially all worked well, and most of the time all works well but every now and then I lose internet. I'm still connected to WiFi, if I ping the GW, the ONT, even the ONT's outbound IP, I get a response. But the next hop is lost and comes back in 10-60 seconds. It is as if some dialer disconnects and reconnects. Some days there are no issues, some times I get 5 disconnects an hour.

Any idea how to fix this before I give up on Google Home?



P.S. I already shipped back to Verizon their routers so I can't really go back to the original configuration. I also hope I can get it to work the way it was suppose to work.


Community Member

I have the same setup and started experiencing the drops recently.  From looking at some other posts, it looks like a firmware update issue.  This is really frustrating.

Community Member

I also started randomly experiencing this issue and have 3 different networks in my house. If I by-pass the Google Wifi, no issues. Connect to Google Wifi and every few minutes I drop packets and drop internet. Ping results show "Request timeout" to local device on my network. 

This also sounds like an issue that's been going on for awhile with no resolution:

Community Member

Community Specialist
Community Specialist

Hi folks,


That certainly isn’t the experience we want you to have, and we apologize for the delay. A few questions: are you using a modem/router combo from your Internet Service Provider (ISP)? What device are you using to set up your network (iOS or Android)? Do you have the Internet on your modem?

You can do a sequential reboot of your entire network and see if that helps, or please perform a 2-minute power cycle on your entire network to re-establish the connection on your connected devices. Here's how: 

  1. Disconnect the power from the modem.
  2. Disconnect the Ethernet cable and power cord from the parent point.
  3. Disconnect the power cord from the child points.
  4. Leave everything unplugged for 2 minutes.
  5. Connect the power cord to the modem then to your router and points.


Also, you can give these steps a try:


  1. If you're using a modem/router combo, set that to bridge mode to avoid double NAT issues.
  2. Make sure that there is minimal to no interference (concrete, bulletproof glass, metal, mirror, etc.) and the points are no more than two rooms apart.
  3. Remove any special characters in your network name and password.
  4. Turn off IPv6:
    1. Open the Google Home app Google Home app.
    2. Tap the Wi-Fi coin  and then Settings.
    3. Scroll down and tap Advanced networking.
    4. Scroll down to IPv6.
    5. Toggle the switch off Toggle button off.
  5. Change your DNS server into on the primary and on the secondary server. Hit the save/ floppy disk icon on the upper right.
  6. Unplug the power from your Google Wifi devices for 2 minutes.
  7. If the issue persists, try factory resetting your network. Take note that this will delete all network data.


You may skip any step that you’ve done already.


Let us know how it goes.


Thanks for helping, mind-hunter!