cancel
Showing results for 
Search instead for 
Did you mean: 

Reconnecting Google Nest to new Virgin router

Steve28
Community Member

I had been using Google Nest through my old Virgin hub. Virgin provided me with an upgraded router, but when I installed it and converted the new router to modem mode I found I could not install the Google nest device at all as the original settings woud not work. Worst still, I could not change the Virgin hub back from modem to router mode as I had not wife connection to do so. I had toobtain an entirely new Virgin hub to connect to wifi.

I want to use the nest again. But I think I need somehow to do a factory reset of my Google nest device, but cannot do so without being able to reconnect the Nest (which I cannot do on the current settings). I cannot risk convering the Virgin hun form router to modem mode unles I am certain that I can make the Google Nest device work and deliver wifi.

Any solutions?

31 REPLIES 31

MplsCustomer
Bronze
Bronze

@Steve28 

I'm not sure whether this will help your specific circumstance, but this is Google Nest Help's page on changing to a new Wi-Fi network: I don't know whether this will help or not, but this is Google's page on changing a phone number on your account: https://support.google.com/accounts/answer/3463280?hl=en&co=GENIE.Platform%3DAndroid

When we upgraded to a new modem/router a while ago, we set the network name (SSID) and password on the new modem/router to the same values we used on the old modem/router, and so did not have to update any of our Google Nest cameras or doorbells (not your situation, I know, but perhaps it would work), as suggested here: https://support.google.com/googlenest/answer/9223711?hl=en#zippy=%2Ctry-the-same-network-name-and-pa...

Jeff
Community Specialist
Community Specialist

Hi Steve28,

I just wanted to jump in real fast to see if you saw MplsCustomer's reply and to see if you still needed some help on this or if you were able to get it sorted out. If you are still needing some help, just let us know and we'll be happy to continue helping.

Thanks,
Jeff

EdwardT
Community Specialist
Community Specialist

Hi folks,

 

I wanted to follow up and see if you are still in need of any help. Please let me know if you are still having any trouble from here, as I would be happy to take a closer look and assist you further.

 

Thanks,

Edward

EdwardT
Community Specialist
Community Specialist

Hi folks,

 

I'm just checking in to make sure that you've seen our response. Please let us know if you have any other questions or concerns as I will be locking this in 24 hours.

 

Thanks,

Edward

Steve28
Community Member

I thought I had responded but perhaps my messages had not got through. The issue is that unless I can be sure that I can log back in to my Nest devices when I change my Virgin router to modem mode, I run the risk of not having WiFi and worse still not being able to convert my Virgin hub back to router mode. I have had to ditch one virgin hub and get it replaced precisely because of this issue. 
So, how can I reset my nest devices to factory settings to be sure I can run wifi through them again??

steve 

Steve28
Community Member

The links provided seem to relate to changing your phone number so do not seem overly applicable to the issues I am facing. 
steve 

@Steve28 

I'm just another customer, and must have misread your original post.

This is Google Nest Help's page on restarts and factory resets on Nest cameras and doorbells: https://support.google.com/googlenest/answer/9252162?hl=en

This is Google Nest Help's page on restarts and factory resets on a Nest thermostat: https://support.google.com/googlenest/answer/9247296?hl=en

This is Google Nest Help's page on factory resets on Google Nest or Home Speakers or displays: https://support.google.com/googlenest/answer/7073477?hl=en

@EdwardT:  Do you have any suggestions for this customer?

EdwardT
Community Specialist
Community Specialist

Hi folks,

 

@MplsCustomer, thanks for the help!

 

@Steve28, With setting up the Google Wifi from scratch, I would suggest resetting all the Google Wifi points first and then resetting the network from the app. You can find the steps on this link on how to reset your Google Wifi points and the network.

 

Thanks,

Edward

EdwardT
Community Specialist
Community Specialist

Hi folks,

 

I wanted to follow up and see if you are still in need of any help. Please let me know if you are still having any trouble from here, as I would be happy to take a closer look and assist you further.

 

Thanks,

Edward

TC8
Community Member

I’m having a similar issue. My Nest router simply doesn’t connect to the Virgin router when in modem mode. I’ve tried factory resetting and even got a new virgin router installed. It’s really frustrating as I have Google wifi points for my a mesh network but can’t use them

EdwardT
Community Specialist
Community Specialist

Hi TC8,

 

Thanks for letting us know. Could you tell us more about what's happening? Are you setting up your Nest router to your Virgin router? What's the light status of your Nest router? Also, are you getting any messages?

 

Looking forward to your response.

 

Thanks,

Edward

EdwardT
Community Specialist
Community Specialist

Hi TC8,

 

It's me again. I wanted to check back in to see if you have other questions and concerns. Feel free to let me know if you do. 

 

Thanks,

Edward

Steve28
Community Member

Hi Edward 

I have managed to connect my Nest hub to the router and also connected one of my three speakers to WiFi via Nest. However the remaining two speakers will not connect to Wifi (but can connect to the mesh). I’ve tried all the suggestions like rebooting the router and reconnecting the speakers  to no avail. Do I need to do a factory reset now? 
Appreciate your advice and support. 
Steve 

EdwardT
Community Specialist
Community Specialist

Hi Steve28,

 

Thanks for the response. What speakers are you trying to connect to your WIfi? Also, are you getting any messages?

 

Thanks,

Edward

Steve28
Community Member

Hi Ed. I have three nest speakers and previously (with the former virgin hub router) I was able to connect all three to the Nest Wi-Fi. This time I can connect just one, and the same message I get in each occasion is “unable to connect to Wi-Fi “. 

I have tried the usual rebooting  of the router and reconnecting speakers but get the same result each time. Thoughts?
Best

Steve 

EdwardT
Community Specialist
Community Specialist

Hi Steve28,

 

Thanks for the update. Are they Nest points with speakers? What's the light status of the points when you try to connect them? Also, what device are you using to set them up? Is it an iPhone or an Android phone?

 

Thanks,

Edward

Steve28
Community Member

Hi Ed. They are two nest points. They blow with a night white light when setting up. I can connect them to the nest but the final step connecting to WiFi always fails on both of them. I am using an iPhone to manage the app. 
the iPhone is running on iOS 15.6.1 so is up to date (as is the Home app). 
Steve 

EdwardT
Community Specialist
Community Specialist

Hi Steve28,

 

Thanks for the response. Are you using a VPN when setting it up? Also, please check if local network is enabled for the Google Home app by going to Settings > Privacy > Local Network.

 

Thanks,

Edward

Steve28
Community Member

Hi Edward

The local network is enabled in Settings. I am not using a vpn.

However, the Virgin router is still active as a router, so in effect there are two distinct routers (and two distinct wifi networks) operating. I cannot think that this would enable one nest point to be connected but not the remaining two.

Best

Steve

EdwardT
Community Specialist
Community Specialist

Hi Steve28,

 

Thanks for the response. Are you using the same SSID and password for both network? If so, I would suggest changing it to a different one. Keep us posted.

 

Thanks,

Edward

EdwardT
Community Specialist
Community Specialist

Hi Steve28,

 

I wanted to follow up and see if you are still in need of any help. Please let me know if you are still having any trouble from here, as I would be happy to take a closer look and assist you further.

 

Thanks,

Edward

Steve28
Community Member

Hi Ed

I have not yet resolved the issue. I cannot connect the additional two nest points to wifi. The SSID and passwords are entirely different. Any further suggestions to resolve this would be appreciated. Best. Steve 

Jhonleanmel
Community Specialist
Community Specialist

Hey folks,

 

@EdwardT, thanks for the helpful responses.

@Steve28, we appreciate you getting back to us, and sorry for the delay. 

 

A few questions: what is the setup network that shows in the Home app? What setup network is printed on the bottom of the points?

 

Try to unplug one of the two points so only one setup network will show up in the Home app.

 

Keep us posted.

 

Thanks,

Mel

Jake
Community Specialist
Community Specialist

Hey Steve28,

 

I wanted to check in and see if you managed to see Mel's post. Please let me know if you have any questions from here. I would be happy to assist, and make sure you are good to go.

Best regards,
Jake

Jhonleanmel
Community Specialist
Community Specialist

Hi everyone,

Just one quick final check in here since activity has slowed down. We'll be locking the thread in the next 24 hours, but if you still need help, I would be happy to keep it open. If there's more we can do, just let me know.

Thanks,
Mel

I’d be very grateful if the thread could be maintained open as the issue remains unresolved and useful suggestions and tips are being generated. 
Thanks

steve 

Jhonleanmel
Community Specialist
Community Specialist

Hi Steve28,

Thanks for getting back to us and I'm sorry to hear that you're still having an issue with your Google Nest Wifi. We'd like to take a deeper look into this — could you fill out this form and let us know once you're done?

Thanks,
Mel

Hi Steve28, 

Checking back in — have you had the chance to fill out the form?

Best, 
Mel

Hi Mel

Thx for the reminder. Form now submitted. 
Steve

Jhonleanmel
Community Specialist
Community Specialist

Hey Steve28, 

We got your form — thanks for filling it out. Keep your lines open as our team will reach out to you via email anytime soon. 

Also, please continue the conversation there as this thread will be locked after 24 hours.

Cheers, 
Mel

Steve28
Community Member

Hi Jake

yes I have tried unplugging as suggested by Mel to no avail.