Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Speed Test and setting up Nest Points in Google Home is kept on failing.

Community Member

It has been a few months with problems with Home App. (I have been using Nest Wifi for 1+ years and just a few months ago it just stopped listing my networks and wifi points anymore). But I tried the factory reset and try setting it up again with no success. I kept on getting failures below.

1) Doing Speed Test inside the Google Home app is failing but using speed test using 3rd party app is working fine.






























2) Adding Google Wifi Point is failing as well.

cannot setup.jpeg


Please help, I've done everything including factory reset, uninstalling, etc2 that the default answer has been in the forums and internet. It's been really really frustrating, I'm thinking that this 2 problem is somewhat connected.


Community Specialist
Community Specialist

Hi, aswininpi.

Sorry for the issues you've been having running speed tests and setting up new points. I am sure that's a really frustrating thing to be dealing with. Let's see if we can get this worked out for you.

It looks like you've tried a good bit of troubleshooting already, including a full factory reset. Thanks for letting me know what you have tried so far. There's one more troubleshooting step I would like you to try. Let's go ahead and toggle your cloud services. The steps for doing so are below.

Open the Google Home app.

  1. Tap the WiFi icon.

  2. Tap Settings.

  3. Select Privacy settings.

  4. Toggle Nest WiFi cloud services OFF and wait for 30 seconds, then back ON.

Once done, close the Home app and perform a full network restart to ensure that the new settings are in place. To do this, I would recommend doing a power cycle on your network.

  1. Disconnect the power adapter and the Ethernet cable from the Nest WiFi router.

  2. Disconnect the power adapter from the Nest WiFi points.

  3. Disconnect the power adapter from the modem. Allow all devices to stay disconnected from the power for 5 minutes.

  4. Connect the power back to the modem only and wait for it to fully back up. All lights should be lit up before moving to the next step.

  5. After the modem is back online, connect the Ethernet cable back to Nest WiFi router's WAN port (globe symbol port).

  6. Connect the power back to the Nest WiFi router and to the Nest WiFi points. Wait until they're all fully back on.

Once you're through these steps, go ahead and try your speed test and setting up new points. If either doesn't work, please come back and let me know and we can go deeper with this. Thanks.

Community Specialist
Community Specialist

Hello, aswininpi.

I just wanted to follow up really quickly to see if we were able to resolve this or if you still needed some help. If there's anything more I can do, please let me know.


Community Member

Hi Jeff,

Thank you for the follow up, I just did the steps above but unfortunately speed test is still failing. Can we please go deeper?





Community Member

The same error happened. 


Community Specialist
Community Specialist

Hey there Aswin, 

Sorry to hear that you're still experiencing issues with this, but I appreciate your willingness to troubleshoot with us. 

For this case, it typically has something to do with the app not communicating properly with the Cloud services and some of the possible reasons are.


1. Double NAT - It happens when you connected your Google wifi to an upstream 3rd party router or to a ‘modem/router’ device, a firewall from these devices are more likely blocking Cloud Services reason for it not to sync properly with the app. If yes, check out these following recommendations.

  • Set a DMZ on the upstream router 
  • If possible, bridge the upstream router. 
  • Disable the firewall and wireless of the upstream router.

If you’re not sure how to do it, we recommend contacting either your ISP or your Modem/router manufacturer.


2. Upstream Switch - If you have an upstream switch, then it may be blocking STP packets which can be another reason for the Cloud Services not sync properly with the app.

  • For unmanaged switch - move it downstream from parent point. (We suggest connecting it to the primary wifi point’s LAN port) 
  • For managed switch - enable BPDU flooding

3. There’s a device that is stuck in device priority- Its a feature from your Google wifi app that will allow you to allot 80% of your internet bandwidth to a single device to a specific time window. If you have a device previously put into device priority that should have been removed from being priority and still showing, then the network might get just 20% of the remaining Internet bandwidth which may cause it to have an unstable connection.


To remove a stuck priority device follow the steps below:


1. Open the Google Wifi App. 

2. Tap the “Settings” tab (3 circle with the gear icon on the top right) > Network & General > Privacy. 

3. Toggle Cloud Services OFF for 10 seconds and then back ON. 

4. Tap the back arrow in the upper left-hand corner twice to get back to the Settings tab. 

5. Tap Priority Device. 

6. Create a new priority device that’s different than the stuck priority device and hit Save. Note: Any time-frame will work as long as it’s a different device than the stuck priority device. 

7. Go back into Priority Device and tap End Priority and then Save in the upper right-hand corner.


Let me know if you need further assistance. 


Best regards, 

Garrett DS

Community Specialist
Community Specialist

Hey, aswininpi.

I just wanted to follow up real quick on this and see if you were able to get this resolved of if you still needed some help here. If there's anything else I can do for you, please let me know.


Community Specialist
Community Specialist

Hi, everyone.

As we haven't had any activity here recently I'm going to go ahead and close the thread. If you have more to add, feel free to start a new discussion.