cancel
Showing results for 
Search instead for 
Did you mean: 

Two Nest Routers, Second Router Bad Connection (won't recognize LAN)

Mahnarchy
Community Member

I have a main house and a guest house in the backyard. I have my Primary Nest Router in the main house as:

Modem -> Primary Nest Router

and a second Nest Router in the guest house connected via:

Modem -> Primary Nest Router -> Unmanaged Switch -> Cat6 Ethernet -> Secondary Nest Router. 

There are also two Access Points in the main house that are connected via wireless Mesh to the Primary Router. 

This has worked well for the past several months. Randomly, none of our routers had internet connection this morning so I reset the primary router. This restored internet to the main house, but unfortunately, now the Secondary Router in the guest house no longer recognizes the Ethernet cable and only attempts to connect via wireless mesh to the main house Router/Access Points. Because they are very far away, this is suboptimal (get only 20 mbp/s speeds compared to 800+ before).

I have tried factory resetting the entire network and setting up each device from scratch using the Google Home app, to no avail. I also tested that the Ethernet cable from the switch to the guest house works and it does; when I plug in via LAN to my laptop I get full speeds. So it's definitely something wrong with the configuration of the Secondary Router. 

 

What am I doing wrong? How do I get the Secondary Router to 'use' the wired ethernet connection? 

Additional note that may help: when I connect via LAN to the Secondary Router using my laptop, it has a 'self assigned IP address.' 

6 REPLIES 6

RT63
Community Member

There are a number of helpful articles for your problem, and you may want to do some searching for additional details.  In the short term, I suggest that you try the following, unplug all of your wifi routers and points.  Then plug in the primary router and switch if you turned that off.  Let it boot.  Check that you have wifi to the primary router.  Then plug in the point in your guest house.  (It is a point and not a router in your mesh network.)  check that you have wifi in the guest house.  Then plug in your wireless points.  

There are a couple of technical responses to other people who had wired and wireless backhaul in their installation.  Apparently, the Google mesh wants all wireless or all wired backhauls, but you can force the mesh if you turn on the wired paths first then the wireless points.  

I hope this helps.

Mahnarchy
Community Member

I tried that just now. Unfortunately it did not work – I unplugged, then re-plugged in the Primary Router, it had connection, all good. 

I then unplugged and replugged in the Secondary Router (point) in the back (with Ethernet connected) and it still tried to connect via Mesh. 

I factory reset the Secondary Router, and tried to initiate set-up, and the operation timed out. 

What else should I try? I've tried every permutation of resetting the network, factory resetting every Router/Point. Losing hope here. 

I'd also note – in regards to the set-up, switches, the Ethernet, etc., nothing was changed from when I was able to use the Secondary Router as a wired backhaul connection successfully before this recent change. In fact, when I test the 200 ft. long Ethernet cable going to the backyard house, it has a perfect signal still.

RT63
Community Member

HI Mahnarchy, you need to unplug all of the points and the main router and have them all powered off at the start of this process.  Then plug in the primary router, then plug in the wired point, then plug in the wireless points.  If you're only power cycling one at a time, it won't work.  Your primary router and wired point must establish a wired connection before the wireless points come online.  Otherwise, your guest house router is trying to connect wireless and the signal can't reach. 

You can check the connection type in the Google Home app / WiFi / WiFi  Devices / click on your guest house point, and then click on the gear to see the "connection type:".  If it says mesh, it's trying to connect wirelessly despite having a wired backhaul.  If wireless points come online first, then all points will have to connect wirelessly and your guest house will fail.  

I don't know why it was working and then stopped, it could have been a software update that rebooted the mesh and the guest house didn't come up first.  

I'm just trying to help.

Mahnarchy
Community Member

Thanks RT63. What you're saying totally makes sense. Unfortunately it seems I have added a new problem.

I was attempting to do what you say by first bringing the Secondary Router into the Main House so it could connect wirelessly to the Primary Router first (the other two APs are totally unplugged). Somewhere in the process of resetting the routers, I got stuck with a 'ghost' Nest Router for the Secondary that is preventing me from setting up the Secondary Router now, so I can't try your suggestion until that gets resolved. 

I tried setting up the Secondary Router under a new Home to start fresh but it still reads as 'connection failed.' I also reset the Nest Router via the button on the bottom. It is flashing white light for set-up, and is recognized by the Home app, but fails when it gets to the "connect to WiFi" stage ("can't connect to device."). Strange, as all day long when I was fiddling with this, I was always able to factory reset and start fresh. 

When I click the old 'ghost' Router, it is unable to find it and delete it (since the actual Router has been factory reset). 

RT63
Community Member

I hope you can get it back to a working state.  I don't recommend factory reset unless you're selling or sending it away, or you're one short step away from throwing it at the wall.  Now, you've compounded the problem with a new reset / setup problem for which I don't have any useful suggestions. 

You might want to search for other posts on reset problems and setup problems.  Good luck.