cancel
Showing results for 
Search instead for 
Did you mean: 

Google Nest Hub Max will not remove from account

sarahu
Community Member

I sold my Google Nest Hub Max to someone else. Before giving it to them, I did a factory reset, assuming it would disconnect it from my devices. They have messaged me with a screenshot of the error code they are getting: "this nest hub max is connected to another account or home". To continue the setup, this device needs to be removed from its previous account. Ask the previous owner to go to their device settings and remove it"

I did this, and the device no longer shows up in my Google Home app or Google Assistant app. But the new owner still cannot get it connected. What is going on here? How do I get it disassociated with my account so they can set it up? Is it just at time lag thing?

10 REPLIES 10

MplsCustomer
Bronze
Bronze

I believe you need to go to the Google Nest Hub Max in the Google Home app, open Settings, and select "Remove device" at the bottom of the screen.  So perhaps you'll need to re-install the Hub so that you cam remove it.

Maybe others in this forum could add more.  I've never had to actually remove a device.

Ary
Community Member

I'm having the same problem I'm trying to sync to my account with the hub max as a 2nd owner. But it keeps saying the previous owner have to log out or delete their account first on this device before I can sync my account. And the previous owner is not responding to me. Help please

Jake
Community Specialist
Community Specialist

Hey all,

 

Sorry for the late reply. I wanted to follow up and see if you are still in need of any help? Please let me know if you are still having any trouble from here, as I would be happy to take a closer look and assist you further. 

Best regards,
Jake

Justin822
Community Member

I’m having this issue and would love help

Tahirsheikh
Community Member

I bought one used like new nest hub max 1 year ago and i reset it and sign up with my account used like a week then i just save it for future cuz i do have other devices now after 1 year I'm trying to use it it's asking previous owner need to remove I'm the previous owner as i used to use it a year ago

Elyn14
Community Member

I’m having the same issue, it was already removed from the previous account and when I try to add, it still says it needs to be removed. Already tried a reset and it’s still telling me the same thing. Help!!! 

Did you recieve any info on your problem.  Having the same issue.

 

Thanks

Chris

 

No, sadly it still gives me the same error message. The display works but the camera feature doesn’t which is pretty sad as it’s a Hub Max that I had purchased for that feature specifically. I had also removed it from my Nest account and it still says it’s associated with one. I can’t reinstall it to it or a new one I create. 

Thanks for the reply.

I spent an hour or so on the phone with Google support team yesterday and have a scheduled call back today(had to escalate the issue).  Hopefully we can get it resolved.  If we do I will post the solution.
 
Cheers
 
Chris

Just got off the phone from Google support.  Some how the issue resolved itself.

First the variables that changed between yesterday and today.

1. I took the unit from my grandmother's to my house 2. it was unplugged for about 8 hours

3. I factory reset (hold down volume buttons for ~10 second) it in the morning, kept it plugged in and went about my morning for about 4 hours. Then I called Google support since I haven't heard from them.

Now for Google support...

Google support asked me to unplug the unit for 10 seconds then plug it back in for 10 seconds, do this 10x consecutively.  After plugging it back in on the 10th time let the unit boot, then do a factory reset (hold down volume buttons for ~10 seconds.)

I was able to go back to my grandmother's account and add the unit to Home.

I was very skeptical about unplugging and plugging the unit back in, but maybe that worked.  Maybe it was another variable.

Good luck