Showing results for 
Search instead for 
Did you mean: 

Google Nest Mini Sleep command

Community Member

Up until the last couple of days I could instruct my mini nest to “sleep in 20 minutes” and 20 minutes later is would stop. But now it although it acknowledges the command, it keeps on playing after the time period. I have tried saying “stop in 20 minutes”  as well as specifying an actual time, but all to no avail. I have two speakers, and they both are doing the same. 
Does anyone know what has changed?

2 Recommended AnswerS


Here’s what support is saying

We have been made aware of reported issues with the Sleep Timer. We’re looking into possible solutions. For the meantime, we would like you to send a feedback about this issue with the steps provided below.

1. Turn on device usage data and crash reports:


  • Open the Google Home app.
  • Select the device card to share feedback about.
  • At the top-right, select Settings and then Recognition and sharing.
  • Turn on Send [device model] device usage and crash reports to Google. (Example: Send Google Home device usage and crash reports to Google.)
    • Note: For iOS devices, turn on Send device usage and crash reports.


2. Reproduce the issue (Try setting a sleep timer). After the issue occurred, send feedback from the speaker device via voice command (OK Google, send feedback) then say the keywords "GHT3 sleep timer not working".

View Recommended Answer in original post

Community Specialist
Community Specialist

Hi folks,


I hope everyone is doing well. We're happy to confirm that we've rolled out a fix for this behavior. Are you still experiencing the Sleep Timer feature issue? We would like to know so we can follow up with the team. 


Looking forward to your responses.




View Recommended Answer in original post

379 REPLIES 379

Community Member

It appears to have worked last night! Fingers crossed for tonight!

Mine is working now, thanks.

Everything is perfect on both of my Nest Mini, but now neither of my Nest hubs will play Radio services like the BBC, they only seem to respond if I specifically ask them to play something on Spotify. 


If I say OK Google, play BBC Radio 1 the Nest Hubs say "I don't understand" and then bring me up a google search for BBC Radio 1.

Same issue. Now requesting the news plays Sky News instead of BBC! WTF? 

Open a new case. I'll add to it.

Well, at least it's not something that I've done. I've got two Nest Hubs, and it's doing the same on both.  I can't play any BBC radio services at all.


Everything is great on my Nest Mini through.

Everything is OK on both of my Nest Mini, but neither of my Nest Hubs can play any BBC radio services. They just search for them on Google. Can other people please try this. I used to just say "OK Google, play BBC Radio 1" and it would automatically play. Now it goes to a google seach.

I am in the UK and I have just asked my hubs to play Radio 2, LBC and Boom Radio (the ones I normally listen to) and they all play the requested station?

Is that with a Hub or a Mini?


My Mini are OK, but my Hubs just do a Google search.

I have Nest Hubs (with the screen)  I have used commands 'OK Google play Radio 2' and also.......BBC Radio 2 and either command works?

I'm still just getting a google search. I get it for any radio station that I ask for. Heart, Capital FM, LBC, anything BBC. Could this be geoblocking? it's been OK for me up until now.

I'll have to pass on your question I'm afraid. I had to look up what 'geoblocking' was? 🙂

I notice that when I ask for a BBC station, the BBC Sounds App screen flashes up for a moment and when I ask for LBC, it accesses it through Global Player. Not sure if this helps?

Community Member

Both my hub and mini appear to be working again.

Community Member

Just tested it.  Fix seems to work fine.  Thanks!

Community Member

UK based and all seems to be working fine again

Community Member


Community Member

Fix worked on both devices...thanks very much for following up and keeping us posted.

Community Member

Thanks for the update Juni. Yes, it is fixed 🙂

Community Member

Hello Juni, sorry to say that on my hub Sleeptimer doesn’t work as did a couple of weeks ago. On my routine ‘Sleeptimer 10’ voice says ‘timer can be set when playing music or audiobook etc’, But it doesn’t work when playing radio!


Rob (The Netherlands)

Community Member


yes you appear to have fixed it it worked this morning 


thanks robert

Community Member

Working again, thanks 👍

Community Member

Fixed for me.  Now working as it should


Thank you! It works again!!!

Community Member

Bravo, so glad to have this back. Thank you!

Community Member

I am still experiencing the issue on my Google home. It just happened last night. It's kinda annoying. Hoping it gets sorted out soon. 

Community Member

Update to my original: This is my Google Home, not a mini. I will try again on my daughters mini. The sleep feature is still not working on my Google Home. 

Community Member

It all works fine for me also.

Community Member

Hello Juni, this message is an addition to my earlier message in which I said the Sleeptimer function doesn’t work with yet:

Until a few weeks ago, the following worked perfectly:

One of my routines was 'Set a sleep timer for 10 minutes' when I said “Sleep timer 10”.

The media currently playing was stopped after 10 minutes. Whether it was radio or Spotify.

Now when I say “Sleeptimer 10” the following text appears on the screen of the Nest Hub 2:

‘You can set a timer when I play music or an audiobook. I'll stop playing after the time you set. Just say something like "Set a sleep timer for 20 minutes" after I start playing your media.

Following up this command, "Set a sleep timer for 20 minutes," sets an alarm that goes off after ten minutes!

On night of  Tuesday 10th/Wednesday 11th the issue seemed to be resolved and I was delighted to have turn off after Xx minutes working again. Sadly just two nights later it appears to have stopped working again!!! Please try to sort as I was so thrilled to have issue resolved.

Hi folks, 


Thanks for updating us with the sleep command working on your devices. For those who are still experiencing the same thing, could you try to reset the device and set it up again? 


Keep me posted. 





Community Member

I did a reset on my Google Nest hub but still it doesn't work.

When I say "Set a sleep timer for 20 minutes," an alarm is set that goes off after 20 minutes!

while previously it would stop the media playing after 20 minutes.

Please solve this! I wouldn't be so hard, would it? With all you clever people.


It was fixed for about 48 hours from 11th Jan and now sadly has stopped working again. So frustrating. Please keep working on it!

I can confirm this is now working for me.

The issue has not been fixed. I have two devices both mini still doing the same thing.

Community Member

I have just tested on my living room speaker. It stopped after the requested time, just 2 minutes for the test. Hopefully it will apply to all 4 speakers.
Please ask the Google Team to google 'regression testing'

Community Member

Hi, I just tested the sleep timer and it seems it works fine now.

Best regards,

Community Member

Mine is working again now!  🙃

My sleep command is now working as expected. Thanks for the fix

however you may want review your regression testing process. This should never have happened

Community Member

Still having the issue intermittently in the last week.

Community Member

Still not working... So frustrating 

Community Member

Have you tried unplugging and rebooting the device. Since the fix came out all of my devices have been repaired. Sorry you are still having issues.